Every Dock has semi black semi transparent rectangle, latte dock hangs

Hello.

Seems like I can't find any solution to this. I tried many docks, but every of them instead of full transparency has a semi-black semi-transparent rectangle under the dock.

Till now I was using latte-dock (which looks nice and has no "rectangle" bug), but if I open more than 7 windows (for example terminal app x7 or more) whole latte dock hangs. I can't click anywhere for 30 sec or even more and it lags like that till I close all windows/apps.

I also tried cairo dock, but same "rectangle" problem. I can't install cairo-compmgr (composite manager). I'm not sure if this is needed to fix "rectangle" bug?

Thanks for any help

EDIT: This is my first post. I'm honestly lost here... I can't even see reply to the person button. I will be happy to edit the post, but I don't have any terminal information. I installed through pamac this time. I'm not sure what is garuda-inxi...

Screenshot:

https://images89.fotosik.pl/570/6120306b4ac6fe96.png

System:
  Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e49052f4-76d2-433c-a915-462daae59dd6 rw [email protected]
    quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 splash pcie_aspm=off
    init_on_alloc=1 sysrq_always_enabled=1 clocksource=tsc tsc=reliable
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock, cairo-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Micro-Star product: GL63 9SD v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-16P7 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E16P7IMS.10E date: 03/29/2019
Battery:
  ID-1: BAT1 charge: 32.2 Wh (74.4%) condition: 43.3/53.4 Wh (81.0%)
    volts: 11.5 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: N/A
CPU:
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1841 high: 1888 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1871 2: 1832 3: 1827
    4: 1830 5: 1829 6: 1819 7: 1841 8: 1862 9: 1810 10: 1888 11: 1877
    12: 1817 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
    vendor: Micro-Star MSI driver: nvidia v: 510.47.03
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191
    class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: modesetting,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet
    vendor: Micro-Star MSI driver: alx v: kernel port: 3000 bus-ID: 05:00.0
    chip-ID: 1969:e0a1 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 1.38 TiB used: 941.27 GiB (66.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Samsung
    model: PM981a NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 15304029 temp: 39.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN520 SDAPNUW-256G-1032 size: 238.47 GiB block-size:
    physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
    serial: <filter> rev: 20140000 temp: 38.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LCM2
    scheme: MBR
Partition:
  ID-1: / raw-size: 238.22 GiB size: 238.22 GiB (100.00%)
    used: 83.42 GiB (35.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
  ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%)
    used: 547 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:6
  ID-3: /home raw-size: 238.22 GiB size: 238.22 GiB (100.00%)
    used: 83.42 GiB (35.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
  ID-4: /var/log raw-size: 238.22 GiB size: 238.22 GiB (100.00%)
    used: 83.42 GiB (35.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
  ID-5: /var/tmp raw-size: 238.22 GiB size: 238.22 GiB (100.00%)
    used: 83.42 GiB (35.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.16 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 49.0 C pch: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 355 Uptime: 9h 26m wakeups: 3 Memory: 31.16 GiB
  used: 8.87 GiB (28.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1886 lib: 511 Shell: fish
  v: 3.3.1 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-02-04
  Last full system update: 2022-02-06
  Is partially upgraded:   No
  Relevant software:       tlp NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Timeshift
  Failed units:            

Hey, it seems like you ignored the forum template. Please provide the info as requested.
It's also pretty hard to guess what you mean by this mysterious rectangle, maybe provide a link to a screenshot showing the problem.

1 Like

Are you sure your compositor is on, it may have crashed?

If you edit your first post to include a garuda-inxi output your thread will be reopened.

Nope :slight_smile:


I move it from #issues-assistance:kde to #issues-assistance:latte-dock

1 Like

Well, that was just answer. Now it's my own problem :slight_smile:

Compositor is opened. I double checked with Open GL 2.0 and 3.1

Was this happening before you installed tlp, because I have seen tlp cause all manner of issues in the past?

If you have your laptop optimized for power saving you may experience performance issues.

1 Like

Headline say "Every Dock has semi black semi transparent rectangle"

But hangs with more than 7 apps open.
So, the developer of Latte Dock is a Member of this forum, maybe he can help :slight_smile: , so I move it to Latte Dock.

1 Like

In the Garuda Assistant in Settings tab:

Performance Tweaks section:

Preload enabled (checked) everything else is unchecked and grayed out beside Performance Tweaks (unchecked, but not grayed out)

Power Tweaks section:

Those below are checked:

Powersave tweaks
Auto-cpufreq
Thermald
Intel-undervolt
Thermald enabled
Intel-undervolt enabled

I never had issues. Default KDE panel works smooth and fast. And that visual bug is in every other dock I tried beside latte :confused:

UPDATE:

I still didn't figure out about other docks, but I know why Latte hangs...

If you add latte dock with Latte Tasks widget it will cause lags (more windows opened and more shortcuts added - more lag). But that would be like 1-2 sec only (I tried with 30+ terminal windows opened). The problem starts if you have any shortcut that leads to NTFS partition. In this case lag will be really huge, depends on amount of windows opened - even 30 sec or longer.

Workaround: instead of Latte Tasks widget just add apps shortcuts as icons. It will be no lag, but a bit less functionality :frowning:

If you use plasma icon only taskmanager dont you get the same issue?

2 Likes

You mean only shortcuts from the "system" right? From apps in launcher, on the linux system partition?

If you have them a lot and you open many apps/windows - you get a bit lag, but like I said it wasn't that big deal (maybe 1-2s delay only).

Is the NTFS partition mounted before you are using these shortcuts? If not, that would explain why you are getting that tremendous lag.

You can set NTFS partitions to auto-mount with the rest of your partitions by adding an entry to /etc/fstab, but it is more complicated than a normal partition and you will need to disable Windows "fast boot".

This will give you the "default settings" fstab entry described in Arch Wiki:

sudo mkdir /mnt/windows
sudo echo "/dev/sdaX /mnt/windows ntfs-3g defaults 0 0" >> /etc/fstab
sudo mount -a

Obviously put in your actual device name for "sdaX".

More: NTFS-3G - ArchWiki

2 Likes

Yes. Since I installed Garuda I have it mounted in fstab, so it's not the reason for lag. I think NTFS (mount.NTFS) itself causing the lag. Anyway, it's no lag now if I don't use Latte Tasks widget.

Still the problem with others docks remains... I don't know, what might causing that visual bug.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.