Even simple Wine games cause loud fan sound on Ryzen

I've recently changed over to a Ryzen 5 2400GE system and I decided to give it a try with Garuda. Videos (inc. H/W acc.) and native games work as expected, but whenever I play a game with Wine on any desktop, even if it's a simple 2D platformer like Darkula, I can hear the fan ramp up massively. I previously had a Core i5-8500T and that didn't make anywhere near the same amount of noise. Has anyone got any ideas why it might be doing that? I thought the Vega 11 graphics were supposed to be more powerful than the Intel UHD 630! If it's any help, I've tried other distros and desktops on the same machine and they also make the same loud noise, so it clearly isn't Garuda specific.

Thanks for any help.

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=95fc1d31-d21c-49d9-a029-0bffe4a18fe0 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: LightDM 1.30.0, SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: HP product: HP EliteDesk 705 G4 DM 35W v: DBXEnabled
           serial: <filter> Chassis: type: 3 serial: <filter>
           Mobo: HP model: 83E9 v: KBC Version 07.D1.00 serial: <filter> UEFI: HP
           v: Q26 Ver. 02.16.00 date: 04/15/2021
CPU:       Info: Quad Core model: AMD Ryzen 5 PRO 2400GE w/ Radeon Vega Graphics bits: 64
           type: MT MCP arch: Zen family: 17 (23) model-id: 11 (17) stepping: 0 microcode: 8101016
           cache: L2: 2 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 51101
           Speed: 3791 MHz min/max: 1600/3200 MHz boost: enabled Core speeds (MHz): 1: 3791
           2: 3792 3: 1516 4: 2358 5: 2538 6: 2648 7: 2398 8: 1743
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
           vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 0a:00.0 chip-ID: 1002:15dd
           class-ID: 0300
           Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: amdgpu,ati
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
           s-diag: 777mm (30.6")
           Monitor-1: DisplayPort-3 res: 2560x1440 dpi: 93 size: 698x393mm (27.5x15.5")
           diag: 801mm (31.5")
           renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.42.0 5.15.2-zen1-1-zen LLVM 13.0.0)
           v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
           driver: snd_hda_intel v: kernel bus-ID: 0a:00.1 chip-ID: 1002:15de class-ID: 0403
           Device-2: AMD Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus-ID: 0a:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Device-3: XMOS iFi (by AMR) HD USB Audio type: USB
           driver: hid-generic,snd-usb-audio,usbhid bus-ID: 2-3:2 chip-ID: 20b1:3008
           class-ID: 0300 serial: <filter>
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Hewlett-Packard driver: r8169 v: kernel port: 3300 bus-ID: 05:00.0
           chip-ID: 10ec:8168 class-ID: 0200
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus-ID: 06:00.0
           chip-ID: 8086:2526 class-ID: 0280
           IF: wlp6s0 state: down mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb v: 0.8
           bus-ID: 2-10:4 chip-ID: 8087:0025 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
           rfk-block: hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 267.72 GiB used: 73.1 GiB (27.3%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB256HAHQ-000H1
           size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
           type: SSD serial: <filter> rev: EXD70H1Q temp: 46.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Blade
           size: 29.25 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
           rev: 1.00 scheme: MBR
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 117.2 GiB size: 117.2 GiB (100.00%) used: 46 GiB (39.2%) fs: btrfs
           dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 61.1 MiB (63.7%) fs: vfat
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-3: /home raw-size: 117.2 GiB size: 117.2 GiB (100.00%) used: 46 GiB (39.2%)
           fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-4: /var/log raw-size: 117.2 GiB size: 117.2 GiB (100.00%) used: 46 GiB (39.2%)
           fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-5: /var/tmp raw-size: 117.2 GiB size: 117.2 GiB (100.00%) used: 46 GiB (39.2%)
           fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 14.64 GiB used: 1.8 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 30.0 C mobo: N/A gpu: amdgpu temp: 62.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 348 Uptime: 5m wakeups: 0 Memory: 14.64 GiB used: 2.76 GiB (18.9%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
           pacman: 1621 lib: 449 flatpak: 0 Client: Unknown Client: garuda-assistant inxi: 3.3.08

I just moved from Xubuntu 21.04 and have noticed similar. Super aggressive clocking (Hell Yeah Brother! (read in Hulk Hogans Voice)) and fan ramping but I suspect that is due to the Garuda tuning for gaming. While the game might be simple I suspect there are some things that are just bringing clocks/fans/temps/noise up just because games aren't something you want to underestimate then ramp up once you're lagging, stuttering and realize the application needs more go go juice.

I'd be interested in what a someone who knows the Garuda guts a tad more has to say but it's not just you.

You could try to nerf it though and see how things perform with
cpupower frequency-set -g ondemand / powersave / conservative and see which works best for you (if any change at all).

1 Like

Thanks very much for your help. I've tried multiple distros now but all have the same result. However, your advice to try 'cpupower frequency-set -g powersave' did the trick! Now I can game without it sounding like an aircraft taking off...

Can you tell me what I need to do to make the change permanent? Thanks again.

Yeah I think a lot of distros are now semi trashed due to kernel changes and a massive chunk of the software ecosystem half-arsedly transitioning to Wayland pipewire concepts.

As for the persistent settings;
sudo systemctl enable cpupower
then you can set in the config
uncomment the governor line #2 and change it to powersave, save.

There is a GUI for cpupower too if you want to do the clicky clicky route.



Yeah, this is the first time I've used a Ryzen machine with Linux and I've found you have to have the bios settings exactly right or the installation won't work (blank screen, lock-up, no USB, etc.).

Many thanks.

That's odd, never had that issue with Ryzen CPU's. Biggest issue I've had was last week where the mobo shipped without actual BIOS support for the CPU model. That said it's certainly not a Ryzen issue, just the biggest issue I've had building a Ryzen machine. Used to have those issues with AMD and Intel both back in the day. Back then you'd have to pull the damned EPROM chip and send it away to be flashed heh. Everything is so easy these days though I was able to flash the board and away it goes.

Either way glad I could help.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.