/etc/fstab don't mount nfs drives automatically

Hello, after some last updates Garuda stop automounting my nfs drives. I have to sudo mount -a after reboot.

System:
  Kernel: 5.18.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=417f187a-a42b-44a5-b6b3-c27517119ed0 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=8f7c97f0-2758-4001-95b0-57f15fb14228 loglevel=3
  Desktop: GNOME v: 42.2 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1300
    serial: <superuser required>
  Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1300 serial: <superuser required>
    UEFI: HUAWEI v: 1.06 date: 09/14/2020
Battery:
  ID-1: BAT0 charge: 16.8 Wh (33.8%) condition: 49.7/54.9 Wh (90.5%)
    volts: 7.5 min: 7.6 model: SUNWODA HB4593R1ECW-22S0 type: Li-ion
    serial: <filter> status: discharging cycles: 181
CPU:
  Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x60 (96) stepping: 1 microcode: 0x8600104
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1396 high: 1397 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: powersave cores: 1: 1397 2: 1396
    3: 1397 4: 1394 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397
    12: 1397 bogomips: 71861
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel arch: GCN 5.1
    process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
    chip-ID: 1002:1636 class-ID: 0300
  Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 3-4:3
    chip-ID: 13d3:5451 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
    s-diag: 686mm (27.03")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0893 built: 2019
    res: 2160x1440 hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76")
    diag: 356mm (14") ratio: 3:2 modes: max: 2160x1440 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_sof_amd_renoir
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.6-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: & Tele RSH driver: rtw_8822ce v: kernel modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-3:2 chip-ID: 1358:c123 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 68.4 GiB (14.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPNPZ-512G-1027 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21117000 temp: 41.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 68.4 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 68.4 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 68.4 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 68.4 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.14 GiB used: 512 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 35.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 338 Uptime: 1h 1m wakeups: 1 Memory: 7.14 GiB
  used: 3.65 GiB (51.2%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: 1364 pacman: 1359 lib: 365
  flatpak: 5 Shell: fish v: 3.4.1 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.19
Garuda (2.6.4-1):
  System install date:     2022-04-09
  Last full system update: 2022-06-24 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            

You have to check journal for relevant messages, to see what is happening exactly.
AFAIK, systemd creates mount units for each entry in fstab and mounts them according to supplied parameters/directives.
It might also help, if you post those lines in fstab, to see what exactly is requested and how.

3 Likes

Thanks for answer.

In journal I see only:
failed to mount /mnt/Toshiba and failed to mount /mnt/Seagate

/etc/fstab:

192.168.0.19:/mnt/Seagate /mnt/Seagate nfs defaults 0 0
192.168.0.19:/mnt/Toshiba/dietpi_userdata /mnt/Toshiba nfs defaults 0 0

Regards.

It sounds impossible to not have more messages. Find the mount unit name and check status with systemctl.

I would suggest you (re)do the manual mount procedure and see if it works manually.
If it has worked in the past with the same configuration, maybe a package upgrade has changed.
Archwiki should be the reference point for setup and troubleshooting.

Unfortunately I have no personal experience on nfs.

1 Like

I would first search for recent bug reports regarding nfs.

Next I would test alternate kernels.

If no progress, then try writing systemd mount & automount units for your nfs shares. It would seem logical that fstab & systemd mount units would behave identically. However, in the past I have found that not to always be the case. I have found when a bug occurs, sometimes a mount unit will work when fstab doesn't, (and vice versa).

No luck on any of my prior suggestions, then give autofs a try:

https://wiki.archlinux.org/title/autofs

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.