Error with the Xfce terminal

Hello everyone,
I downloaded GarudaLinux Xfce yesterday and I installed it only today, after I change the settings of the distribution (wallpaper, sound, police, ...) I tryed to open the terminal to remove some apps pre-installed and each time I try to open the Xfce Terminal I got this error message : ''Impossible d'exécuter le processus fils << >> : Failed to execve: Aucun fichier ou dossier de ce type" (I am french), when I close the erroer window, I can write nothing in the terminal.
I'm probably very bad but please I need help to fix it !

Thanks for any answers,

Mando

P.S. : Forgive my English, like I said it I'm french :wink:

Welcome :slight_smile:

???

Use alacritty until we know more what you all changed. :slight_smile:

Forgive my English, I am german :wink: and I use deepl translator.

2 Likes

Hi there, welcome to the community.

:policeman: :policewoman: :rotating_light:

"Unable to run the > thread process: Failed to execve: No files or folders of this type"

This most probably means somethings wrong with your terminal configuration file, i.e. bashrc/ fishrc/ zshrc.
So, paste the output of inxi -Faz , echo $SHELL as well as relevant configuration file.

1 Like

You can open any system monitor app, and try killing all the instances of xfce terminal & relaunch it. It'll be better if you post everything in English.

New user can't post pictures.
We do not like pictures from terminal or 3840 x 2160 pixel pictures from Screen for single sentence error messages too.

We try to keep the storage space on our servers as small as possible as well as the traffic for backups.

4 Likes

Another option could be to restore the previous snapshot, reboot, restore the default configs with the Garuda assistant and start removing carefully what you need or changing your settings, taking notes of what you do, to see if and where the terminal stops working.
Remember to reboot after removing packages, to get to a (hopefully) stable status.

1 Like

Hi,
Thank you very much for your replies !
I tried all of them but nothing worked, finally I have just removed Garuda and installed it again... All works perfectly !

Anyway thank you for your help !

Have a nice day :+1: !

Mando

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.