Error when updating packages with garuda-update

System:
  Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c970e795-250e-497e-9e1a-9a02045a9887 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: sway v: 1.7 info: waybar vt: 1 dm: greetd Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Laptop 15-db0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 84AE v: 86.30 serial: <superuser required> UEFI: Insyde
    v: F.33 date: 08/17/2020
Battery:
  ID-1: BAT1 charge: 33.1 Wh (84.4%) condition: 39.2/40.9 Wh (95.9%)
    volts: 12.1 min: 11.3 model: Hewlett-Packard PABAS0241231 type: Li-ion
    serial: <filter> status: discharging
CPU:
  Info: model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen level: v3 note: check built: 2017-19
    process: GF 14nm family: 0x17 (23) model-id: 0x11 (17) stepping: 0
    microcode: 0x810100B
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1892 high: 2391 min/max: 1600/2500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2391 2: 2327
    3: 1430 4: 1423 bogomips: 19961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:15dd
    class-ID: 0300 temp: 44.0 C
  Device-2: Lite-On HP Webcam type: USB driver: uvcvideo bus-ID: 3-2.1:3
    chip-ID: 04ca:707d class-ID: 0e02 serial: <filter>
  Display: wayland server: Xwayland v: 22.1.3 compositor: sway v: 1.7
    driver: gpu: amdgpu display-ID: 1
  Monitor-1: eDP-1 model: AU Optronics 0x70ec built: 2017 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 scale: 1 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1366x768 min: 640x480
  Message: Wayland GBM/EGL data currently not available.
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_pci_acp3x v: kernel
    alternate: snd_rn_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 3-2.3:4 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 30.13 GiB (3.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 4C scheme: GPT
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 30.13 GiB
    (3.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 30.13
    GiB (3.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 30.13
    GiB (3.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 30.13
    GiB (3.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.24 GiB used: 824.8 MiB (24.8%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.6 C mobo: N/A gpu: amdgpu temp: 44.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 271 Uptime: 20m wakeups: 1 Memory: 3.24 GiB used: 1.52 GiB
  (46.8%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 2098
  libs: 416 tools: pamac,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: kitty inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-10-10
  Last full system update: 2022-10-15
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:         

The error seems to be related to this signing key:
signature from "Nico Jensch (Chaotic-AUR) [email protected]" is unknown trust

I've tried running the pacman-fix script here:

#!/bin/sh
echo "::file: /usr/local/bin/fix-gpme-arch.sh"
    echo "Thanks to folks at https://stackoverflow.com/questions/48117783/arch-linux-system-update-error-gpgme-error-no-data and other forums"
    echo "#######"
    echo ""
    echo ""
    echo ":: Script to fix GPME error"
    echo ""
    sleep 1
    
    echo "Remove files: /etc/pacman.d/gnupg and /var/lib/pacman/sync"
    echo ""
    sudo rm -rfv /etc/pacman.d/gnupg /var/lib/pacman/sync
    sleep 1
    
    echo ""
    echo "Reinitialize pacman keys"
    echo ""
    echo ":: pacman-key --init"
    echo ""
    sudo pacman-key --init 
    echo ""
    echo ":: pacman-key --populate archlinux"
    echo ""
    sudo pacman-key --populate archlinux
    echo ""
    sleep 1
    
    echo "Update pacman database"
    echo ""
    echo ":: pacman -Fyy"
    echo ""
    sudo pacman -Fyy
    echo ""
    echo "::sudo -E pacman -Syu"
    sudo -E pacman -Syu
    echo ""
    echo ":: pacman -Syyu"
    echo ""
    sudo pacman -Syyu
    echo ""
    sleep 1
    
    echo "GPME fix error done"
    echo ""
    echo "If you see further errors, suggest running: pacman -S archlinux-keyring"
    echo ""
    
    exit 0

Yet the problem persists.

Any help is appreciated.

have you tried update remote fix as mentioned elsewhere in these forums?

2 Likes

This is the go-to document for this issue:

2 Likes

update remote fix did the trick. Sorry for the duplicate question, and thanks for the quick reply. I love Garuda Linux!

1 Like

would it be possible to update the "issues with "marginal trust" " link/faq/tutorials link with the new script update remote fix and others so as to avoid having only those "scary looking" commands be the only reference?

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.