Error when trying to update/reinstall nvidia driver

inxi -Fxxxza output:

System:
  Kernel: 5.10.2-104-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
  root=UUID=02d847ea-a164-4033-a8e0-2a389eb00e1a rw [email protected] quiet 
  splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 
  resume=UUID=84ec478b-2fa6-4043-a851-9ee4be08d485 loglevel=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
  Distro: Garuda Linux 
Machine:
  Type: Desktop Mobo: MSI model: Z170A GAMING PRO CARBON (MS-7A12) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.30 date: 05/12/2016 
CPU:
  Info: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S 
  family: 6 model-id: 5E (94) stepping: 3 microcode: E2 L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54450 
  Speed: 3215 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 3215 2: 3311 3: 3220 
  4: 2426 5: 3401 6: 3051 7: 3400 8: 1984 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: Gigabyte driver: nvidia 
  v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:21c4 
  Display: x11 server: X.org 1.20.10 compositor: kwin_x11 driver: nvidia 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: GeForce GTX 1660 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: NVIDIA TU116 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:1aeb 
  Device-3: Samsung USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 1-1.2:4 chip ID: 04e8:7084 serial: <filter> 
  Device-4: Logitech Webcam C200 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-9:5 chip ID: 046d:0802 serial: <filter> 
  Sound Server: ALSA v: k5.10.2-104-tkg-bmq 
Network:
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e v: kernel 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8192CE PCIe Wireless Network Adapter vendor: ASUSTeK 
  driver: rtl8192ce v: kernel port: d000 bus ID: 06:00.0 chip ID: 10ec:8178 
  IF: wlp6s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 2.27 TiB used: 115.77 GiB (5.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS545025B9A300 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: CA1G 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST31000524AS 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: HP64 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 2B6Q 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital model: WD10EZEX-00ZF5A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 0A80 
Partition:
  ID-1: / raw size: 914.07 GiB size: 914.07 GiB (100.00%) used: 115.77 GiB (12.7%) 
  fs: btrfs dev: /dev/sdb2 maj-min: 8:18 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) 
  fs: vfat dev: /dev/sdb1 maj-min: 8:17 
  ID-3: /home raw size: 914.07 GiB size: 914.07 GiB (100.00%) 
  used: 115.77 GiB (12.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 
  ID-4: /var/log raw size: 914.07 GiB size: 914.07 GiB (100.00%) 
  used: 115.77 GiB (12.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 
  ID-5: /var/tmp raw size: 914.07 GiB size: 914.07 GiB (100.00%) 
  used: 115.77 GiB (12.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: partition size: 17.15 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 maj-min: 8:19 
  ID-2: swap-2 type: zram size: 1.95 GiB used: 1024 KiB (0.1%) priority: 32767 
  dev: /dev/zram0 
  ID-3: swap-3 type: zram size: 1.95 GiB used: 612 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-4: swap-4 type: zram size: 1.95 GiB used: 560 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-5: swap-5 type: zram size: 1.95 GiB used: 620 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  ID-6: swap-6 type: zram size: 1.95 GiB used: 768 KiB (0.0%) priority: 32767 
  dev: /dev/zram4 
  ID-7: swap-7 type: zram size: 1.95 GiB used: 768 KiB (0.0%) priority: 32767 
  dev: /dev/zram5 
  ID-8: swap-8 type: zram size: 1.95 GiB used: 768 KiB (0.0%) priority: 32767 
  dev: /dev/zram6 
  ID-9: swap-9 type: zram size: 1.95 GiB used: 768 KiB (0.0%) priority: 32767 
  dev: /dev/zram7 
Sensors:
  System Temperatures: cpu: 41.5 C mobo: 29.8 C gpu: nvidia temp: 52 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 269 Uptime: 2h 38m wakeups: 0 Memory: 15.59 GiB 
  used: 5.96 GiB (38.2%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1092 lib: 281 Shell: fish v: 3.1.2 running in: konsole inxi: 3.2.01 

When running "sudo pacman -Syu", I get this output:

"warning: cannot resolve "mhwd-nvidia-390xx", a dependency of "mhwd-db-garuda-git"
warning: cannot resolve "mhwd-nvidia-390xx", a dependency of "mhwd-db-garuda-git"
:: The following package cannot be upgraded due to unresolvable dependencies:
      mhwd-db-garuda-git

:: Do you want to skip the above package for this upgrade? [y/N]"

I tried using the hardware configuration settings to reinstall the NVIDIA drivers and got this output.

"Starting

> Removing video-nvidia-dkms...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/local/pci/video-nvidia-dkms/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

checking dependencies...

error: failed to prepare transaction (could not satisfy dependencies)

:: removing nvidia-utils breaks dependency 'vulkan-driver' required by steam

:: removing lib32-nvidia-utils breaks dependency 'lib32-vulkan-driver' required by steam

Error: pacman failed!

Error: script failed!

Done ..."

Any idea on how to fix this?

I guess it is related to

2 Likes

read

please, formated text output
and

:slight_smile:

2 Likes

I updated my post to follow the bug report format.

3 Likes

I got the same problem

@caniko so-called 'necro-bumping' is frowned on here, mainly because things can change massively in a short time.

Please start your own, separate thread :slight_smile:

4 Likes

haha, necro bumping :smiley:

You got it.

This is good, because looking further into it I see that it is very different.

1 Like