Error when trying to install bootloader

Hello everyone.
I premise that I am a beginner in the linux world and decided a few days ago to make the switch from Windows to Linux.
While trying to install Garuda, I had some problems in overwriting the disk with Windows on it, but I completely erased the data on there with dd and it no longer gave me that problem.

However, at that point it was giving me a new problem, which was the inability to install the bootloader

The bootloader could not be installed. The installation command <pre>grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force</pre> returned error code 1.

I also searched here on the forum and saw that others had the same problem as me, but nothing the other users recommended helped me fix the problem. I also tried to chroot, but even then it gives me an error. Does anyone have any ideas why it gives me that error? Should I continue down the chroot path or try something else?

Hi there, welcome to the forum.
Please provide your garuda-inxi from a live USB.
Is secure boot disabled in the BIOS?
Are you in UEFI only mode, as opposed to Legacy/ CSM?


Yes, they are in UEFI mode.

Here is the result of garuda-inxi

  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda root=miso:LABEL=GARUDA_GNOME_RAPTOR quiet
    systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
    i915.modeset=1 radeon.modeset=1
  Desktop: GNOME v: 45.0 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: X553MA v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X553MA v: 1.0 serial: <filter>
    UEFI: American Megatrends v: X553MA.208 date: 07/09/2014
  ID-1: BAT0 charge: 23.2 Wh (97.5%) condition: 23.8/31.7 Wh (75.2%)
    volts: 7.6 min: 7.6 model: ASUSTeK X453-42 type: Li-ion serial: N/A
    status: not charging
  Info: model: Intel Pentium N3540 socket: BGA1155 bits: 64 type: MCP
    arch: Silvermont level: v2 built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x37 (55) stepping: 8 microcode: 0x838
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
    desc: d-4x24 KiB; i-4x32 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 1291 high: 2666 min/max: 500/2666 base/boost: 2160/2400
    scaling: driver: intel_cpufreq governor: schedutil volts: 1.2 V
    ext-clock: 83 MHz cores: 1: 2666 2: 500 3: 500 4: 1500 bogomips: 17333
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-7 process: Intel 22nm
    built: 2012-13 ports: active: HDMI-A-1,eDP-1 empty: DP-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300
  Device-2: Chicony [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-3:3 chip-ID: 04f2:b483 class-ID: 0e02
  Display: server: X.Org v: 23.2.2 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.21x11.22")
    s-diag: 915mm (36.01")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,right model: 27N1
    serial: <filter> built: 2021 res: 1920x1080 hz: 60 dpi: 81 gamma: 1.2
    size: 600x330mm (23.62x12.99") diag: 685mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: left model: AU Optronics 0x20ec built: 2013
    res: 1366x768 hz: 60 dpi: 102 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu
    name: Intel HD Graphics (BYT) driver: mesa intel v: 23.2.1-arch1.2
    device-ID: 8086:0f31 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 128 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:0f04 class-ID: 0403
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.83 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Lite-On driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0036 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.2
    chip-ID: 10ec:8136 class-ID: 0200
  IF: enp3s0f2 state: down mac: <filter>
  Device-1: Lite-On [] driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-4:7 chip-ID: 04ca:3010 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.1
    lmp-v: 7 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 523.75 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000LPVX-80V0TT0 family: Blue Mobile size: 465.76 GiB block-size:
    physical: 4096 B logical: 512 B sata: 3.0 speed: 3.0 Gb/s tech: HDD
    rpm: 5400 serial: <filter> fw-rev: 1A01 temp: 28 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 34d 6h cycles: 544
  ID-2: /dev/sdb maj-min: 8:16 vendor: Netac model: OnlyDisk size: 57.99 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s
    lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: 1100
    scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 3.71 GiB used: 415.8 MiB (10.9%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
    dev: /dev/zram0
  System Temperatures: cpu: 6280.4 C mobo: N/A
  Fan Speeds (rpm): cpu: 2700
  Processes: 202 Uptime: 8m wakeups: 1 Memory: total: 4 GiB
  available: 3.71 GiB used: 2.12 GiB (57.0%) igpu: 64 MiB Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1165 libs: 365 tools: paru Shell: Bash (sudo) v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.30
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
  System install date:     2024-03-10
  Last full system update: 2024-03-10 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:  

Ideally, I’d start updating this.
It can seem a detail, but I remember it solved an equivalent issue recently.
I guess there must be a chance to do it via a bootable USB.
I’d also repeat the whole process, especially using Ventoy, possibly in UEFI mode (if I remember correctly there is this option for Ventoy).
Please provide also

lsblk -f
NAME  FSTYPE FSVER  LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0 squash 4.0                                                                   0   100% /run/miso/sfs/livefs
loop1 squash 4.0                                                                   0   100% /run/miso/sfs/mhwdfs
loop2 squash 4.0                                                                   0   100% /run/miso/sfs/desktopfs
loop3 squash 4.0                                                                   0   100% /run/miso/sfs/rootfs
│     vfat   FAT32                      4112-610A                             299.1M     0% /tmp/calamares-root-111aeu6q/boot/efi
      btrfs                             6703bce7-9beb-4dfe-a060-eea853492461  460.3G     1% /tmp/calamares-root-111aeu6q/var/tmp
sdb   iso966 Joliet GARUDA_GNOME_RAPTOR 2023-10-29-08-16-17-00                              
│     iso966 Joliet GARUDA_GNOME_RAPTOR 2023-10-29-08-16-17-00                     0   100% /run/miso/bootmnt
      vfat   FAT12  MISO_EFI            4388-655B                                           

I know a lot of people on here recommend Ventoy but personally i’ve been using Rufus for around 10 years with no issues, even when I installed Garuda. Just something else to try

Its early in the morning, i originally put down UNetbootin but i switched to Rufus a while ago

As well as being an elderly computer, you have a minimal amount of RAM. You can still have a “happy ending” in Linux with this machine, but you will have to be aware of its limitations.

Since Day One, the rumor mill has stated again & again that “Linux runs great on old, low-powered computers” and that can be true, when it generally applies to those Linux distros meant for that.

Race-horse distros–and Garuda is built for performance–generally work better with newer hardware that can handle the requirements to be performant (new favorite word).

Not sayin’ you can’t, but for someone totally new to Linux, and with this hardware, you have your work cut out for you.


What specifically did you try? What was the outcome? If you can paste some terminal output from your efforts into the thread that is often very informative.

Did you try this one? Garuda Installation failed, bootloader installation error - #25 by FOUR_7777 It’s a fairly unconventional process but it seems to have worked for a few people (like this one: Bootloader install failed - #15 by future-XD).

What is the exact error? Paste the input and output into the thread if you can.

Yes, don’t give up! :muscle:


This topic was automatically closed after 14 days. New replies are no longer allowed.