Error trying to create a usb directory point

I have been following the tutorial on how to mount a U.S.B drive Ive found that my USB is sda1 .I do know how to copy files in windows but this is totally different .Ive been on the road and only have WiFi now and then so I am posting again.i have sent the terminal results to the private bin .
https://bin.garudalinux.org/?af0bc9bc30f74922#7WQ9HTc4fAtyHbhXiEaLMM8UAAy8KdMtwP7hLSzfGBPC
https://bin.garudalinux.org/?653ae598f671fe22#A9zHJNdJ5JysZm8vRqpZc2AxQwMSRTxqXH554mfSWW2r

  1. Find yourself a good explainer on the linux directory structure. Get a better understanding of how / relates to the rest of it, and what some sub directories are for.

  2. Use what you've learned from step 1 to figure out where would be a good place to mount a thumb drive.

  3. Look up the 'mount' command and it's options.

  4. Use information gleaned from steps 1-3 to mount thumb drive.

  5. Look up the 'cp' and 'mv' commands, study their options.

  6. Use the information gleaned from steps 1-5 to move or copy data.

  7. I think you have a /data folder on /dev/nvme0n1p2 now, you might revisit that at a later date.

3 Likes

Use a filemanager. It'll do most of the heavy lifting automatically. Mount, copy, unmount etc.

2 Likes

Oh hhhhh really thanks ill study how to use that

1 Like

There's not that much to learn. KDE uses Dolphin as it's file manager and it should automatically mount your thumdrives.

3 Likes

Which tutorial?

That should happen automatically - it's built in to KDE and GNOME and Xfce. Given you are using KDE you just open it in Dolphin, your file manager, as covered previously:

2 Likes

Ok so ive tried to open the file manager i find the mp3 folder i right click on it then scroll down to share then i left click on share ,then share to devices,then i click that and i get a no device found.

Mark the file, copy the file and paste the file, share is maybe for email/chat IDK and so on. :smiley:

2 Likes

"Share" would be for a Bluetooth connection, not a USB connection.

This is the same under Windows and macOS.

Insert USB drive into USB port. Open USB drive in file manager. Copy files over. Unmount ("eject"/"safely remove") USB device. Remove USB drive from USB port.

5 Likes

Ok Ive tried a different USB stick,i inserted it and i see the device top right i left click it ,it opens then i see open with file manager .I open it in file manager i click desktop to find the music file i right click copy and then go to the USB device but there's no option to paste it .Ok i have found the problem i still had a file on there after running the format i now can copy the music file and paste it from the clipboard .Thanks so much everyone for your patience,.My problem is now solved .Now we will have George staight tunes in the car.

1 Like