Error saying that my packages are corrupted (either invalid or corrupted)

I'm having an issue similar to this, but the signatures I'm getting are from random names at ArchLinux.org. This is a fresh install, mind you. I was trying to update via the Assistant, and it keeps giving me an error saying that my packages are corrupted (either invalid or corrupted) and asking if I want to remove them. This has been happening to me on multiple Arch-based Distros, so I don't know if this is a problem with my mirror list or something else. Please help.

Check here first:

2 Likes

I'll keep following this, but the top solution didn't work for me.

Is your system clock correct?

If it is then post the output of each command (as text) that you have tried along with its output.

My time's correct. Give me a second to post the output.

How do I post it as text? It keeps limiting me to 32000 characters.

Firstly, how on Earth are you getting so many characters? (Oh, maybe the refresh-keys part...)

Secondly:

image

and link.

1 Like

Have you tried deleting the files it says are corrupted?

It's only ~26 out of 263 packages, after all.

2 Likes

So I should just try removing the packages from Pacman's cache in order to test it?