Error " no secrets were provided"

Hello.
I recently installed garuda Linux but I'm having problems connecting to the wifi network. The error is "no secrets were provided". I searched for solutions and tried everything I found, but the error still pops up. Can anyone help me?

I had the same problem with kubuntu the next command fixed my problem which simply changes the regulatory domain

sudo iw reg set US

just change the US to your country code

2 Likes

Welcome :slight_smile:

Could you, please, post what you try and post your inxi -Faz.

I tired adding:

[device]
wiFi.scan-rand-mac-address=no

in the network manager, I also tried restarting the wifi module from the garuda network assistant, but nothing changed

Especially for networking support providing inxi -Faz is quite important. Please provide this so helping can be more efficient :slight_smile:

1 Like

Since I'm running garuda on my pc, how do I have to provide the output of the command?

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Network:   Device-1: Realtek RTL8111/8168/8411 
                    PCI Express Gigabit Ethernet vendor: 
                    ASUSTeK PRIME B450M-A  driver: 
                   r8169 v: kernel port: 3000  bus-ID: 
                   02:00.0  chip-ID: 10ec:8168  class- 
                   ID:0200
                   IF: enp2s0 state: down  mac:<filter> 
                   Device-2: Realtek RTL8192EU 
                   802.11b/g/n WLAN Adapter type: USB 
                   driver: rtl8xxxu  bus-ID:1-14:3     chip- 
                   ID: 0bda:818b  class-ID: 0000  serial:. 
                  <filter>  IF:wlp0s20f0u14 state:down  
                  mac:<filter>

Again

Edit your post.


You do it in

/etc/NetworkManager/conf.d/wifi_rand_mac.conf

?

Summary

Secrets were required, but not provided

If you attempt to connect to a network using nmcli device wifi connect SSID password password and received the following error:

Error: Connection activation failed: (7) Secrets were required, but not provided

The error can be resolved by deleting the connection profile and creating a new one:

$ nmcli connection delete SSID
$ nmcli device wifi connect SSID password password

You can also try disabling MAC address randomization:

/etc/NetworkManager/conf.d/wifi_rand_mac.conf

[device] wifi.scan-rand-mac-address=no

2 Likes

I tried the command

nmcli connection delete SSID 

and I got this output

Error: unknown connection 'Aria Wi-Fi' . 
Error: cannot delete unknown connection(s): 'Aria Wi-Fi' .

Maybe you could try the following:

  1. Install crda
  2. Uncomment the correct Country Code in /etc/conf.d/wireless-regdom
  3. Reboot the system, because the setting is only read on boot
2 Likes

After rebooting I get a different error, it says "WiFi network could not be found"

I'm afraid this seems to be a very problematic wifi card. Just searched RTL8192EU in the forum and there was never a real solution.
The only reasonable thing to try seems to be this one (although it was not working in that case, that driver is meant for this card).

1 Like

You don't post your inxi, you do not answer

We are not psychics and would like to know if you have read and performed it.

In the template it says that without inxi -Faz we shoot the post etc..
Same in post #7

You were also asked three times in this topic to post it, how long do you think my patience is?

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.