Error: key "8A9E14A07010F7E3" could not be looked up remotely

Hello!
First things first: Thank you for creating this distro! This is the first time when I've felt right at home using Linux.

Now... eh, I have an issue. I'm sorry in advance if this is a wrong place to post it.
If I update my packages with
sudo pacman -Syu
I get multiple error messages of the kind
error: key "8A9E14A07010F7E3" could not be looked up remotely

I could narrow it down to just one package: beautyline. Yet there are more, that fail.
Here is the full output, when I try to update it:

sudo pacman -S beautyline
resolving dependencies...
looking for conflicting packages...

Packages (1) beautyline-20210621-1

Total Installed Size:  9,05 MiB
Net Upgrade Size:      0,01 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                     [------------------------------------] 100%
downloading required keys...
:: Import PGP key 0706B90D37D9B881, "Pedro Henrique Lara Campos <[email protected]>"? [Y/n] y
error: key "0706B90D37D9B881" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

I have already tried

sudo pacman -Sy archlinux-keyring

and

sudo rm -R /etc/pacman.d/gnupg/
sudo rm -R /root/.gnupg/ 
sudo gpg --refresh-keys
sudo pacman-key --init && pacman-key --populate archlinux

yet none of those worked.

Does anyone know what I am missing?

Thanks in advance!

maybe next time before trying wild things like:

Search the forum first...

8 Likes

Worked like a charm! Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.