Error installing grub in dual boot: windows10 + Garuda


i've tried to install garuda after windows 10 but I received an error:

"error installing grub: btrfs not allowing blocklist"

any suggestion would be great!

Hi there, welcome to forums.

Try turning off secure boot, if not already


HI Naman, secure boot is not active.

What does inxi says?

(Paste text)

1 Like


Install the bootloader to the drive, not to a partition.


Boot and install in UEFI mode when using a GPT partition table.


iso name: garuda-dr460nized-linux-zen-210329.iso

inxi output:

╰─λ inxi -Fxxxza
System:    Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=es_ES keytable=es tz=UTC misobasedir=garuda 
misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 driver=free nouveau.modeset=1 i915.modeset=1
Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux
Machine:   Type: Laptop System: Intel product: SLIMBOOK v: 0.1 serial: <filter>
Mobo: SLIMBOOK model: N/A v: RVP7 serial: <filter> UEFI [Legacy]: American Megatrends v: 5.12 date: 12/20/2017
Battery:   ID-1: BAT0 charge: 34.0 Wh condition: 34.1/44.7 Wh (76%) volts: 8.3/7.4 model: TPS S10 type: Li-ion serial: N/A
status: Unknown
CPU:       Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6
model-id: 8E (142) stepping: 9 microcode: DE L2 cache: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23199
Speed: 3501 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 3501 2: 3500 3: 3500 4: 3500
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 class ID: 0300
Device-2: Alcor Micro HD WebCam type: USB driver: uvcvideo bus ID: 1-4:3 chip ID: 058f:d102 class ID: 0e02
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1080 s-dpi: 96 s-size: 1182x285mm (46.5x11.2") s-diag: 1216mm (47.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 168 size: 290x170mm (11.4x6.7") diag: 336mm (13.2")
Monitor-2: HDMI1 res: 2560x1080 hz: 60 dpi: 81 size: 800x340mm (31.5x13.4") diag: 869mm (34.2")
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3
chip ID: 8086:9d71 class ID: 0403
Sound Server: ALSA v: k5.11.1-zen1-1-zen
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 chip ID: 8086:24fd
class ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus ID: 1-3:2 chip ID: 8087:0a2b
class ID: e001
Message: Required tool hciconfig not installed. Check --recommends
Drives:    Local Storage: total: 960.96 GiB used: 924.4 MiB (0.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB block size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 3B7QCXE7 temp: 34.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 010 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Transcend model: JetFlash Transcend 32GB size: 29.44 GiB block size:
physical: 512 B logical: 512 B rotation: SSD serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw size: N/A size: 11.66 GiB used: 924.4 MiB (7.7%) fs: overlay source: ERR-102
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 75.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 183 Uptime: 8m wakeups: 1 Memory: 15.55 GiB used: 3.82 GiB (24.6%) Init: systemd v: 247 Compilers:
gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1221 lib: 299 Shell: fish v: 3.1.2 running in: konsole inxi: 3.3.01

no option to choose where to put bootloader is offered in the installation process.

OK, now read the second half of my post.


Worked! thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.