Error: failed to prepare transaction (could not satisfy dependencies)

Hey guys, so the below error is happening when I run the update command. I tried installing ffmpeg4.4 which installed but Garuda now warns of a partial update.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing x264 (3:0.164.r3081.19856cc-1) breaks dependency 'libx264.so=163-64' required by ffmpeg4.4

This happened after running the below command in order to update some extra packages

curl https://iso.builds.garudalinux.org/iso/garuda/dr460nized/220217/garuda-dr460nized-linux-zen-220217.pkgs.txt | grep -Eo '^[^ ]+' | paru -Syu --needed -

Here is my garuda -inxi

System:    Kernel: 5.16.9-2-cachyos x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
           root=UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0
           resume=UUID=41193397-191d-45b5-8c2b-405cf71e73b2 loglevel=3
           Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_wayland vt: 2 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: X510UA v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: X510UA v: 1.0 serial: <filter> UEFI: American Megatrends v: X510UA.312
           date: 04/29/2020
Battery:   ID-1: BAT0 charge: 6.9 Wh (25.9%) condition: 26.6/42.1 Wh (63.3%) volts: 11.5 min: 11.5
           model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging cycles: 437
CPU:       Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Amber/Kaby Lake
           note: check family: 6 model-id: 8E (142) stepping: 9 microcode: EC cache: L2: 4 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23220
           Speed: 2960 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 2960 2: 2445 3: 2744 4: 2869
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:5916 class-ID: 0300
           Device-2: IMC Networks VGA UVC WebCam type: USB driver: uvcvideo bus-ID: 1-6:4
           chip-ID: 13d3:5a07 class-ID: 0e02 serial: <filter>
           Display: wayland server: X.Org 1.21.1.4 compositor: kwin_wayland driver: loaded: intel
           unloaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") s-diag: 583mm (23")
           Monitor-1: XWAYLAND0 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5")
           diag: 389mm (15.3")
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.6 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
           Sound Server-1: ALSA v: k5.16.9-2-cachyos running: yes
           Sound Server-2: PulseAudio v: 15.0 running: no
           Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel bus-ID: 02:00.0
           chip-ID: 8086:24fd class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:5
           chip-ID: 8087:0a2b class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 1.57 TiB used: 331.64 GiB (20.6%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB size: 465.76 GiB
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q
           scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: A020
           scheme: GPT
           ID-3: /dev/sdd maj-min: 8:48 type: USB vendor: Seagate model: ST1000LM035-1RK172
           size: 903.57 GiB block-size: physical: 4096 B logical: 512 B type: HDD rpm: 5400
           serial: <filter> scheme: GPT
Partition: ID-1: / raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 326.63 GiB (72.8%) fs: btrfs
           dev: /dev/sda2 maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
           dev: /dev/sda1 maj-min: 8:1
           ID-3: /home raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 326.63 GiB (72.8%) fs: btrfs
           dev: /dev/sda2 maj-min: 8:2
           ID-4: /var/log raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 326.63 GiB (72.8%) fs: btrfs
           dev: /dev/sda2 maj-min: 8:2
           ID-5: /var/tmp raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 326.63 GiB (72.8%) fs: btrfs
           dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 17.06 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
           maj-min: 8:3
           ID-2: swap-2 type: zram size: 15.52 GiB used: 1024 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 3200
Info:      Processes: 253 Uptime: 1h 38m wakeups: 1 Memory: 15.52 GiB used: 3.74 GiB (24.1%) Init: systemd
           v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1551 lib: 388
           Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.07
Garuda (2.5.4-2):
  System install date:     2022-01-27
  Last full system update: 2022-02-17
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            systemd-sysctl.service 

Any help would be greatly appreciated thank you

Seems to be a known, still open, issue

2 Likes

Oh I see thank you. I did spend a whole Googling this but I guess I don't know the best places to look as I was finding old reports on Ubuntu forums haha. Couldn't work out and solutions though. I assume this means I didn't do anything wrong necessarily and I just have to wait for an update in the repos to fix this? Thanks for the clarification

If you compulsively have to use a developer version, this may happen.

2 Likes

Just felt like seeing if the command worked tbh and what would happen. Not gonna do that again probably though

1 Like

Temporal solution until Arch Linux repo doesn't solve that issue.

warning: ignoring package ffmpeg-2:5.0-4
warning: cannot resolve "libavcodec.so=59-64", a dependency of "freerdp"
warning: ignoring package ffmpeg-2:5.0-4
warning: cannot resolve "libavutil.so=57-64", a dependency of "freerdp"
warning: ignoring package ffmpeg-2:5.0-4
warning: cannot resolve "libswscale.so=6-64", a dependency of "freerdp"
warning: ignoring package ffmpeg-2:5.0-4
warning: cannot resolve "libswresample.so=4-64", a dependency of "freerdp"
:: The following package cannot be upgraded due to unresolvable dependencies:
freerdp

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...

So type this for ignore ffmpeg.

sudo pacman -Syu --ignore=ffmpeg

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.