Error 500 on FIrefox Sync

Hello all,

I'm having a problem that manifests the same as in this topic. I open the application menu, to go click SIgn In next to "Sync and Save Data", and get the 500 Error and cannot sign in.


I've never used Firefox Sync before. I attempted this on Librewolf on my Windows machine (as I had intended to switch), same error. I tried the same on normal Firefox, that works both on Garuda and Windows.


Things I've tried (all on FireDragon):

  • Made sure the dom.storage.enabled pref is TRUE
  • Made sure the Clear URLs extension is gone
  • Made sure to include accounts.firefox.com in Tracking Protection and cookie exceptions
  • Ran firedragon -safe-mode and firedragon -P to test in Safe Mode and a fresh profile, neither helped

I should add that my install of Garuda is pretty fresh, not even a week old.

It has been discovered this is an upstream bug related to Resist Fingerprinting. Before attempting to sign in to Firefox Sync, go to about:config and change privacy.resistFingerprinting to FALSE. Then sign in and set up syncing.

Once done, I've re-enabled RFP and syncing still works, for now.

Source: Firefox Sync doesn't seem to work (#310) · Issues · LibreWolf / Browser / Windows · GitLab

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.