Encryption password with wrong keyboard layout

Hi.

I am a 20+ year Linux user. I installed Garuda for a bit of fun while on vacation. I discovered that even though I set the keyboard (non-US) correctly (AFAICS) during the installation, when I select the encryption password it actually sets the encryption keyboard layout to US, but then applies the password correctly. In other words if my password were simply "!" (it is not) I have to now use shift+1 which is not "!" on my keyboard, to decrypt the disk.

Fortunately, I can make the switch between my default (physical) keyboard and the US one in my head. However, this seems likely to be a bug in the installer when it sets up the encryption?

I went through the installer a few times with different keyboard selections to validate this and got the same result each time.

inxi -Faz
System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2cd2b712-01fa-4ff3-a84a-fd100255cd44
rw [email protected] quiet
cryptdevice=UUID=0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848:luks-0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848
root=/dev/mapper/luks-0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-2b4c4f23-2e22-4ac7-928d-e46fdd5b3333 loglevel=3
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> Chassis: type: 10
serial: <filter>
Mobo: Dell model: 0VYV0G v: A00 serial: <filter> UEFI: Dell v: 1.9.1 date: 12/14/2020
Battery:   ID-1: BAT0 charge: 68.9 Wh (100.0%) condition: 68.9/97.0 Wh (71.1%) volts: 12.7 min: 11.4
model: SMP DELL GPM0365 type: Li-ion serial: <filter> status: Full
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399
Speed: 4438 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4438 2: 4401 3: 4403 4: 4500
5: 4401 6: 4401 7: 4396 8: 4483 9: 4218 10: 4245 11: 4178 12: 4438
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Hewlett-Packard
driver: nvidia v: 470.74 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f91
class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-12:4
chip-ID: 0c45:6723 class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") s-diag: 1165mm (45.9")
Monitor-1: eDP-1 res: 3840x2160 hz: 60 dpi: 284 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™ driver: iwlwifi v: kernel
bus-ID: 3b:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp59s0 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 261.74 GiB (27.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KXG60ZNV1T02 NVMe 1024GB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 10604107 temp: 39.9 C scheme: GPT
Partition: ID-1: / raw-size: 919.54 GiB size: 919.54 GiB (100.00%) used: 261.74 GiB (28.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 682 KiB (0.3%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 919.54 GiB size: 919.54 GiB (100.00%) used: 261.74 GiB (28.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848
ID-4: /var/log raw-size: 919.54 GiB size: 919.54 GiB (100.00%) used: 261.74 GiB (28.5%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848
ID-5: /var/tmp raw-size: 919.54 GiB size: 919.54 GiB (100.00%) used: 261.74 GiB (28.5%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-0b77bdf9-1bf0-4efb-b1fb-a5c8e8206848
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.97 GiB used: 6.5 MiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.07 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
maj-min: 254:1 mapped: luks-2b4c4f23-2e22-4ac7-928d-e46fdd5b3333
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2388 fan-2: 2391
Info:      Processes: 314 Uptime: 29m wakeups: 2667 Memory: 30.97 GiB used: 5.07 GiB (16.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1238 lib: 300
Shell: Bash v: 5.1.8 default: fish v: 3.3.1 running-in: konsole inxi: 3.3.07

HTH.

This happens now and then, and it is very hard to alter the US layout once it gets it in its head (so to speak) that's the default.

A workaround would be to choose a strictly numerical password, but of course that's not a fix. You'll have to do a fair bit of reading to overcome this as it can be quite stubborn about not wanting to change.

2 Likes

I did use this with a recent Fedora, and that worked rather nicely. There were warnings about not being able to change it, and the password box comes up with a label showing which layout to use. May be they have something in anaconda which could help?

Like I said, it's not a show stopper for me and thanks for the honest and rapid reply :slight_smile:

Probably I need to go through the install a few times to work out a work around. I think I i wlll keep that for my next vacation :sunglasses:

Thanks again.

1 Like