Dual monitor fail to load

I have a monitor plugged in but it does not work.

System:
Kernel: 5.19.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6a9e8edd-14c2-4d20-aa71-671321d8469d rw [email protected]
quiet splash drm_kms_helper.edid_firmware=HDMI-A-1:edid/1920x1080.bin
Console: pty pts/0 wm: kwin_x11 DM: 1: LightDM v: 1.32.0 note: stopped
2: SDDM note: stopped Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-56 v: V1.05 serial: <filter>
Mobo: TGL model: Scala_TLM v: V1.05 serial: <filter> UEFI: Insyde v: 1.05
date: 04/22/2021
Battery:
ID-1: BAT1 charge: 47.1 Wh (100.0%) condition: 47.1/57.5 Wh (82.0%)
volts: 16.7 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
status: full cycles: 60
CPU:
Info: model: 11th Gen Intel Core i5-11300H socket: U3E1 bits: 64
type: MT MCP arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm
family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0xA4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3026 high: 3100 min/max: 400/4400 base/boost: 4000/4400
scaling: driver: intel_pstate governor: performance volts: 0.8 V
ext-clock: 100 MHz cores: 1: 3100 2: 3100 3: 3100 4: 3100 5: 3100 6: 2512
7: 3100 8: 3100 bogomips: 49766
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Acer
Incorporated ALI driver: i915 v: kernel arch: Gen-12.1
process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: DP-1
bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Acer
Incorporated ALI driver: N/A alternate: nouveau non-free: 515.xx+
status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:25a5
class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-8:3
chip-ID: 04f2:b72b class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0xaf90 built: 2020 res: 1920x1080
hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Acer Incorporated
ALI driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Sound Server-1: ALSA v: k5.19.6-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi
v: kernel bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
port: 3000 bus-ID: 0000:2c:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp44s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
class-ID: 0104
Drives:
Local Storage: total: 700.51 GiB used: 17.25 GiB (2.5%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-512G-1114 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 21113000 temp: 47.9 C scheme: GPT
SMART: yes health: PASSED on: 157d 2h cycles: 192 read-units: 168,037,689
[86.0 TB] written-units: 48,572,616 [24.8 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX200SSD1
family: based SSDs size: 223.57 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: .6 temp: 34 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 6d 17h cycles: 1252
read: 4.58 TiB written: 1.86 TiB
Partition:
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 17.25 GiB
(7.7%) fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 17.25
GiB (7.7%) fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 17.25
GiB (7.7%) fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 17.25
GiB (7.7%) fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.56 GiB used: 46.8 MiB (0.6%)
priority: 100 dev: /dev/zram0
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 285 Uptime: 21m wakeups: 2573 Memory: 7.56 GiB used: 4.16 GiB
(55.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: apt: 0 pacman: 1949 lib: 532
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-09-04
Last full system update: 2022-09-04 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:

Also if I use xrandr it does not appear:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
1920x1080    144.15*+  60.01    59.97    59.96    59.93
1680x1050     59.95    59.88
1400x1050     74.76    59.98
1600x900      59.99    59.94    59.95    59.82
1280x1024     85.02    75.02    60.02
1400x900      59.96    59.88
1280x960      85.00    60.00
1440x810      60.00    59.97
1368x768      59.88    59.85
1280x800      59.99    59.97    59.81    59.91
1152x864      75.00
1280x720      60.00    59.99    59.86    59.74
1024x768      85.00    75.05    60.04    85.00    75.03    70.07    60.00
1024x768i     86.96
960x720       85.00    75.00    60.00
928x696       75.00    60.05
896x672       75.05    60.01
1024x576      59.95    59.96    59.90    59.82
960x600       59.93    60.00
832x624       74.55
960x540       59.96    59.99    59.63    59.82
800x600       85.00    75.00    70.00    65.00    60.00    85.14    72.19    75.00    60.32    56.25
840x525       60.01    59.88
864x486       59.92    59.57
700x525       74.76    59.98
800x450       59.95    59.82
640x512       85.02    75.02    60.02
700x450       59.96    59.88
640x480       85.09    60.00    85.01    72.81    75.00    59.94
720x405       59.51    58.99
720x400       85.04
684x384       59.88    59.85
640x400       59.88    59.98    85.08
576x432       75.00
640x360       59.86    59.83    59.84    59.32
640x350       85.08
512x384       85.00    75.03    70.07    60.00
512x384i      87.06
512x288       60.00    59.92
416x312       74.66
480x270       59.63    59.82
400x300       85.27    72.19    75.12    60.32    56.34
432x243       59.92    59.57
320x240       85.18    72.81    75.00    60.05
360x202       59.51    59.13
360x200       85.04
320x200       85.27
320x180       59.84    59.32
320x175       85.27
DP-1 disconnected (normal left inverted right x axis y axis)

My computer is dual booted with windows and on Win dual monitor works properly.

Welcome :slight_smile:

2 Likes

:man_facepalming:
Add ibt=off kernel parameter.

2 Likes

Is this kernel parameter really needed and correct?
I'm just wondering, I don't mean it's not needed.

2 Likes

No, no necessary at all. It was a first attempt to fix the problem

it didn't work,

I've already read but didn't help

Send your new inxi. If you edited /etc/default/grub, you need to run update-grub afterwards.

Now i managed to reinstall all nvidia drivers but now works only the second monitor. The built-in laptop monitor shows me boot log.

System:
Kernel: 5.19.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6a9e8edd-14c2-4d20-aa71-671321d8469d rw [email protected]
quiet splash ibt=off
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: 1: LightDM v: 1.32.0 note: stopped 2: SDDM
note: stopped Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-56 v: V1.05
serial: <superuser required>
Mobo: TGL model: Scala_TLM v: V1.05 serial: <superuser required>
UEFI: Insyde v: 1.05 date: 04/22/2021
Battery:
ID-1: BAT1 charge: 47.1 Wh (100.0%) condition: 47.1/57.5 Wh (82.0%)
volts: 16.7 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
status: full cycles: 60
CPU:
Info: model: 11th Gen Intel Core i5-11300H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
model-id: 0x8C (140) stepping: 1 microcode: 0xA4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3092 high: 3368 min/max: 400/4400 scaling:
driver: intel_pstate governor: performance cores: 1: 3368 2: 3193 3: 3100
4: 3100 5: 2678 6: 3100 7: 3100 8: 3100 bogomips: 49766
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Acer
Incorporated ALI driver: i915 v: kernel arch: Gen-12.1
process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: DP-1
bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Acer
Incorporated ALI driver: nvidia v: 515.65.01
alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
2022-07) arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22
bus-ID: 0000:01:00.0 chip-ID: 10de:25a5 class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-8:3
chip-ID: 04f2:b72b class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
s-diag: 610mm (24")
Monitor-1: eDP-1 mapped: HDMI-0 model: AU Optronics 0xaf90 built: 2020
res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2 size: 528x297mm (20.79x11.69")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: NVIDIA GeForce RTX 3050 Laptop GPU/PCIe/SSE2 v: 4.6.0
NVIDIA 515.65.01 direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Acer Incorporated
ALI driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Sound Server-1: ALSA v: k5.19.6-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 16.1 running: no
Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi
v: kernel bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
port: 3000 bus-ID: 0000:2c:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp44s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
class-ID: 0104
Drives:
Local Storage: total: 700.51 GiB used: 27.27 GiB (3.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-512G-1114 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 21113000 temp: 49.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX200SSD1
size: 223.57 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: .6 scheme: GPT
Partition:
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 27.27 GiB
(12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 27.27
GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 27.27
GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 27.27
GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.56 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A
Info:
Processes: 290 Uptime: 1m wakeups: 254 Memory: 7.56 GiB used: 2.46 GiB
(32.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: 1989 apt: 0 pacman: 1982 lib: 533 snap: 7
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-09-04
Last full system update: 2022-09-05
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 528mm x 297mm
1920x1080     60.00*+  74.97    59.94    50.00
1680x1050     59.95
1600x900      60.00
1440x900      59.89
1280x1024     75.02    60.02
1280x800      59.81
1280x720      60.00    59.94    50.00
1152x864      75.00
1024x768      75.03    70.07    60.00
800x600       75.00    72.19    60.32    56.25
720x576       50.00
720x480       59.94
640x480       75.00    72.81    59.94

I solved the problem installing the driver and using nvidia-switch