Dual monitor - 60 fps on external display 180hz but laptop screen is smooth

Hi, I have weird issue. Recently I’ve got a new monitor 180 hz. To check fps i’m using kde’s “show fps” desktop effect. When I move any window on the laptop screen (120hz) everything is smooth and it shows 180 fps. However, when I move window on my external screen, kde shows current fps at 60 and I can see that window is laggy. Also, sometimes both screen just freezes for a second.
I’m on wayland. When i switched to x11 and disabled laptop display, the external display worked as expected (rendering 180 fps).

I tried adding MaxFPS=180 to ~/.config/kwinrc, but it doesn’t work.

Kernel: 6.8.2-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9ab680d1-bec4-4d96-8638-f920e8bf7007 rw rootflags=subvol=@
nvidia-drm.modeset=1 nvidia-drm.modeset=1 rd.udev.log_priority=3
vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Micro-Star product: GF65 Thin 9SEXR v: REV:1.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-16W1 v: REV:1.0 serial: <superuser required>
part-nu: 16W1.1 uuid: <superuser required> UEFI: American Megatrends
v: E16W1IMS.10A date: 03/26/2020
ID-1: BAT1 charge: 39.7 Wh (95.4%) condition: 41.6/51.3 Wh (81.0%)
volts: 12.7 min: 11.4 model: MSI Corp. MS-16W1 type: Li-ion serial: N/A
status: not charging
Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xFC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3999 high: 4003 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 4000 2: 4000 3: 4002
4: 3992 5: 4003 6: 4000 7: 4000 8: 3999 bogomips: 38400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:3e9b
class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI
driver: nvidia v: 550.67 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2024-02; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-1
empty: none bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Display: wayland server: X.org v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia d-rect: 1920x2160 display-ID: 0
Monitor-1: HDMI-A-1 pos: primary,top res: 1920x1080 size: N/A modes: N/A
Monitor-2: eDP-1 pos: bottom res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.4-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) device-ID: 8086:3e9b memory: 15.1 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 11 device: 0 type: integrated-gpu
name: Intel UHD Graphics 630 (CFL GT2) driver: mesa intel v: 24.0.4-arch1.2
device-ID: 8086:3e9b surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.67
device-ID: 10de:1f15 surfaces: xcb,xlib,wayland device: 2 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.4-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
API: ALSA v: k6.8.2-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI RTL8111/8168/8411 driver: r8169 v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Info: services: NetworkManager, smbd, systemd-networkd, systemd-timesyncd
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:3
chip-ID: 8087:0aaa class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no
Local Storage: total: 476.94 GiB used: 433.41 GiB (90.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: LITE-ON model: CL1-8D512
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1.00 temp: 43.9 C scheme: GPT
ID-1: / raw-size: 469.65 GiB size: 469.65 GiB (100.00%)
used: 433.41 GiB (92.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 584 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 469.65 GiB size: 469.65 GiB (100.00%)
used: 433.41 GiB (92.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:2
ID-4: /var/log raw-size: 469.65 GiB size: 469.65 GiB (100.00%)
used: 433.41 GiB (92.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:2
ID-5: /var/tmp raw-size: 469.65 GiB size: 469.65 GiB (100.00%)
used: 433.41 GiB (92.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.46 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
ID-2: swap-2 type: partition size: 1.91 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:3
System Temperatures: cpu: 77.0 C pch: 63.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.46 GiB used: 3.67 GiB (23.7%)
Processes: 297 Power: uptime: 3m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.12 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 2147 libs: 558 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-09-04
Last full system update: 2024-04-06
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            systemd-networkd-wait-online.service


Screen 0: minimum 16 x 16, current 1920 x 2160, maximum 32767 x 32767
eDP-1 connected primary 1920x1080+0+1080 (normal left inverted right x axis y axis) 340mm x 190mm
1920x1080    120.01*+
1440x1080    120.03
1400x1050    120.01
1280x1024    119.96
1280x960     119.89
1152x864     119.94
1024x768     120.02
800x600      119.85
640x480      119.52
320x240      119.73
1680x1050    119.99
1440x900     120.07
1280x800     120.01
1152x720     119.94
960x600      120.04
928x580      119.87
800x500      119.91
768x480      119.71
720x480      119.65
640x400      119.64
320x200      117.55
1600x900     120.07
1368x768     119.99
1280x720     119.86
1024x576     119.85
864x486      119.69
720x400      119.54
640x350      120.03
HDMI-A-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 540mm x 310mm
1920x1080    179.98*+
1440x1080    179.92
1400x1050    179.92
1280x1024    179.91
1280x960     179.87
1152x864     179.78
1024x768     179.84
800x600      179.71
640x480      179.43
320x240      178.06
1680x1050    179.94
1440x900     179.84
1280x800     179.74
1152x720     179.84
960x600      179.74
928x580      179.47
800x500      179.63
768x480      179.51
720x480      179.35
640x400      179.55
320x200      176.99
1600x900     179.77
1368x768     179.92
1280x720     179.72
1024x576     179.77
864x486      179.75
720x400      179.53
640x350      179.74

:point_up_2: and wait for better wayland support :slight_smile:


Ok, thanks

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.