(DUAL BOOT) - GRUB not working after installation of Garuda

Hi!

First of all, i'd like to thank everyone for helping me solve this problem.

Well let's get into the matter, i've installed Garuda Linux recently in a partition my secondary hard drive. The issue is that after what seems as a perfect installation Garuda won't boot, instead Windows shows up. Trying to solve this i plugged-in the USB i used to install the os and realized that i could launch GRUB from the "detect efi bootloaders" option in the bootable menu then i could launch the previously installed garuda without any problems. The thing is that i don't want to plug-in the bootable USB each time i boot Garuda. I've searched the forum and tried some solutions but nothing seems to work. I would really appreciate any help.

Here are the hardware specifications:

  • The computer i'm using is a laptop, specifically, is a Acer Predator 15 here are the specs

Here is the installation scheme i want for my machine:

As mentioned in the specifications this laptop has 2 drives, a SSD and a HDD. I'm trying to install garuda in a partition of the HDD. So in summary the SSD contains Windows and the HDD has a partition accessible for Windows to store data and a partition for Garuda and it's data.
I'd like to mention, if it helps someone figuring out what i mean, that sda1 is the EFI system partition, sda2 is the "C:" windows disk, sda3 is the windows recovery partition and then sdb1 is the first half of the HDD which i'd like to use for windows (It's file system is NTFS ) and sdb2 is currently where Garuda Linux is installed.

The installation process i followed:

  • I used the Calamares installer built-in the live version of Garuda Dr46onized iso. For burning the ISO i used rufus, i know it's not recommended but i tried Balena Etcher and it kept failing also the ISO boots normally so i dont't think the problem is related to that. In the partition section of the installation i selected "Replace partition" and carefully selected the space that i had allocated in my HDD using windows disk manager.

Next a list of the things i've tried until now:

  • Installing and updating GRUB using garuda-chroot from bootable device as recommended in other post of this forum. I've done this several times.
  • Reinstalling Garuda using the same partition scheme. I could not observe any differences.
  • Disabled fast boot and hibernation mode from windows and reinstalling GRUB.
  • Reorganizing the boot preference, the SSD and the windows boot have less preferences than floppy disks :open_mouth:
  • Holding shift on start up. It's supposed to launch GRUB menu.

Once again thanks in advance for all your help!

This suggests you installed GRUB to the bootable USB instead of your internal disk.

Given this is a fresh installation I'd recommend you reinstall and verify your choices at each step of the process.

5 Likes

Thanks for your answer!

I've gone through the installation process again and this time i've taken some snapshots. I'll guide you through them to see if you can spot the problem.

First i want to show you how the bootable menu looks for me. In the next image you can see the usual boot menu.

If i select the "Detect EFI bootloaders" option then i get redirected to this screen:

Selecting the highlighted option takes me to the Garuda dual-boot menu. This time i returned back and selected the live session from the bootable menu.

Next i'm showing the current partition scheme of my machine, as you can see Windows is installed in the sda drive where the sda1 is the EFI system partition. The second image displays the partitions of the sdb drive (My secondary drive) in sdb2 is where i'd like to install Garuda (And where it was previously installed).


Now let's continue with the installation process. This time i've noticed a difference which i don't know if is of any relevance. The first drive says it has a GPT partition table on the other side the second drive has a MBR partition table (Highlighted in red). You can see that i selected the second half of the secondary drive to replace with my Garuda installation and the installer responds: "EFI system partition on /dev/sda1 will be used to boot Garuda" (Underlined in the image).

This is all the new information i can give you, the process seems simple so maybe i'm failing to see some fundamental truth, i must say that i don't know much about current booting systems.

Once again thank you for your help!

Seems you use old ISO, try new one.

3 Likes

Thank you, i'll try it. Where should i download the new one from?

2 Likes

I'd also suggest you stick to one OS because if you were fully capable of managing a multi-boot setup you wouldn't need to be asking for advice on a Linux forum. This is the reason why we tell people we do not support dual/multi booting with Garuda.

Those capable of managing a multi-boot setup are certainly welcome to do so. It is not Garuda's job to teach you how to retain a M$ install and boot both. Pick one or the other if you don't know how to manage a multi-boot setup. Sorry for being rude, but more support time is wasted and more problems are created by those who insist on Multi-booting when they are too inexperienced to handle it themself.

This is comparable to purchasing a new car. When you walk on to a car lot to purchase a vehicle, is it the car manufacturers job to teach you how to drive so you can test drive one of their vehicles? Say they did actually teach you how to drive so you could take their product out for a test spin. If you crash their vehicle, is the manufacturer the one responsible for repairing the damage caused by your poor driving skills? Sometimes the old car analogies are the best for describing why new users expectations are not that appropriate for a small independent distro with limited support resources.

3 Likes

Hi, first of all thanks again to everyone for helping me out. I'd like to be able to choose Garuda over Windows but for personal reasons i just can't but i still want to switch and learn about the alternatives so one day i may be able to. I'm sorry for all the inconvinience i have caused and i'll think more carefully the next time i get to post on the forum.

Once again thank you all! :smiling_face_with_three_hearts:

1 Like

It's certainly doable to dual boot, but it does take some research and know how. Take a little more time and be sure to do backups before attempting it. Then if you do mess up with proper backups it's not such a big deal.

Good luck.

3 Likes

Hi, I am also a Dual-Boot user with windows and garuda, before installing a GNU/Linux operating system I was like 4 months in a Virtual Machine jumping from distribution to distribution configuring, but in real hardware it looks serious.
Maybe this will help you I will attach some screenshots I hope they will be of help.

-First if you install with the calamares installer will ask you to create an EFI partition with Fat32 format, the thing is that if you do not have the compatibility enabled in the BIOS setup you will not vote the GRUB of garuda but will continue with the windows and you will have to go to the manual boot and choose the EFI file as attached in the picture.

it is annoying to be booted manually if with garuda grub you can select which OS to choose.

-So what I did was to turn on the wounded compatibility by configuring the BIOS and disable the secure boot, after that I went back to the BIOS and looked in boot systems and found the garuda GRUB. Then I set it as the first boot option so that I always boot with garuda Linux.

A few recommendations before you go on to Dual that I have come across.

  • Check the BIOS settings, some BIOS are more advanced than others and have more settings so you should do some research there first.
  • Be careful with the Windows Restore, Reinstall and Upgrade, I have come across many times that if you restore your Grub from garuda it will be lost, in the Windows Reinstall you have to disable the wounded compatibility or well that was in my case leave it as it was before, in the upgrades I had to take the risk because in the mid year upgrades (Depending on what license you have windows) may be that you delete the Grub, ! I DON'T RECOMMEND YOU TO BE A WINDOWS INSIDER BECAUSE OF THE CONSTANT UPDATES! Although those previous problems can be solved by repairing the GRUB or reinstalling with Garuda's own tool, it is better to be prepared.
  • Remove or disable windows fastboot that can cause problems later with GRUB.

I hope it helped you I attach photos of the installation I just did because yesterday I had to reinstall windows, and I removed the GRUB from garuda then as I saw your post I decided to reinstall to capture the photos of my installation.

  1. First I deleted the first 2 partitions I had before for a clean install.
    Instalacion-antes — ImgBB
  2. I created the two new partitions one 250Mb Fat32 format, mount point /boot/efi and in labels I put : /boot , Bios-grub, Legacy-boot and the other btrfs mount / root label. thus being ready to boot. after the installation set the BIOS to garuda to be first boot.
    nueva-particion — ImgBB
    tabla-particion — ImgBB

Sorry for the translation my English is bad at the moment but I know enough technical words not to get lost www.DeepL.com/Translator (free version)

4 Likes

Thanks! As you suggested i went into BIOS and did the research. In the end i needed to activate secure boot and select from the EFI partition grub as trusted EFI file then it started showing in the boot preference menu.

Once again thank you all and specially @osvarcha for taking the time to get all the pictures! Gracias!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.