Dr460nized is frequently freezing and ~30k lines of ACPI errors per second when I look into journalctl

Errors in journalctl:

Jan 05 22:31:38 JoLi-HauptPC-Garuda kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_GPE._L09.D1F0], AE_NOT_FOUND (20210730/psargs-330)
Jan 05 22:31:38 JoLi-HauptPC-Garuda kernel: ACPI Error: Aborting method \_GPE._L09 due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
Jan 05 22:31:38 JoLi-HauptPC-Garuda kernel: ACPI Error: AE_NOT_FOUND, while evaluating GPE method [_L09] (20210730/evgpe-511)

These 3 Lines are repeated all the time (30k lines per second, probably more)

This started today at about 5pm, since then ~5 freezes, for a few seconds, then I see my bios screen.
My BIOS is up-to-date, the only thing on my system that is not up-to-date is llvm-git and llvm-libs-git which I can't update because they take ~5h to compile and then it failes (This is the case since ~2 weeks ago)

The Errors appear while running with Kernel linux-zen5.15.12.zen1-1 and linux5.15.12.arch1-1
I just installed linux-mainline5.16rc7-1 which I'll try out next.

edit I forgot inxi -Faz output:

System:
Kernel: 5.15.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
root=UUID=ed7d29e6-cb8d-43b9-8031-6acbb474bc2d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: N/A wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop System: MSI product: MS-7926 v: 1.0
serial: <superuser required>
Mobo: MSI model: Z97 GAMING 9 AC (MS-7926) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.13
date: 02/16/2016
CPU:
Info: model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4580 high: 4597 min/max: 800/4600 scaling:
driver: intel_cpufreq governor: performance cores: 1: 4597 2: 4592 3: 4564
4: 4580 5: 4576 6: 4582 7: 4572 8: 4582 bogomips: 64030
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M]
vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 03:00.0
chip-ID: 1002:73df class-ID: 0300
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4864x1280 s-dpi: 96 s-size: 1283x337mm (50.5x13.3")
s-diag: 1327mm (52.2")
Monitor-1: DisplayPort-1 res: 1024x1280
Monitor-2: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 102
size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
Monitor-3: HDMI-A-0 res: 1920x1080 hz: 75 dpi: 92
size: 531x299mm (20.9x11.8") diag: 609mm (24")
OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 14.0.0 DRM
3.42 5.15.12-arch1-1)
v: 4.6 Mesa 22.0.0-devel (git-268fc8e5c1) direct render: Yes
Audio:
Device-1: Intel 9 Series Family HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
class-ID: 0403
Device-2: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel v: kernel bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-3: Digidesign Mbox 2 type: USB driver: snd-usb-audio
bus-ID: 3-3.3:6 chip-ID: 0dba:3000 class-ID: 0102
Device-4: Micro Star USB2.0 High-Speed True HD Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-8:9 chip-ID: 0db0:7926
class-ID: 0300
Sound Server-1: ALSA v: k5.15.12-arch1-1 running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel bus-ID: 05:00.0
chip-ID: 8086:08b1 class-ID: 0280
IF: wlp5s0 state: down mac: <filter>
Device-2: Qualcomm Atheros Killer E220x Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus-ID: 06:00.0
chip-ID: 1969:e091 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 3-7:8 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 14.33 TiB used: 975.69 GiB (6.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 QVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: MZ7LN256HMJP-000H1
size: 238.47 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1H3Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: DT01ACA050
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A7C0
scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD40EZAZ-00SF3B0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-5: /dev/sde maj-min: 8:64 vendor: Western Digital
model: WD60EZAZ-00SF3B0 size: 5.46 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-6: /dev/sdf maj-min: 8:80 type: USB vendor: Western Digital
model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 4096 B type: HDD rpm: 5400 serial: <filter> scheme: MBR
ID-7: /dev/sdg maj-min: 8:96 type: USB vendor: Western Digital
model: WD Elements SE 2623 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1026 scheme: GPT
Partition:
ID-1: / raw-size: 191.11 GiB size: 191.11 GiB (100.00%)
used: 59.44 GiB (31.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 916.25 GiB (98.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 191.11 GiB size: 191.11 GiB (100.00%)
used: 59.44 GiB (31.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 191.11 GiB size: 191.11 GiB (100.00%)
used: 59.44 GiB (31.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 46.87 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
ID-2: swap-2 type: zram size: 31.3 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.5 C mobo: 46.0 C gpu: amdgpu temp: 53.0 C
mem: 50.0 C
Fan Speeds (RPM): cpu: 310 fan-1: 377 fan-3: 0 fan-4: 579 fan-5: 765
gpu: amdgpu fan: 0
Info:
Processes: 383 Uptime: 18m wakeups: 20589 Memory: 31.3 GiB
used: 6.78 GiB (21.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 alt: 10 clang: 14.0.0 Packages: pacman: 1986 lib: 517
flatpak: 0 Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.11

What did you do, or what happened, just prior to this?

It looks like a hardware-related issue, so if it started happening without any other changes it means something came loose, overheated, or just simply failed.

1 Like

I didn't change anything at that time, overheating can't really be the problem, with full load the cpu goes to ~80°C.

one thing to mention would be that at boot there are ~3 messages about something with the cpu, but they go away too fast to read them

I could try to reseat the cpu in the socket and see if the problem persists

It could also be a problem with the gpu drivers, because I upgraded from a 1060 to the 6700xt, so I had to change drivers, which was a bit of a hassle and I think I didn't do everything richt, there still are some nvidia libraries installed, also I didn't know how to properly upgrade to mesa-git
Although apart from windows getting randomly located after suspend everything mostly worked fine with the gpu

Check all the components, cables, and do a RAM test.

Don't make any configuration changes to Garuda as this will only muddy things - if nothing in Garuda changed then more changes won't help.

1 Like

Ok, so I'll do a memtest, and see if that gives more info, if it turnes out that there are problems with the ram I'll reseat it and try again.

Although if I look at my Clock it's 3 am and I should get some sleep, so I'll probably do that tomorrow (in ~10h), if not you'll see it

1 Like

Heh, yes. Trying to fix things at 3am is rarely a good idea... :grin:

1 Like

Same problem with 5.16.0-rc7-1-mainline

Test the LTS kernel as your computer is older.

3 Likes

It passed memtest86 last night, I'll try the lts kernel now, if that doesn't help I'll reseat the cpu

@JoLi I don't think Kernel change will fix this, they don't/won't add mobo/chipset specific quirk patches upstream. There is a fix/workaround you can use instead to try mask that interrupt in the kernel parameters:

sudo nano /etc/default/grub

Add acpi_mask_gpe=0x09 as an additional parameter into GRUB_CMDLINE_LINUX_DEFAULT, so should look something like this e.g:

GRUB_CMDLINE_LINUX_DEFAULT="blabla=example rd.udev.log-priority=3 acpi_mask_gpe=0x09"

Generate and apply new GRUB config:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot and hopefully should be fine now.

5 Likes

I've just read the same things on other forums, but these people mostly had skylake chipsets, and also if I understood correctly what they wrote this doesn't "fix" the problem it just disables logging for that error, but I'll try anyways

No if you mask it in Kernel Boot Parameters it should afaik stop the freezing issue, as it's completely disregarding the interrupt.

2 Likes

I can't even boot with LTS Kernel, it gets stuck after the 2 messages where it says Kernel Linux-LTS wird geladen (sry I'm german idk what that message is in english) It's displayed immediately after I selected the OS in grub

rd.udev.log-priority=3
Already was there, so I added
acpi_mask_gpe=0x09

Ok cool. I just added the udev. thing in there as an example, I'm guessing there were quite a few parameters in there already. Are you stuck unable to boot with LTS Kernel now or have you been able to switch it back?

Seems to have fixed it, systemd-journald also isn't using 1/4 of my cpu :smile:, but I'm still curious what caused it because afaik I didn't change anything at the time the problem started appearing...

Yep, that part certainly is strange. I can't think of what would cause it to suddenly start, unless of change on MoBo settings or something. At least it's OK now :smiley:

Hm I didn't change something in my BIOS settings, neither did I do any Hardware changes

Very nicely done with that solution @noop. Just for future reference, Garuda uses micro as the default editor rather than nano.

Great work, and nice to have you helping out on the forum.

4 Likes

Thanks. Personally I still use Nano so writing that is force of habit lol :sweat_smile:

3 Likes