Dpkg is installed with version 1.20.9 and yet on trying to use it, it says dpkg is not installed and I require at least version 1.14

I'm trying to install google chrome but dpkg seems to not be working. Here's what happens:

╭─[email protected] in /🔒
╰─λ sudo dpkg -i (file path)
dpkg: regarding .../google-chrome-stable_current_amd64.deb containing google-chrome-stable, pre-dependency problem:
google-chrome-stable pre-depends on dpkg (>= 1.14.0)
dpkg is not installed.

However, when I run dpkg --version this is what i get:

Debian 'dpkg' package management program version 1.20.9 (amd64).
This is free software; see the GNU General Public License version 2 or
later for copying conditions. There is NO warranty.

I've tried searching but didn't find anything similar to this problem. Any help would be appreciated.

Why not
image

?
And welcome :slight_smile:

1 Like

i have no idea what you just replied sorry

Use in terminal/konsole

sudo pacman -Syu google-chrome

Done.

2 Likes

ahh, first time

garuda-update

Refresh mirrors and other things

1 Like

okay thank you so much

2 Likes

This is most definitely not Debian or any of it's derivatives, so 'dpkg' will not work. Garuda is an Arch-based distribution and Pacman is it's package manager.

Here is the Pacman Rosetta which shows the equivalent commands for Arch, Debian, Fedora, et al.

P.S. Gotta love old-school commands like 'dpkg.' IMHO it indicates a user with more than a passing interest in Linux. Bravo! :smiley:

7 Likes

I had put the focus too much on google( I do not like)-chrome. Thereby the Debian stuff has gone down with me :smiley:
Thanks :slight_smile:

3 Likes

That's OK! Read my P.S.

I like users not afraid to try. :wink:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.