Dosbox Staging - not integrated

Hello, I installed Dosbox Staging - it was quite difficult because DIscover didnt see it… After googling I found out that I have to add flatpak repository, so i made it according to Arch wiki and then was possible to install it by Discover.

And my issue is that now it is not visible in system application menu - under games like basic Dosbox nor other under-menu. But even worse is that I can not find “open with dosbox staging” in right click context menu when I click on .bat or .exe file. It is main reason why i need this version of dosbox because this content menu item allows to run dos programs without long and difficult setting of Dosbox.

In OpenSuse it is working.

Thank you in advance for your help.

Don’t use


this is not debian or openSUSE :slight_smile:
Just use terminal

sudo pacman -Syu app-name


In addition to that, I’d like to remind that flatpak packages are not supported.
You’d better remove that flatpak package, since I see there is one in the Chaotic-AUR.

sudo pacman -S dosbox-staging

If necessary, there are also dosbox-staging-git and dosbox-staging-bin in the AUR. To be installed Eg with the paru helper:

paru <package>

Quit from PKGBUILD with button q and confirm installation.


OK, but if it is in repo, why discover didnt show it?
So what software center would be working correctly? Or it is necessary always search by cli? I dont even know how to do it.


OK, i found Octopi where I found this package correctly. And installed and now the package is showed in software menu.

But still - I opened some game through context menu and said “open with other application” and all ok… But next time I had to make it the same way again… My expectation was that system will remember this option and will offer me… I mean not “allways open with”, just offer me or “open with dosbox staging” or “with wine”.

Its very pity that Discover dont see all packages.

Ask the Discover developers, please.
Again, use the terminal or pacseek for software install, not octopi, use only for search.


There usually a box below in the same menu that says something like “remember this as default”

1 Like

Yes but I dont want open all .exe and .bat by dosbox staging. But I want have possibility to choose it immediatelly in menu. In Opensuse such item occured in menu after first launching of appliation - here stays only “launch with wine”

My english is not brilliant, sorry.

I mean - now is right-click context menu this way:

“Open with Wine
Open with other appliation”

Expcectation after I launched with other application dosbox-staging:

“Open with dosbox staging (last used)
Open with Wine
Open with other application”

This I remember was behavior in OpenSuse and was better. Here I have to make long process always when I want to launch it with dosbox staging.

If It will helpful with finding the solution, I just sent 10 € to support Garuda Linux :grin: (and 1€ tip to Open Collective).

I am preparing this computer for my son, its his first “gaming” computer for simplier games - and I would like to make it perferct for using, because he is only 8 and will be not able to make difficult settings by himself…

Please do not post here in the forum, like in chat forums like Telegram.
As long as no one has responded to your post, you can edit your post.


Uh oh, I almost always use terminal / command line but I occasionally use Octopi for things other than searching. Why is it not recommended?

1 Like

so is there possibility to add “open with Dosbox Staging” into context menu for .bat and .exe files? Thank you very much.

finaly I tried this and it was working good enough so its solved - thank you


We always mark here the solution and not the implementation. :slight_smile:
So I change it to @IUSELINUX post.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.


unfortunatelly, after this disappeared “open with Wine” and I am not able to find how to give it back. I need it for other applications.

In menu is only “Wine settings” and “Uninstall software with Wine”.

Thank you very much.

This topic was automatically closed after 10 days. New replies are no longer allowed.