Don't have latte dock on the top of the screen

Hey all,

Strange problem for me after yesterday's update. Garuda is lauching properly but i don't have latte dock on the top of the screen and i dont have the dock with the icons.

I had to restore a snapshot, but when i'm doing a new update, anything goes wrong again...

System:
  Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=67e1e13a-4842-4384-b3eb-3f6fa6d905be
    rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire A517-51 v: V2.03 serial: <superuser required>
  Mobo: KBL model: Dragonite_KL v: V2.03 serial: <superuser required> UEFI: Insyde v: 2.03
    date: 05/22/2019
Battery:
  ID-1: BAT1 charge: 39.1 Wh (100.0%) condition: 39.1/48.9 Wh (79.9%) volts: 16.2 min: 15.2
    model: LG 004B384234314341 type: Li-ion serial: <filter> status: full
CPU:
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake gen: core 8 built: 2017
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 3400 high: 3401 min/max: 400/3400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 3401 2: 3401 3: 3400 4: 3400 5: 3398 6: 3400 7: 3399 8: 3401
    bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel
    arch: Gen9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: Quanta HD Webcam type: USB driver: uvcvideo bus-ID: 1-7:4 chip-ID: 0408:a060
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x139d built: 2017 res: 1920x1080 hz: 60 dpi: 128
    gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 22.1.1 direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.1
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On
    driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
Bluetooth:
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-5:3 chip-ID: 04ca:3015 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Loc
al Storage: total: 1.14 TiB used: 201.15 GiB (17.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SD9SN8W256G1014 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 7000
    scheme: GPT
Partition:
  ID-1: / raw-size: 118.93 GiB size: 118.93 GiB (100.00%) used: 79.1 GiB (66.5%) fs: btrfs
    dev: /dev/sdb8 maj-min: 8:24
  ID-2: /boot/efi raw-size: 547 MiB size: 545.9 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
    dev: /dev/sdb6 maj-min: 8:22
  ID-3: /home raw-size: 118.93 GiB size: 118.93 GiB (100.00%) used: 79.1 GiB (66.5%) fs: btrfs
    dev: /dev/sdb8 maj-min: 8:24
  ID-4: /var/log raw-size: 118.93 GiB size: 118.93 GiB (100.00%) used: 79.1 GiB (66.5%)
    fs: btrfs dev: /dev/sdb8 maj-min: 8:24
  ID-5: /var/tmp raw-size: 118.93 GiB size: 118.93 GiB (100.00%) used: 79.1 GiB (66.5%)
    fs: btrfs dev: /dev/sdb8 maj-min: 8:24
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.64 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 64.0 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 249 Uptime: 8m wakeups: 1 Memory: 7.64 GiB used: 2.68 GiB (35.1%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages:
  pacman: 1386 lib: 371 Client: shell wrapper v: 5.1.16-release inxi: 3.3.18
Garuda (2.6.3-2):
  System install date:     2022-01-20
  Last full system update: 2022-06-15
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

Here are the updates :

:: Synchronisation des bases de données de paquets…
core                                  155.9 KiB   715 KiB/s 00:00 [------------------------------------] 100%
extra                                1716.7 KiB  5.74 MiB/s 00:00 [------------------------------------] 100%
community                               6.7 MiB  15.3 MiB/s 00:00 [------------------------------------] 100%
multilib                              169.6 KiB   835 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur                          1905.7 KiB  2.29 MiB/s 00:01 [------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
:: Replace kwayland-server with extra/kwin? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (78) aha-0.5.1-2  android-udev-20220611-1  bluedevil-1:5.25.0-1  breeze-5.25.0-1  ethtool-1:5.18-1
ffmpeg-2:5.0.1-3  ffmpeg4.4-4.4.2-3  garuda-assistant-2.6.2-1  garuda-dr460nized-2.0.1-2
gst-libav-1.20.3-1  gst-plugins-bad-1.20.3-1  gst-plugins-bad-libs-1.20.3-1
gst-plugins-base-1.20.3-1  gst-plugins-base-libs-1.20.3-1  gst-plugins-good-1.20.3-1
gst-plugins-ugly-1.20.3-1  gstreamer-1.20.3-1  gstreamer-vaapi-1.20.3-1
intel-media-driver-22.4.3-1  kactivitymanagerd-5.25.0-1  kde-cli-tools-5.25.0-1
kde-gtk-config-5.25.0-1  kdecoration-5.25.0-1  kdeplasma-addons-5.25.0-1  khotkeys-5.25.0-1
kinfocenter-5.25.0-1  kmenuedit-5.25.0-1  kscreen-5.25.0-1  kscreenlocker-5.25.0-1
ksystemstats-5.25.0-1  kwallet-pam-5.25.0-1  kwayland-integration-5.25.0-1
kwayland-server-5.24.5-1 [removal]  kwin-5.25.0-1  layer-shell-qt-5.25.0-1  libkscreen-5.25.0-1
libksysguard-5.25.0-1  libnm-1.38.2-1  libnma-1.8.40-1  libnma-common-1.8.40-1
linux-zen-5.18.5.zen1-1  linux-zen-headers-5.18.5.zen1-1  masterpdfeditor-5.8.63-1
mercurial-6.1.4-1  mesa-demos-8.5.0-2  mesa-utils-8.5.0-2  milou-5.25.0-1
networkmanager-1.38.2-1  nm-cloud-setup-1.38.2-1  oxygen-sounds-5.25.0-1
plasma-browser-integration-5.25.0-1  plasma-desktop-5.25.0-1  plasma-firewall-5.25.0-1
plasma-integration-5.25.0-1  plasma-nm-5.25.0-1  plasma-pa-5.25.0-1
plasma-systemmonitor-5.25.0-1  plasma-thunderbolt-5.25.0-1  plasma-workspace-5.25.0-1
polkit-kde-agent-5.25.0-1  powerdevil-5.25.0-2  qt6-5compat-6.3.1-1  qt6-base-6.3.1-1
qt6-declarative-6.3.1-1  qt6-imageformats-6.3.1-1  qt6-svg-6.3.1-1  qt6-translations-6.3.1-1
qt6-wayland-6.3.1-1  sddm-kcm-5.25.0-1  srt-1.5.0-1  starship-1.8.0-1  systemsettings-5.25.0-1
vlc-3.0.17.4-6  xcb-proto-1.15.1-1  xdg-desktop-portal-kde-5.25.0-1  xkeyboard-config-2.36-2
yay-11.2.0-1  zstd-1.5.2-7

Total Installed Size:  1021.26 MiB
Net Upgrade Size:        14.16 MiB

:: Proceed with installation? [Y/n]

So i cant update my system... I you have an idea for me... :innocent:

Have you tried resetting Latte to the default config with the Garuda Assistant?
Use krunner to launch it.
How are you updating?
Always use

garuda-update

(just in case)

2 Likes

Hey,

I'm using garuda-update as usual...
Looking to find how to reset latte...

First try to restart latte from terminal:

latte-dock --replace &

If not working, open krunner with alt+space and search and launch Garuda Assistant, flag Latte and push reset button.

2 Likes

Hey again,

The command in konsole, latte-dock --replace &, did the trick... But if i close Konsole, both are disapearing again...

Try also

latte-dock --replace

From krunner.
If not working, reset config with Garuda Assistant.

When i did latte-dock --replace in Konsole, both docks appears, but again, closing Konsole makes them disappear...

I tried to do a reset of Latte in garuda assistant, but no changes...

Have you logged off & on after the reset?

Yep, but with no changes...

Try delaying latte startup. On KDE startup applications change Latte to eg:
"sleep 3 && /usr/bin/latte-dock"
This is really strange...

4 Likes

That did the trick, thanks a lot :star_struck:
Launching like that

/usr/bin/latte-dock

Just a bit sad that i have lost all my latte-dock config...

1 Like

6 Likes

Yep, you are so right... But i was so sure that restoring a snapshot was giving me my config back...
So i dont have to be so sure about me... :innocent:

Snapshots are not affecting the home directory by default, that's important to know. If it did, restoring snapshots would basically mean losing a lot of data if we are talking about Documents for example. Anyways, nice to see it solved!

3 Likes

I believe this will not work anymore once upgraded to Plasma 5.25.
On all my machines, all my autostart scripts (*.desktop + *.sh) using the sleep command are failing and don't start anymore (but they do once launched manually).

I am currently troubleshooting this and may file a bug at KDE for starters.

This issue is off topic, but since that solution has been suggested and he is using 5.24.5, it would be very interesting to see if @FenDanT can still start latte-dock delayed with sleep command after he upgrades to 5.25. :thinking:

3 Likes

Unfortunately not... After the update i tried to use the sleep command but the problem still remains. So, at this time i had to delete it, waiting for changes.
I had to use this command because i had some flickering problems with my screen. But yet, without the sleep command i don't have such problems...

Hang on, I found a solution that works fine for me, will be testing it on a totally different machine today and if it succeeds I'll post it here. :slight_smile:

2 Likes

Ok got it. This post will be a bit long but I want to explain some caveats.

I tested this "fix" on 2 physical machines and 3 VMs, all of which have Plasma of course but with different KDE experience, therefore different packages and configurations. It works all the time, good news.

For some reason using the sleep command now returns an invalid time interval error msg.

To my personal experience, cause could be one or many:

  • Plasma 5.25 bug
  • Plasma 5.25 deprecated feature
  • A buggy package updated at the same time as 5.25
  • A package that should be updated now that "maybe" 5.25 is handling this feature differently but that package has not been upgraded yet.

I have tried various syntax with the sleep command, bash -c, etc. and it always fails. I could not find anything in Arch Bug list, KDE Bug list, Plasma 5.25 full Changelog and neither on Whoogle. Maybe 5.25 is too new yet.

So the way to fix it may be a small hack or worse could use a deprecated feature of Plasma which at some point will get removed, but for now it works. And until I find something better I will stick with it.

  • Create folder ~/.config/autostart-scripts
  • In that folder, create file latte-dock.sh and make it executable
  • Open the file and paste this code:
#!/usr/bin/bash
sleep 3 && /usr/bin/latte-dock
  • MOVE your ~/.config/autostart/org.kde.latte-dock.desktop out of the way in a safe backup folder
  • LOG OUT Plasma
  • LOG IN Plasma

Normally it should start with 3s delay, you can make it 15s delay if you want to make sure it works and revert back to 3 afterwards.
But Plasma also modified a few things... it moved the autostart-scripts folder to old-autostart-scripts and created a latte-dock.sh.desktop in autostart-scripts which calls the shell script in old-autostart-scripts.

Because of the "old" in the folder name, I tend to think this feature is deprecated.
As I said I will continue searching and learning about this, but for now it works.

:smiley:

6 Likes

Just to note, after the Plasma 5.25, the official Latte-dock maintainer has stated that there are too many issues to tackle regarding the "stable" version of latte, so they recommend making sure you are using the GIT version, also found in Chaotic-AUR, which is were future development will occur.

In the official announcement of Latte v0.11 there will be a specific sentence that will discourage the use of Latte v0.10.x or lower version with Plasma 5.25 and above.
If you are using Plasma 5.25 you should switch to Latte git version As.Soon.As.Possible.
P.S Latte v0.11 is officially scheduled for this August

7 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.