Dolphin is only as root transparent

Hello.
Like the title said - Dolphin is only transparent when I open it as root. Is there a way to change it, so that dolphin is always transparent?

garuda-inxi
System:
Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=43b241d7-bc58-4420-8da4-c4e897970c7c rw [email protected]
splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=5
systemd.unified_cgroup_hierarchy=0
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1560
serial: <superuser required>
Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1560 serial: <superuser required>
UEFI: HUAWEI v: 1.06 date: 09/14/2020
Battery:
ID-1: BAT0 charge: 21.9 Wh (40.0%) condition: 54.8/54.9 Wh (99.8%)
volts: 8.0 min: 7.6 model: DYNAPACK HB4593R1ECW-22T0 type: Li-ion
serial: <filter> status: charging cycles: 71
CPU:
Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 2012 high: 4290 min/max: 1400/2900 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1397 2: 2081
3: 1835 4: 1404 5: 2872 6: 2572 7: 1911 8: 4290 9: 2863 10: 1595 11: 1453
12: 1396 13: 1946 14: 1525 15: 1626 16: 1429 bogomips: 92621
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 3-4:3
chip-ID: 13d3:5451 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
s-diag: 686mm (27.03")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0893 built: 2019
res: 2160x1440 hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76")
diag: 356mm (14") ratio: 3:2 modes: max: 2160x1440 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.4-zen1-1-zen)
v: 4.6 Mesa 22.0.1 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: & Tele RSH driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
IF-ID-1: br-9a7bb5fd2534 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
IF-ID-3: vethf98fe2a state: up speed: 10000 Mbps duplex: full
mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-3:2 chip-ID: 1358:c123 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 180.1 GiB (37.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 SDBPNPZ-512G-1027 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 21117000 temp: 48.9 C scheme: GPT
Partition:
ID-1: / raw-size: 312.5 GiB size: 312.5 GiB (100.00%)
used: 180.07 GiB (57.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.5 MiB (26.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 312.5 GiB size: 312.5 GiB (100.00%)
used: 180.07 GiB (57.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 312.5 GiB size: 312.5 GiB (100.00%)
used: 180.07 GiB (57.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 312.5 GiB size: 312.5 GiB (100.00%)
used: 180.07 GiB (57.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.07 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 52.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 408 Uptime: 20m wakeups: 1 Memory: 15.07 GiB
used: 6.08 GiB (40.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 2123 pacman: 2117 lib: 576 flatpak: 0
snap: 6 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15
Garuda (2.6.1-3):
System install date:     2021-12-30
Last full system update: 2022-04-23
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            postgresql.service [email protected] systemd-oomd.socket

Piece of cake solutions :cake:

Goto Garuda Assistant

  • Then change select Kvantum in reset configs option
  • Select reset configs
  • Logout then Login again

:warning: Warning :
You loose the KDE customisation done by yourself !

Go to Kvantum Manager [🇰 🇻]

  • Click on change/delete theme the theme
  • Select the checkbox transperant windows for Dolphin
  • Select save
Advanced

How to enable translucent background

Well if you are fan of translucency then you have to

  • Go to Settings > Workspace and behaviour > Desktop effects
  • Select the option for Blur, then set 0 noices and 0 blur
  • Enable and Select the option for Translucency then tweak how you want
  • Search for Kwin Scripts and then disable Force blur in that
  • Select Apply

You are done now open a konsole [>_ ] or a dolphin :file_folder: window and test it out

1 Like

I tried loading default Kvantum theme. Transparent Dolphin view is there activated by default. Still only works when opening Dolphin via addon as root. Otherwise it looks same like in sweet theme.

Try to reset config is Garuda assistant

I did. But that didn't work

Try this theme
Sweet-transperent-toolbar (modified)

OR

Goto Application Themes
Type dolphin in application section besides installed theme

OR

If none of them works then

Open konsole and type

$ dolphin

post the output u get in konsole

I already tried the top one.
I wont try the bottom one, since I want it to be blurred (right now it has just a static blue-gray background).

here's the output:

Icon theme "adwaita" not found.
Icon theme "adwaita" not found.
QImage::pixel: coordinate (0,0) out of range
Icon theme "adwaita" not found.

Edit: Icon theme is btw Beatyline. And Dolphin also looks like it

Goto Kvantum Manager > Configure activate theme
Select Transparent Dolphin view

Editz : Sorry, I forgot to mention Configure activate theme
Answered without gui so I went wrong

Like I said - I already did.

Now when I see it - Kvantum isn't blurred either. Thought till now it would be normal

Wait I will do a video or send a bunch of photos togather
Ur themes must be set like in video then customize as you want

Editz : Done capturing editing, sending in few minutes
Sorry for late reply

Watch @ 2x 720p

Note :

  • Theme must be applied twice in Kvantum Manager and in settings
  • Theme should be selected correctly, there is difference between Kvantum and Kvantum-dark

Settings are the same for me. But nothing is transparent (like kate, dolphin, kvantum).
What I've found online is that people with different global screen scale have/had issues. My scale is at 137.5 (it goes up with 6.25% at the time to prevent issues). Maybe there's the issue. Or maybe something in desktop effects or kvim scrips is messed up. Could u show that too?

I fixed it.

Now after reinstalling Garuda I saw, that translucency was gone. It can be fixed with unchecking in Kvantum Hacks -> Disable translucency with non integer scaling. According to some research this could lead to an issue with "annoying artifacts". In these first 5 minutes I didn't had any issues with that) this could lead to "annoying artifacts". In the first 5 min I didn't experienced smth like that

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.