Dolphin and SAMBA : file / folder does not exist

Hi everyone,
since a long time now I'm not available to access to my SYNOLOGY server by SMB protocol by using dolphin explorator.

when I click on my distant disk I receive that response : kf.kio.core: "The file or folder smb://192.168.1.xxx/ does not exist."

I can acces to my server by using command line with smbclient and with a windows computer two (so the server work well).

I have also see other logs when I start dolphin with a terminal and try to acces to the SMB folder :


smbXcli_negprot_smb1_done: No compatible protocol selected by server.
smbXcli_negprot_smb1_done: No compatible protocol selected by server.
kf.kio.slaves.smb: Failed to resolve any WS transport address. This suggests that DNS resolution may be broken. (QUrl("http://{{my server}}/{{UUID here}}"))
org.kde.dolphin: could not find entry for charset= "Other encoding ()"
kf.kio.core: "The file or folder smb://{{my server}}.local/ does not exist."

Thank for your help

System:
Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f327471a-c329-462b-a1dc-fca7bb7580b2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20TH001AFR v: ThinkPad P1 Gen 3
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20TH001AFR v: SDK0T08861 WIN
serial: <superuser required> UEFI: LENOVO v: N2VET26W (1.11 )
date: 11/16/2020
Battery:
ID-1: BAT0 charge: 72.3 Wh (100.0%) condition: 72.3/80.4 Wh (90.0%)
volts: 17.2 min: 15.4 model: SMP 5B10X19049 type: Li-poly serial: <filter>
status: full cycles: 145
Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i9-10885H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165)
stepping: 2 microcode: 0xF0
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3426 high: 4803 min/max: 800/5300 scaling:
driver: intel_pstate governor: performance cores: 1: 4800 2: 4800 3: 2400
4: 2400 5: 2400 6: 2400 7: 2400 8: 4461 9: 4800 10: 2400 11: 4777
12: 4803 13: 2400 14: 4778 15: 2400 16: 2400 bogomips: 76800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-07) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s ports: active: none off: DP-1
empty: DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1fb8 class-ID: 0300
Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-8:3 chip-ID: 04f2:b6cb class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1015x285mm (39.96x11.22")
s-diag: 1054mm (41.51")
Monitor-1: DP-1 mapped: DP-1-0 note: disabled pos: primary,left
model: Samsung C27F390 serial: <filter> built: 2020 res: 1920x1080 hz: 60
dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 pos: primary,right model-id: CSO 0x1500 built: 2019
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 3840x2160
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.6
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:7 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 227.94 GiB (23.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 5108AGLA
temp: 43.9 C scheme: GPT
Partition:
ID-1: / raw-size: 585.94 GiB size: 585.94 GiB (100.00%) used: 227.91 GiB
(38.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 33.6 MiB
(13.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 585.94 GiB size: 585.94 GiB (100.00%) used: 227.91
GiB (38.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 585.94 GiB size: 585.94 GiB (100.00%) used: 227.91
GiB (38.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 585.94 GiB size: 585.94 GiB (100.00%) used: 227.91
GiB (38.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.98 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 68.0 C pch: 59.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 3653 fan-2: 3473
Info:
Processes: 351 Uptime: 54m wakeups: 351 Memory: 30.98 GiB used: 5.8 GiB
(18.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1524 lib: 363
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2021-11-16
Last full system update: 2022-08-21 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Could be this bug between KDE and Samba...
https://bugs.kde.org/show_bug.cgi?id=453090
Even clearer in this duplicate
https://bugs.kde.org/show_bug.cgi?id=457661

2 Likes

I finaly find two workaround :

  1. Update Windows Share setting to set the good ids for connecting to the NAS server. I have a static connexion that work only if I have one unique SMB server.
  2. Make a manual mount point. (Solution that I prefered)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.