Docker unable to run Containers

error: package 'garuda-common-settings' was not found

So.... from what I can tell you did something like

sudo pacman -Rdd garuda-common-settings

Honestly, just.. why. If you're not aware of the consequences of such command line parameters, you probably shouldn't do them.

sudo pacman -S --asdeps garuda-common-settings

Then garuda-inxi should work.

2 Likes

Maybe we could see something like:

cat /var/log/pacman.log | grep 'garuda-common-settings' | grep 'removed'

to see then what else was removed that day.

1 Like

[2021-10-30T19:27:51+0530] [ALPM] removed garuda-common-settings (2.2.0-1)

I honestly don't remember removing it unless it there were conflicting packages...

Trust me, I didn't run any inappropriate command from telegram...Or from anywhere for that matter...


Anyways...The issue is solved...
This post solved two issues :sweat_smile: :grin:

Probably shouldn't do it then either! -Rdd doesn't fix stuff. It may look like it fixes stuff, but it really doesn't. There's a reason conflicts exist, and you should address them appropriately!

1 Like

Maybe just out of curiosity you could :

cat /var/log/pacman.log | grep '2021-10-30' | grep 'removed'

to see what else was removed and maybe remember why.
But, as you said, all good now... :wink:

1 Like

[2021-10-30T19:27:51+0530] [ALPM] removed garuda-common-settings (2.2.0-1)
[2021-10-30T19:28:01+0530] [ALPM] removed profile-sync-daemon (6.44-2)
[2021-10-30T19:28:05+0530] [ALPM] removed irqbalance (1.8.0-1)
[2021-10-30T19:28:05+0530] [ALPM] removed preload (0.6.4-7)
[2021-10-30T19:28:06+0530] [ALPM] removed haveged (1.9.15-1)
[2021-10-30T19:28:06+0530] [ALPM] removed zram-generator (0.3.2-1)
[2021-10-30T19:28:08+0530] [ALPM] removed ananicy-cpp (1.0.0.rc4-1)
[2021-10-30T19:28:08+0530] [ALPM] removed nohang (0.2.0-1)
[2021-10-30T19:28:08+0530] [ALPM] removed memavaild (0.6-1)
[2021-10-30T19:28:14+0530] [ALPM] removed ananicy-rules-git (2.2.1.r60.g0b06948-1)
[2021-10-30T19:28:14+0530] [ALPM] removed prelockd (0.9-1)

Well...I removed A LOT of packages that day...Fore sure...

Oh well...I remember now...I had removed all performance tweaks... :point_down:
And enabled all powersave-tweaks... :point_down:


I can see that performance-tweaks is an optional dependency of garuda-common-settings...

But why did garuda-common-settings get removed when I had only removed performance-tweaks...?

1 Like

That doesn't happen. It doesn't just get removed like that. You did a command with -dd most probably.

Try this:

grep -re '^.*2021-10-30.*\[PACMAN\] Running.*' /var/log/pacman.log
1 Like
[2021-10-30T00:00:07+0530] [PACMAN] Running '/usr/bin/pacman -Fy'
[2021-10-30T00:34:55+0530] [PACMAN] Running 'pacman -Sy --needed --noconfirm garuda-update'
[2021-10-30T00:35:43+0530] [PACMAN] Running 'pacman -Syy'
[2021-10-30T00:35:58+0530] [PACMAN] Running 'pacman -S --needed --noconfirm garuda-hotfixes archlinux-keyring chaotic-keyring'
[2021-10-30T00:35:58+0530] [PACMAN] Running 'pacman -Su'
[2021-10-30T15:42:24+0530] [PACMAN] Running 'pacman -Syu'
[2021-10-30T19:27:02+0530] [PACMAN] Running 'pacman -Rc prelockd ananicy-rules-git memavaild nohang ananicy-cpp zram-generator haveged preload irqbalance profile-sync-daemon'
[2021-10-30T19:28:22+0530] [PACMAN] Running 'pacman -S --needed intel-undervolt'
[2021-10-30T19:30:59+0530] [PACMAN] Running '/usr/bin/pacman --noconfirm --noprogressbar -S linux linux-cacule linux-lts linux-zen linux-headers'
[2021-10-30T19:34:49+0530] [PACMAN] Running '/usr/bin/pacman --noconfirm --noprogressbar -S linux linux-zen linux-lts linux-cacule linux-headers'
[2021-10-30T19:43:37+0530] [PACMAN] Running '/usr/bin/pacman --noconfirm --noprogressbar -S linux linux-cacule linux-zen linux-lts linux-headers'
[2021-10-30T19:44:58+0530] [PACMAN] Running 'pacman -Sy linux'
[2021-10-30T20:55:03+0530] [PACMAN] Running 'pacman -Syu linux'

What the f*ck

I'm gonna murder someone.

Heya @dr460nf1r3 btw, why is garuda-common-settings not a dependency of garuda-dr460nized?

4 Likes

@TNE Found the bug!!

-c, --cascade        remove packages and all packages that depend on them

I never ran these commands...
I was a noob back then and so I wouldn't add any flags to any command that I didn't know...

Besides..I had unchecked the performance-tweaks box (and all the other boxes related to it) and it opened a konsole window where I had to put in my sudo password to remove the selected packages...
I had no control over the command it was running...

2 Likes

It was preinstalled by our iso-profiles so I never bothered making it a dependency of the settings package. But you are right, gonna add it to prevent situations like this :eyes:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.