DNS Setting slows down internet

Since the last update was my internet super slow.
I did jump back to an earlier snapshot, and it was still the same.

I figured now out, that it was the DNS Setting in Garuda Assistant.


Changing that back to Default from Cloudflare, fixed the issue.
Changing then back to Cloudflare, works again.

Some other people might experience the same, so this could work for you.

Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fdd9180e-818d-4cd6-8f82-b52c0fbaca7e rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: HP EliteBook 820 G3 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 807C v: KBC Version 85.61 serial: <superuser required>
UEFI: HP v: N75 Ver. 01.05 date: 03/22/2016
ID-1: BAT0 charge: 35.2 Wh (97.5%) condition: 36.1/36.1 Wh (100.0%)
volts: 12.8 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: not charging
Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1465 high: 1500 min/max: 400/2800 scaling:
driver: intel_pstate governor: powersave cores: 1: 1496 2: 1382 3: 1500
4: 1483 bogomips: 19200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1916 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-9:5 chip-ID: 05c8:0383 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: LG Display 0x0498 built: 2015 res: 1366x768 hz: 60
dpi: 125 gamma: 1.2 size: 277x156mm (10.91x6.14") diag: 318mm (12.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: Mesa Intel HD Graphics
520 (SKL GT2) direct-render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1570 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 894.26 GiB used: 38.96 GiB (4.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Patriot model: M.2 P310 480GB
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EDFM90.0 temp: 25.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 1103 scheme: MBR
ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.42 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 44.0 C pch: 38.5 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 219 Uptime: 11m wakeups: 2 Memory: total: 8 GiB note: est.
available: 7.42 GiB used: 4.16 GiB (56.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1355 libs: 334 tools: octopi,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-19
Last full system update: 2023-09-09
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Hope this helps someone.


Yeah, DNS servers are really important.

They basically convert the domain names to IP Addresses. For example, garudalinux.org is the domain name for our website. But the network chip can only exchange data between IP address. And our pc obviously don’t know its IP ( as they can’t store all the domain names and their ip addresses )

So, DNS server asks various “registered” name servers for the website’s IP. If a given name server has the domain name, it returns its matching IP to the DNS server, which gives it to client, and client communicates with the server.

So, the DNS server plays a critical role in the internet speeds, especially latency while browsing the web. Also, it plays a very critical role in users privacy, because all the addresses you are going to visit can be easily tracked by DNS server.

Cloudflare is a really trusted DNS server, and many website use cloudflare as their name server as well, including us.

You can use whois command to see Name Server of the given domain name.

So, I guess, Cloudflare should be better than other DNS. I wonder why it is not default DNS server.


To be honest, I think everyone could setup their own local DNS server, including filtering.

Something like Pi-Hole, Ad Guard Home, or the most advanced one, eBlocker.

I even own two Raspberry Pi’s, that I could use for this. But I am too lazy :stuck_out_tongue:

And in this case, as mentioned, has the choice of Cloudflare - although probably not to their fault - lead to the internet being unreliable.

I assume this is down to some other setting of ours, that has conflicted with it. But that’s the second time, in like a year, that the Garuda Assistance setting for an alternative DNS server has brought down my internet.

So not a good default setting.
For now.

1 Like

Interesting, what gets set by default? Should probably fix that for everyone.

I have used Cloudflare for ages and I highly recommend it. However, there is a very small subset (rare) of hardware that is known to react badly if using Cloudflare with a Linux machine. In these rare cases using Cloudflare can result in much slower internet speeds.

You should always test alternate DNS servers if you are experiencing slow speeds, just to eliminate that factor as a possibility when troubleshooting connectivity issues.


i wonder what would cause that?

1 Like

Old hardware used by some internet providers.


If I remember correctly (have been using cloudflare for ages), the dafault behaviour is NetworkManager’s default, which generates an /etc/resolv.conf file, setting as nameserver your gateway, so that normally the DNS server settings defined on your router are used.
I tried to go through the “theory” in:
But I gave up, not being able at the moment to go back to a default config.
In general, if we want to change the default, we could try applying the logics we implement in the Garuda Assistant? Maybe here:

1 Like

I use Nextdns. Very easy and works on every device

So basically DHCP doing its job. I see :eyes: I wonder whether NetworkManager needs to be restarted to re-apply the configs if the current DNS server was removed. After all it can’t know about the change.

I didn’t know that one yet! Seems pretty interesting from a feature-wise perspective. But… no Docker? Not even binaries? Needs you to run either a VM or an actual RPi :face_with_spiral_eyes:

1 Like

An actual pi is like ÂŁ10 and you can virtualise the pi software anyway so seems alright to me

The whole thing is meant to be run network wide.
Ad Guard Home has a Docker.

The benefits of all these DNS Sinkholes is that you don’t download ads to begin with.

So they are not only blocked locally, but they will never occupy network bandwidth.
This leads obviously to increased download speeds for webpages with ads.

In this regard, it is similar to hblock, I wonder why we don’t turn this on by default?
We have it as an option in Garuda Assistance.

It works great.

The only benefit I can see for Pihole and Co, is that you can protect devices, who are not able to install hblock themselves.

To me, any DNS server that does not do censorship, like Google, AdGuard and Cloudflare should be fine.

In addition, we could also just use DNS over HTTPS:

I have no idea, why this is disabled in Librewolf and Firedragon by default.

I just tested DNS.Watch and Adguard DNS as well:
The positive note is, that it’s not Cloudflare.

All those alternatives slow down my internet, to the degree that it’s almost unusable.
I assume, that the implementation of the setting might not apply it correctly, but I have yet no idea, how this is done.

Can anybody help me, to track this down?
Here again, garuda-inxi: Paste.ee - View paste 2xvga

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.