Distorted Graphics after waking up from Sleep mode

Hello.
I recently installed Garuda on my PC and ever since, I have been experiencing a distorted graphics related problem. Let me explain in detail.
Whenever I wake up my PC from sleep and try to open any stale windows , the graphics gets distorted (see pictures below). For example I am using Visual code Studio, and I put my PC to sleep (with VS code window still open). When I start the PC after some time, and open VS code from, it goes all black and distorted. The only solution is to re-start the PC.

Since my PC has dual boot (windows and Garuda), I thought I need to upgrade windows BIOS, but that did not help. I also tried updating Nvidia Graphics driver both in Garuda and Windows, but no help.

Is there any possible solution to this issue?

Here is the system information:

inxi -Faz
System:
  Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=7349e67d-eaa6-4bbb-81ae-787c5283a4f1 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=45a313d6-3343-4216-8389-6c025119b6c8 loglevel=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING EDGE WIFI (MS-7C37)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.G3
    date: 09/26/2021
CPU:
  Info: model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 4x16 MiB
  Speed (MHz): avg: 2436 high: 4363 min/max: 2200/4672 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 4363 2: 2105
    3: 2057 4: 2196 5: 2200 6: 2199 7: 2199 8: 2199 9: 2195 10: 2057 11: 3600
    12: 2057 13: 3502 14: 2101 15: 2057 16: 2198 17: 2195 18: 2196 19: 2199
    20: 2199 21: 2199 22: 2056 23: 4038 24: 2098 bogomips: 182396
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Micro-Star MSI
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 2d:00.0
    chip-ID: 10de:1e89 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.9x11.9")
    s-diag: 610mm (24")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 2d:00.1 chip-ID: 10de:10f8
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel port: d000
    bus-ID: 27:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak]
    driver: iwlwifi v: kernel bus-ID: 29:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlp41s0 state: down mac: <filter>
  IF-ID-1: vpn0 state: up speed: 10 Mbps duplex: full mac: N/A
Bluetooth:
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-4:2 chip-ID: 8087:0aa7 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.27 TiB used: 1017.27 GiB (43.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXE7 temp: 39.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
Partition:
  ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 23.25 GiB (46.5%)
    fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-2: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-3: /home raw-size: 114.41 GiB size: 114.41 GiB (100.00%)
    used: 17.07 GiB (14.9%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%)
    used: 23.25 GiB (46.5%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%)
    used: 23.25 GiB (46.5%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 30 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: swap-2 type: zram size: 15.6 GiB used: 158.2 MiB (1.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Info:
  Processes: 517 Uptime: 3h 22m wakeups: 0 Memory: 15.6 GiB
  used: 7.16 GiB (45.9%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 1496 pacman: 1490 lib: 347 snap: 6 Shell: Bash
  v: 5.1.12 running-in: konsole inxi: 3.3.11

Here are some screenshots of the distorted graphics:
https://drive.google.com/drive/folders/1DzzDXx3ftRCyDejUk39Oqlaq8kr5F74X?usp=sharing

Hi there, welcome.
Have you tried how it goes with different kernels, especially linux-lts?
Maybe you could give a look at the Arch wiki as well.

No, I havent tried yet. Do you recommend trying it? Could you please re-direct me to any helpful resource that explains step-by-step procedure?

Thank You so much!

The idea comes from the arch wiki entry above, and was successful in a similar case in the past.
There are several ways to install a new kernel:

  • sudo pacman -S linux-lts linux-lts-headers
  • Garuda Settings Manager -> Kernels -> push Refresh -> select kernel to install

But... you may want to forgive me, this cannot get into a basic Arch linux guide... :wink:

1 Like

Hi,
I installed this new kernel. But I can not figure out how to switch to this Kernel.

When i do Garuda Settings Manager -> Kernels -> push Refresh , linux-lts already says installed. I also tried rebooting, but its still using the old kernel.

Am I missing anything?
Thank You

You have to select it in the grub menu when you boot. Most likely under advanced options.

2 Likes

Awsome. I found it.
Shall I remove the old kernel, so that from the next restart linux-lts will automatically load up?

Learn to search!!!

3 Likes

Sorry, yes you are right! Will do it now.
Thank you @filo for all the help.

2 Likes

And first of all make sure that the issue is solved....

2 Likes

Yeah...thats the ultimate subject of worry. I will try and update..if the issue still persists.

1 Like

You should also test altering the settings for sleep states in your bios (assuming they are user alterable).

1 Like

@Sangeet Did switching to linux-lts fix your issue? I have an RTX 3060 and am having similar issues.

No man @kiddogdad ..It has now started to even freeze quite often. Dont know shit..whats wrong. I even tried updating graphics driver..no help.


Test other alternate kernels, especially linux-mainline , linux-next-git , and linux.


Have you tested performance on a Garuda live disk (try Gnome & Xfce as well) for comparison?


If your BIOS config has this option, change the sleep option from "Windows" to "Linux".


Try switching to a TTY then back to your X session when glitching occurs.


Or from the TTY, try triggering a DPMS restart:

xset dpms force off ; sleep 0.1; xset dpms force on

Or, you could try disabling DPMS / monitor power management in KDE.


Try disabling your compositor before suspending.


Try installing linux-firmware-git, then restart. Reinstall the linux-firmware package afterwards if there is no improvement.


Please provide feedback on all suggestions.


2 Likes

I am also having this issue. Whenever I use sleep mode, and then wake the computer, I get a system report, and the only way to correct is to either log out and back in, or restart the computer.

Steps to reproduce:

  1. Click User Switcher icon in top right corner
  2. Click Leave
  3. Click Sleep
  4. Wake computer

Expected Result: Computer wakes normally, user can resume operation with no issues
Actual Result: Screen becomes distorted, sometimes unusable

I am a new user, so I am unable to attach screenshots. The notification is from KWin Window Manager, stating, "Desktop effects were restarted due to a graphics reset".

Thanks in advance! Lets me know if there are any questions or additional info needed.

Welcome to the forum.

Did you already test all the suggestions on this thread?

As this thread has been abandoned, you should really open your own help request.

Please provide a garuda-inxi output on your opening post.

2 Likes