Display issue, color fail

Hello everyone I just installed Garuda and I am having some issues with display. With the following images I can explain my problem.

So I have an image with Hardware Acceleration turned on.
As you can see, Blues and maybe the others as well look kinda off. You can tell in the blues for sure tho. The color looks more like a purple then a blue. Not sure what to do to fix that problem. Will appreciate any help and thanks in advance


here are my system info

 OS: Garuda Linux x86_64 
     Host: HP Pavilion 15 Notebo 
     Kernel: 5.9.6-zen1-1-zen 
     Uptime: 38 mins 
     Packages: 1917 (pacman) 
     Shell: zsh 5.8 
     Resolution: 1366x768 
     DE: Plasma 5.20.2 
     WM: KWin 
     WM Theme: WhiteSur-dark 
     Theme: WhiteSurDark [Plasma 
     Icons: Tela-circle-dark [Pl 
     Terminal: konsole   
     Terminal Font: Source Code  
     CPU: Intel i3-4005U (4) @ 1 
     GPU: Intel Haswell-ULT  Memory: 2841MiB / 15939MiB ```

I think it has to do with hardware acceleration but not sure. Only saying that cause when I disable hardware acceleration it looks fine. But then again its on the whole system and I kinda need the hardware acceleration cause there is a certain game that lags terribly without it

How you make this picture?

More details in

inxi -Fxxxza



The picture I took it by just using the normal screenshot tool(spectacle). I did take another picture without using hardware acceleration.

system info

  Kernel: 5.9.6-zen1-1-zen x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
  root=UUID=9b8a9717-42ef-49b2-824c-9523f971ffc4 rw [email protected] quiet 
  splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Garuda Linux 
  Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC 
  v: 0896100000304100000620100 serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 2163 v: 29.42 serial: <filter> UEFI: Insyde 
  v: F.72 date: 03/09/2018 
  ID-1: BAT0 charge: 23.7 Wh condition: 23.7/23.7 Wh (100%) volts: 16.9/14.8 
  model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Full 
  Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 13569 
  Speed: 1596 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1596 2: 1596 
  3: 1596 4: 1584 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 
  Device-2: Suyin HP Truevision HD type: USB driver: uvcvideo bus ID: 2-3:3 
  chip ID: 064e:e264 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.2.1 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k5.9.6-zen1-1-zen 
  Device-1: Realtek RTL8188EE Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8188ee v: kernel port: 4000 
  bus ID: 08:00.0 chip ID: 10ec:8179 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 09:00.0 
  chip ID: 10ec:8136 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 698.64 GiB used: 25.64 GiB (3.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Western Digital model: WD7500BPVX-60JC3T0 
  size: 698.64 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: GPT 
  ID-1: / raw size: 187.73 GiB size: 187.73 GiB (100.00%) 
  used: 25.61 GiB (13.6%) fs: btrfs dev: /dev/sda6 
  ID-2: /home raw size: 187.73 GiB size: 187.73 GiB (100.00%) 
  used: 25.61 GiB (13.6%) fs: btrfs dev: /dev/sda6 
  ID-3: /var/log raw size: 187.73 GiB size: 187.73 GiB (100.00%) 
  used: 25.61 GiB (13.6%) fs: btrfs dev: /dev/sda6 
  ID-4: /var/tmp raw size: 187.73 GiB size: 187.73 GiB (100.00%) 
  used: 25.61 GiB (13.6%) fs: btrfs dev: /dev/sda6 
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 996.2 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 996.2 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 996.2 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 996.2 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  System Temperatures: cpu: 61.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 274 Uptime: 2h 06m Memory: 15.57 GiB used: 3.37 GiB (21.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1917 lib: 559 flatpak: 0 snap: 0 Shell: Zsh v: 5.8 
  running in: konsole inxi: 3.1.06```

Also thank heard about you guys thru Tylerś Tech youtube.
1 Like

Thank you, because I never had a problem with it and I don't use an HP Notebook I have to pass.

I am almost sure that you can still be helped here.

What did your search on the internet show regarding this problem?

Well I do distro hop a lot and kinda got my problem fixed with some kind of RGB setting using terminal. Not sure what the command was.I've tried Pop Os, Mx Linux,Linux Mint, Fereon Os, Manjaro, KDE Neon, Ubuntu, Fedora and this one of course. The only 2 that hasn't given me problems is Linux Mint and Manjaro. But heard about this distro and wanted to try it out. And it was fine when I ran it thru the USB but I have noticed that with the new updates that's when it starts messing up.

I would test the linux-lts kernel then. Be sure to install the linux-lts-headers as well.

1 Like

How do we do the headers?

I tried the Lts kernel and that didn't fix my problem @SGS :confused: I mean that's the only problem I have I think. Just the colors.

You can change and adjust colors in kde settings.


So going into System settings> Color Corrections> add profile> and choosing from the already installed ones, I chose "Apple RGB" and that for the most part fixed my problem.