Display applet disappears

The Display applet has vanished from the latest Cinnamon update (the one that was pushed a few days ago). I've had to revert to a pre-update snapshot to get it back. Every time I run an update, it vanishes...

Most odd, and totally annoying as I need to set fractional scaling for my in-laptop-display and setup my docked setup for my 34" ultrawide at work.

Hi @HughF, your post has been moved to a new thread since it is an unrelated issue.

Please post the output of

garuda-inxi

and add any additional troubleshooting information that may be relevant to people trying to help.

1 Like

This is pre-upgrade:

System:
  Kernel: 5.18.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=167b0d8e-27dd-4c93-b4b5-833a9f401ef3 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.34 wm: muffin vt: 7
    dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401IV_GA401IV
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: GA401IV v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: GA401IV.220 date: 03/14/2022
Battery:
  ID-1: BAT0 charge: 50.7 Wh (79.0%) condition: 64.2/76.0 Wh (84.5%)
    volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: discharging
CPU:
  Info: model: AMD Ryzen 9 4900HS with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1607 high: 2362 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 1558 2: 1397
    3: 1728 4: 1416 5: 1397 6: 1396 7: 1396 8: 1396 9: 1397 10: 2133 11: 1453
    12: 1658 13: 1434 14: 2362 15: 2204 16: 1397 bogomips: 95818
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1 off: eDP-1 empty: none
    bus-ID: 04:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-2: Chicony HP HD Camera type: USB driver: uvcvideo
    bus-ID: 5-1.3.1:23 chip-ID: 04f2:b5bd class-ID: 0e02
  Device-3: Chicony HP IR Camera type: USB driver: uvcvideo
    bus-ID: 5-1.3.2:24 chip-ID: 04f2:b5be class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: amdgpu
    unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 6880x2880 s-dpi: 96 s-size: 1820x762mm (71.65x30.00")
    s-diag: 1973mm (77.68")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary model: HP ENVY 34
    serial: <filter> built: 2017 res: 6880x2880 dpi: 219 gamma: 1.2
    size: 797x333mm (31.38x13.11") diag: 864mm (34") modes: max: 3440x1440
    min: 720x400
  Monitor-2: eDP-1 mapped: eDP note: disabled model: AU Optronics 0xe68c
    built: 2019 res: 6880x2880 dpi: 210 gamma: 1.2
    size: 309x174mm (12.17x6.85") diag: 355mm (14") ratio: 16:9 modes:
    max: 2560x1440 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_sof_amd_renoir
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: HP ENVY 34 type: USB driver: hid-generic,snd-usb-audio,usbhid
    bus-ID: 5-1.3.4:25 chip-ID: 03f0:0c47 class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.18.1-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 5-4:11 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 88.06 GiB (9.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPNPZ-1T00-1002 size: 953.87 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21106000 temp: 33.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 467.61 GiB size: 467.61 GiB (100.00%)
    used: 88.04 GiB (18.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 25.9 MiB (10.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.61 GiB size: 467.61 GiB (100.00%)
    used: 88.04 GiB (18.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-4: /var/log raw-size: 467.61 GiB size: 467.61 GiB (100.00%)
    used: 88.04 GiB (18.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-5: /var/tmp raw-size: 467.61 GiB size: 467.61 GiB (100.00%)
    used: 88.04 GiB (18.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.11 GiB used: 2.2 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: amdgpu temp: 39.0 C
  Fan Speeds (RPM): cpu: 2400
Info:
  Processes: 410 Uptime: 2h 22m wakeups: 3 Memory: 15.11 GiB
  used: 7.13 GiB (47.2%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1583 lib: 373 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2021-03-24
  Last full system update: 2022-06-06
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Timeshift (maybe)
  Failed units:            systemd-guest-user.service 

And have you checked for any Cinnamon-related bug reports, specifically regarding that Cinnamon Applet? Those things will be out of the hands of Garuda developers most generally.

3 Likes

Hi and welcome, what happens after updating and rebooting?

2 Likes

The display settings should be getting changed through System Settings -> Display.

If you click the menu button on the taskbar or hit the meta key and type "settings" or "system settings" it should come right up. On my system the display settings window looks like this:

Is this the option you are missing, or have you been using something else to configure your display?

3 Likes

System Settings -> Display is not present post-upgrade.

This is the applet that I have used for years to configure my displays, and I've been using Cinnamon for a long time now.

Not yet, no.

Hi there, welcome to the community.

I am facing similar issue, and as I have to switch between refresh rates regularly on my laptop, I can understand your problem.

One of the workaround, as mentioned, is Cinnamon Settings -> Display
It is accessible on my side.

Also, I will try to figure out some solution to the issue ASAP.
Thanks for reporting the bug.

5 Likes

Sorry, I forgot to update

Solution

Run
sudo sed 's/cinnamon-control-panel/cinnamon-settings/' /usr/share/applications/cinnamon-display-panel.deskto

And logout/reboot.

Explanation

For some reason that I don't know, Cinnamon devs have changed cinnamon-settings to cinnamon-control-panel in applet. This command replaces cinnamon-control-panel with cinnamon-settings in the applet.

PS : Marking it solved now.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.