Disney+ stopped working systemwide

Hello,

Dunno if this is the right forum, just wanted to check if anyone else has the issue - and it is thereby a general problem - or if it's just me.

Started two days ago I think that Disney+ stopped working. At first I could solve it by removing website-data, yesterday it worked after I removed website data and rebooted, by now it's all for naught, it just won't work anymore.

To be precise, the actual videos do not work. The website itself can be accessed, but after I click on a show or movie to stream, it just doesn't load. Tried it with firefox, firedragon and brave. No luck. Tried it with my Garuda (on my Desktop) and my Arch (on my Laptop) and with both it doesn't work... which makes me think, it might be a general issue with Disney+.

I just wanted to know if anyone else experiences this issue. I tried searching for it but no luck so far. I'll ask the Disney-support tomorrow if it still doesn't work then.

 ╰─λ garuda-inxi
System:
  Kernel: 6.0.5-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
    root=UUID=b466176b-73a7-439c-b9e8-9a1e0e545d70 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=0fe3174d-c759-439b-843b-fd7b4fafa25e loglevel=3
    amd_pstate.shared_mem=1
  Desktop: GNOME v: 42.5 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: H.H0
    date: 05/19/2022
CPU:
  Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 789 high: 2302 min/max: 550/4560 boost: enabled
    scaling: driver: amd-pstate governor: ondemand cores: 1: 710 2: 2302
    3: 1062 4: 550 5: 550 6: 630 7: 550 8: 540 9: 706 10: 964 11: 1071
    12: 630 13: 590 14: 550 15: 630 16: 590 bogomips: 124917
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Sapphire
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2,DP-3,HDMI-A-1 bus-ID: 2f:00.0 chip-ID: 1002:73bf
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.83x15.00")
    s-diag: 987mm (38.84")
  Monitor-1: DP-1 mapped: DisplayPort-0 model: M40-144 serial: <filter>
    built: 2021 res: 3440x1440 dpi: 94 gamma: 1.2
    size: 926x387mm (36.46x15.24") diag: 995mm (39.2") modes: max: 3440x1440
    min: 720x400
  OpenGL: renderer: AMD Radeon RX 6800 (navi21 LLVM 14.0.6 DRM 3.48
    6.0.5-1-cachyos) v: 4.6 Mesa 22.2.2 direct render: Yes
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: bus-ID: 5-3:2 gen: 4 chip-ID: 1b1c:0a6b speed: 16 GT/s class-ID: 0300
    serial: <filter> lanes: 16 bus-ID: 2f:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI X570-A PRO
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Corsair HS80 RGB Wireless Gaming Receiver type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.5-1-cachyos running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.73 TiB used: 992.63 GiB (35.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte
    model: GP-ASM2NE6500GTTD size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: EGFM13.0 temp: 48.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 970 EVO Plus
    500GB size: 465.76 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7
    temp: 39.9 C scheme: GPT
  ID-3: /dev/nvme2n1 maj-min: 259:6 vendor: Western Digital model: WD BLACK
    SN750 SE 1TB size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 711240WD
    temp: 32.9 C scheme: GPT
  ID-4: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 107.94 GiB
    (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 25.9 MiB
    (8.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 107.94
    GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 107.94
    GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 107.94
    GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 62.72 GiB used: 512 KiB (0.0%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 34.39 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 33.0 C gpu: amdgpu temp: 44.0 C
    mem: 50.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 818 fan-3: 449 fan-4: 545 fan-5: 564
    fan-6: 0 fan-7: 0 gpu: amdgpu fan: 0
Info:
  Processes: 402 Uptime: 1m wakeups: 0 Memory: 62.72 GiB used: 3.41 GiB
  (5.4%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1707 libs: 520
  tools: pamac,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: guake inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2022-08-07
  Last full system update: 2022-10-27
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

Cya

1 Like

Try

qtwebflix-git

:point_up_2:

2 Likes

Unfortunately the same happens with qtwebflix

However, some output:

 ╰─λ qtwebflix -p disneyplus.com
Provider is set
site is set to "disneyplus.com"
Provider is set
site is set to "disneyplus.com"
js: Uncaught TypeError: Cannot read property 'AutoJoinPolicy' of undefined
js: Possible Unhandled Promise Rejection: TypeError: Cannot read property 'deviceProfile' of undefined
1 Like

Have the same issue with Chrome and Firefox. Now on two machines. Since around 26th Oct. 2022.

I had a surreal chat with Disney Plus customer support which ended with the statement that "Linux is not supported"

In the Chrome developer console I see "[MelHiveLoader] Player scripts reset"
I am pretty sure they changed something on their side.

2 Likes

Ah, so Disney now too.

Only still had it because - other than Prime (SD) and Netflix (720p) - Disney apparantly did not discriminate against Linux-users.

If they keep this policy up that'll be the next termination.

Ps. The Support-Live-Chat doesn't work either. xD Well...

4 Likes

The life chat worked for me.
They seriously asked me to unplug my PC and router to solve a possible "synchronization" issue.
It was hilarious, and I am still looking for a place to post the chat.
Maybe I can send it to you as a private message.

At one point I was asking the guy if he's an AI or a real person.

3 Likes

Same thing happened with HBOMax in August, 2020 and lasted a few months. They had switched to a higher Widevine security model than previously used, and it wasn't available to Linux. It was remedied a few months later when HBO went with a less restrictive Widevine version.

Your problem may be similar. You could try it in a Windows VM maybe.

EDIT: The whole "streaming in Linux" issue is a fiasco, as far as I'm concerned. Even when streaming works, 1080p is only available with Netflix and/or YouTube, assuming the right FF or Chrome extension is working. The biggies--Prime, Hulu & HBOMax won't stream above 720p. I would guess Disney may be in the same boat.

And that's what pisses me off about the whole thing. I am forced to run Windows if I want to get the higher-resolution streaming that I pay to receive. And it will probably remain that way until some Linux software engineer gets a bug up his/her butt and decodes the whole effing mess for us less-than-God-like mortals. And that's way above my pay grade.

End of rant. :frowning:

4 Likes

Well. Yeah.

Then again, Mozilla VPN only costs 5€/month. So... I mean... if the streaming-services don't want my money...

Do that. I love having a good laugh. ^^

A lot of people have used that to excuse their own criminal activity. Stealing is still stealing. Says me, the thief. Even when c00ter wants to be a good little reformed user and walk a narrower path than previously trod. They throw bricks! :frowning:

1 Like

I take a more pragmatic approach. If the companies make me a good deal where I can actually use the product I'm buying on the device I choose, I'm happy to pay them.

If they refuse to do so, well, their loss.

Edit: But well. Don't wanna make this into a religious war either. ^^ But I do wonder: The DRM is there so people cannot capture the video. However, a very short time after anything gets released on streaming-sides, it's widely available on every illegal hoster on the net. So... does it just not work? Or are there leaks in the companies? I wonder what reasoning leads the streaming-services to implement stricter and stricter DRM - to the loss of the end-user - while the distribution of the content illegaly seems to be not at all restricted by that.

1 Like

Google Chrome on Wine may work.

I have the same problem.
After a little "investigation", their scripts cannot recognize the Linux systems. It's based on the User-Agent so change it into some as Windows and it should start working :wink:

8 Likes

Vertisan, Could you give me more information to that solution?

By the way, I put the help desk chat on my homepage: Disney Plus Support Chat

1 Like

Omg it actually does. You're a true hero. :smiley:

So, if someone - like me - didn't know how to do that I'll spare them the trouble of searching for it. I used this guide and the user agent

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36 Edge/12.246

And it does work again. Picked the user-agent from a list.

4 Likes

Have you tried removing the fuses and putting them back in yet? ^^

You need to use some of the extensions to change the default User-Agent or follow e.g. this article: How to Change User-Agents in Chrome, Edge, Safari & Firefox

2 Likes

I noticed the same issue. Did not have any luck changing the useragent. I did try the following which worked. DisneyPlus-desktop / Binaries / 1.0.2-1 · GitLab

1 Like

Lol, I did try that too (disneyplus-bin from AUR), no luck. Useragent works well for me though. Startpage now thought I was a bot and blocked me with the above settings (wanted to switch to DuckDuckGo anyways) and the internet as a whole felt a little slow - that issue seems to have been resolved with the useragent-addon, posted by @vertisan

Edit: Works again without different useragent

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.