Discrepancy in Browsers in Windows and Garuda OS. Protected Content IDs Option Missing in all popular browsers in Garuda OS

Guys I found a discrepancy in browsers on Garuda and Windows. I tried several methods to fix it but to no avail. Tried updating components, reinstalling and even different browsers(Chrome,Firefox,Edge,Brave,Firedragon,Vivaldi) but the result was same. I'm sharing the screenshots of both browsers as it is on Windows and Garuda.

As you can see in Brave Browser in Garuda OS the whole option under "Protected IDs" is missing.

Due to this issue I'm unable to play a protected content on my device. And finally resorted to make a VM.

Looking forward to find a resolution.

Garuda Inxi:

Kernel: 6.4.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=afc55953-127d-46ea-8307-75a841da4f50 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: PRO H610M-G DDR4 (MS-7D46) v: 1.0
serial: <superuser required> UEFI: American Megatrends LLC. v: 1.B0
date: 03/23/2023
Info: model: 12th Gen Intel Core i3-12100 bits: 64 type: MT MCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 5
microcode: 0x2E
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2362 high: 3300 min/max: 800/4300 scaling:
driver: intel_pstate governor: powersave cores: 1: 3300 2: 800 3: 3300
4: 3300 5: 800 6: 3300 7: 800 8: 3300 bogomips: 52838
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-S GT1 [UHD Graphics 730] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: DP-2 empty: DP-1, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3,
HDMI-A-4, HDMI-A-5 bus-ID: 00:02.0 chip-ID: 8086:4692 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: DP-2 model: Lenovo G24-20 serial: <filter> built: 2021
res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x296mm (20.75x11.65")
diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.5 renderer: Mesa Intel UHD Graphics 730
(ADL-S GT1) direct-render: Yes
Device-1: Intel Alder Lake-S HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403
API: ALSA v: k6.4.10-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1a1d class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Lite-On Dell Wireless Device driver: hid-generic,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9.2:8
chip-ID: 04ca:00bd class-ID: 0301
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9.1:7
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.0 lmp-v: 6
status: discoverable: no pairing: no
Local Storage: total: 465.76 GiB used: 90.05 GiB (19.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Blue SN570 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234100WD temp: 45.9 C scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 90.05 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 90.05 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 90.05 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 90.05 GiB (19.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.54 GiB used: 1.24 GiB (16.4%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 48.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 287 Uptime: 2h 2m wakeups: 1 Memory: total: 8 GiB note: est.
available: 7.55 GiB used: 3.79 GiB (50.2%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1512 libs: 446 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-17
Last full system update: 2023-08-18 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

and Windows.
Sorry, we do not support it, for that you must contact the brave developer.


This issue is persistent in other browsers as well. Same issue on Firefox, Firedragon and Edge Browser.

? on Linux?
Check with Firefox, and Firedragon is a fork of Librewolf (fork of Firefox).
So here we are using software written for Linux, not Windows, and not written by Garuda.
But this does not mean that there is no solution for this.

1 Like

Yes Edge is awkward :sweat_smile: (but for sake of taking samples)

But here the screenshot on Firefox Browser as well:

(and thanks for prompt reply SGS:) )

I recommend you just chose a website that does not force enabled fingerprinting to allow video playback.

I have no clue why you'd want to enable tracking like that...


School work, so just use M$ :wink:

1 Like

Have you tried "google chrome" I am asking because a lot of websites especially government one's won't work anywhere else and you haven't listed that as a browser you tried up there and no chromium/brave does not count try google chrome.

sudo pacman -S google-chrome

Though I must say I am quite skeptical this will work since this looks most likely a drm issue and not something you can resolve. However it never hurts to try.

You can also try to launch the browser from terminal and then play the video and go through the logs in case something useful pops up or you can post those logs here in case a forum member finds something that can help.


Yeah website's requirements ...can't help it.

"Inside a VM", Probably isn't it :slightly_smiling_face:

Yeah Chrome ....I did't mention it but yes I have tried, sharing the screenshots(spoiler: It didn't work)

And yeah same issue as in Brave, Protected IDs option is missing here as well. probably because Brave too is based on Chromium. Sharing Screenshot.

But really bhai it's a very peculiar issue.

Nevertheless I've raised the issue on Brave Community waiting for their reply.

1 Like

And Thanks @SGS @UltraBlack @NaN for your Inputs. :smiling_face:

I'm curious to know if you see anything useful in the dev console when verbose is enabled, maybe there's a different error happening before it gets to the point of even trying to check for widevine. Check everything is updated in chrome://components too.

1 Like

Yup that's one of the troubleshooting tips I got online too. Have tried that both in Chrome and Brave, but to no avail.

1 Like

We have differing versions for CRLSet, I have Version: 8186. It's just cert revocations so it shouldn't impact. Hyphenation is also differing, but again shouldn't matter-I have 118.0.5956.0. Another differing (that still shouldn't matter) Optimization Hints Version: 407. One final difference is OnDeviceHeadSuggest Version: 20230805.554794387.14. No idea what that one does, maybe try to update it too, just in case?

Have you tried to pretend you're Windows? User-Agent Switcher for Chrome - Chrome Web Store

Thank you for the screenshot, I've deleted it for now as it accidentally leaked some information that should not be public.

The screenshot indicates that you are blocking some resources. Though it shouldn't be a problem, you should turn off any blockers (including custom DNS) for the sake of testing.


Thanks @Technetium, yes updated the said component as well pretended to be a windows.. as you've directed me to but to no avail.
It seems some kind of DRM issue which can be resolved only by the browser side.

1 Like

@Valiant_AJ I've pondered on this for a while. You definitely have done everything right. I don't know of a way forward without the direct involvement of those who implemented the DRM on the site. The best we can do is ask you reach out to their developers. :frowning:


Thanks @Technetium and Team Garuda for the support.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.