Discord registers itself as browser based instead of desktop client?

Hi all,
About 3 days ago discord completely broke for me, would not open whatsoever. After uninstalling betterdiscord, then uninstalling actual discord, i was able to reinstall just through pacman however now it is saying it doesn't have access to any input devices, as well as in settings it says.s

I am wondering if anyone else has had this issue, so far I have tried the version from pacman, from snap, downloading the .tar directly from the website, as well as the stable electron builds.
I have also tried adjusting file perms as well as launching discord as sudo, I am unable to find anyone else on other arch wiki's that are sharing my issues nor on any discord support tabs which is why I am starting to believe its OS specific.
My mic output from lsusb
Bus 003 Device 002: ID 0d8c:0014 C-Media Electronics, Inc. Audio Adapter (Unitek Y-247A)
Ouput from uname -r

Uhm, what? :eyes:

1 Like

got desperate, tried everything lol.

There are two parts to discord. Discord itself will run as the client, but then in addition there is a discord updater that launches via the web browser. Check your auto-start and disable the web browser and you should be all set.

May I ask where the auto-start script is located? Having an issue finding it :smile:

Ended up being a mixture of betterdiscord now being broken across all installations ++ the newest update from discord stable.

For anyone else that encounters this problem as of 3/26/21 canary is the only version running properly on the newest update.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.