Disabled the ethernet manually with network manager, after restarting it does not show up

I wanted to connect to a different router with wifi so I disconnected the ethernet with Network manager but after restarting I see Wired: cable unplugged.

I am on a laptop (legion to be exact), I looked around but couldn't fix it.

Also, the output of ip link show dev enp7s0:

2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 98:fa:9b:2d:52:11 brd ff:ff:ff:ff:ff:ff

When I try to activate the Wired connection 1 with nmtui I get `Could not activate connection: Connection 'Wired connection 1' is not availble on device enp7s0 because device has no carrier.

System:
  Kernel: 6.0.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=392bffd4-0fd1-42c4-a26e-95dc0ab8ab7b rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Cinnamon v: 5.6.1 tk: GTK v: 3.24.34 wm: muffin vt: 7 dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81SX v: Legion Y540-15IRH
    serial: <superuser required> Chassis: type: 10 v: Legion Y540-15IRH
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: BHCN45WW date: 05/24/2022
Battery:
  ID-1: BAT0 charge: 47.0 Wh (96.9%) condition: 48.5/57.0 Wh (85.1%)
    volts: 12.8 min: 11.5 model: SMP L17M3PG2 type: Li-poly serial: <filter>
    status: not charging cycles: 73
CPU:
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2896 high: 4401 min/max: 800/4500 scaling:
    driver: intel_pstate governor: performance cores: 1: 2600 2: 2600 3: 2600
    4: 2600 5: 2600 6: 2600 7: 2600 8: 2600 9: 4401 10: 4354 11: 2600 12: 2600
    bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Lenovo
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Turing code: TUxxx
    process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:2191
    class-ID: 0300
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-6:4 chip-ID: 5986:2113 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 driver: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 143 s-size: 682x191mm (26.85x7.52")
    s-diag: 708mm (27.88")
  Monitor-1: DP-2 pos: right res: 1920x1080 hz: 144 dpi: 142
    size: 344x193mm (13.54x7.6") diag: 394mm (15.53") modes: N/A
  Monitor-2: DP-3 pos: primary,left res: 1920x1080 hz: 60 dpi: 94
    size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU116 High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:1aeb
    class-ID: 0403
  Sound API: ALSA v: k6.0.9-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IF-ID-2: wg_admin state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
  Local Storage: total: 1.84 TiB used: 190.13 GiB (10.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: KBG40ZNV1T02 KIOXIA size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HP00AE00 temp: 36.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-24Z10
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A04 scheme: GPT
Partition:
  ID-1: / raw-size: 495.08 GiB size: 495.08 GiB (100.00%)
    used: 190.11 GiB (38.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 18 MiB (3.5%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-3: /home raw-size: 495.08 GiB size: 495.08 GiB (100.00%)
    used: 190.11 GiB (38.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-4: /var/log raw-size: 495.08 GiB size: 495.08 GiB (100.00%)
    used: 190.11 GiB (38.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-5: /var/tmp raw-size: 495.08 GiB size: 495.08 GiB (100.00%)
    used: 190.11 GiB (38.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4.42 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: swap-2 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 72.0 C pch: 63.0 C mobo: N/A gpu: nvidia
    temp: 56 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 340 Uptime: 2m wakeups: 1 Memory: 15.53 GiB
  used: 3.37 GiB (21.7%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1658 libs: 454 tools: paru,yay pm: pkg pkgs: 0 Shell: fish v: 3.5.1
  running-in: alacritty inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-10-06
  Last full system update: 2022-11-20
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

What was your method for disabling the ethernet?

Try restarting NetworkManager.

sudo systemctl restart NetworkManager

Edit

Just a couple other thoughts:

Do you know why you are in a partially upgraded state? For example, are you holding a package back, or similar? Or is something broken?

If your method for doing this was to take down the interface, you will have removed the default route and bringing it back up will not automatically re-establish the route.

List routes:

ip route show

If what is listed for the default gateway is the other router, you will have to delete the route.

sudo ip route del default via 192.168.xxx.xxx dev enp7s0

Then add the correct one for the ethernet gateway.

sudo ip route add default via 192.168.xxx.xxx dev enp7s0
5 Likes

Hello

I disabled the ethernet using a toggle in Network Manager, like this:
image
I had done it before and it didn't cause any problems up until ...

I tried restarting the network manager as well but it didn't work.

I have since updated the system and it is no longer partially upgraded as well.

I can't see my router with ip route show:

0.0.0.0/1 via 10.111.84.1 dev tun0
default via 192.168.1.1 dev wlp0s20f3 proto dhcp src 192.168.1.108 metric 600
10.111.84.0/23 dev tun0 proto kernel scope link src 10.111.84.6
127.0.0.1 via 192.168.1.1 dev wlp0s20f3
128.0.0.0/1 via 10.111.84.1 dev tun0
192.168.1.0/24 dev wlp0s20f3 proto kernel scope link src 192.168.1.108 metric 600
194.187.251.146 via 192.168.1.1 dev wlp0s20f3

OK... it fixed itself...

I changed the ethernet port on the router and then put the laptop to suspend and turned it on again and it works now...

Thanks :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.