Disable extra buttons on window titlebars

Hello. I've searched everywhere for this, but apparently I can't find what I'm looking for. GNOME apps (like gnome-calendar, gnome-calculator, dconf-editor etc.), have some extra buttons (other than minimize, maximize and close) on their windows' title bars, as shown in the picture below (which makes me hate GNOME for their poor decisions even more). Is there any way to disable them? I've looked into dconf settings and gnome-tweaks (even though I'm on cinnamon) with no luck. nemo seems to have the same kind of buttons as gnome-calendar, but they're not on the title bar (why would anyone want the title bar to be so thick and of inconsistent width? :unamused:).

gnome-calendar:

nemo:

I "fixed" it using Sway :wink: LOL -- "You can't double my buttons if I don't have buttons"
/trollmode off

I dont' really have a solution, all I know is that it is a known problem and it looks like it's an interaction between Gnome applications and the desktop environment, extensions and customizations in particular.

Gnome is redesigning the way things look and work (again, and again), I think the rationale behind those title bars, besides the "tablet look" and outdoing Apple, is to make use of that otherwise usually wasted horizontal space -- at the expense of vertical space, inconsistent user interfaces for years to come, and incompatibilities like this one.

It seems to me that some of the newer applications draw their own titles to be able to place extra buttons in there, while normally that is a task of the window manager, so unless the wm is aware of that, there are two title bars. But I could be wrong here, not that I really investigated much.
All I can say, in Sway there are no title bars (by default, they can be enabled) and some Gnome apps still display their own.
Another funny thing: try placing the window buttons on the left, you'll see some applications with buttons in the middle of the title bar, those with a left panel like the Gnome settings of all things.

1 Like

I experience no double title bars, is it possible what you were confused by the 2 images I put close together? (I added some spaces now)

Yep I've been confused by that. It really looked like those double bars I was talking about.

So, you'd like to have "normal" title bars without the extra buttons?
Got this link from GNOME - ArchWiki -- the first place where to look for answers about all things Arch, and possibly the best written documentation on the interwebs.
Not sure it's what you are looking for but sounds like it should.

1 Like

Yes, that's what I want to achieve. I consulted the Arch wiki before posting, but still, I don't see anything relevant. I'm not on GNOME, how could I switch to GNOME-Classic? That's gotta have something to do with muffin WM right?

I hoped some of that stuff could be applicable, and sorry for the RTFM -- how could I know.
I'm not on Gnome either, and looks like I can't be of much help so... I just sneak away :man_shrugging:

1 Like

It is because gnome applications are client-side decorated so they draw their own.

3 Likes

Hi,

first of all, you have customized themes, and they are not the default one. So I have no idea what you have modified and what not.
Nemo should look like this by default

Also, these buttons can be modified under edit>preferences>toolbar
Also, you can disable toolbar altogether in view>Main Toolbar checkbox

Wait a minute, how did you install cinnamon? On top of Gnome edition? Post your output of garuda-inxi

3 Likes

No, I'm just using the Cinnamon edition, with another theme (Nordic). I don't want to change nemo's behaviour. I want to change the behaviour of all gnome apps adding menus and buttons to title bars.

Inxi
System:
  Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=622586c4-6f82-4957-a50c-3aa9ab09c772 rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 wm: Muffin vt: 7
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 82JY v: Legion 5 17ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 17ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: GKCN46WW date: 10/01/2021
Battery:
  ID-1: BAT0 charge: 53.0 Wh (64.0%) condition: 82.8/80.0 Wh (103.5%)
    volts: 15.6 min: 15.4 model: Celxpert L20C4PC2 type: Li-poly
    serial: <filter> status: N/A cycles: 4
CPU:
  Info: model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 3248 high: 4155 min/max: 1200/3300 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3178 2: 3434
    3: 2902 4: 2702 5: 3379 6: 2905 7: 3193 8: 3802 9: 4155 10: 3997 11: 2733
    12: 2602 bogomips: 79048
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:2560 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 04f2:b6c2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: muffin driver:
    loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
    s-diag: 583mm (23")
  Monitor-1: DP-4 res: 1920x1080 hz: 144 dpi: 128
    size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
    bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: Creative Sound Blaster Play! 3 type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.1.4:9
    chip-ID: 041e:324d class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 1000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 1.43 TiB used: 52.82 GiB (3.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPMPZ-512G-1101 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21160001 temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Kingston
    model: DT microDuo 3.0 size: 28.88 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate
    model: ST1000LM 048-2E7172 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: SDM1 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Generic model: Flash Disk
    size: 29.3 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 8.01 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 75 GiB size: 75 GiB (100.00%) used: 44.14 GiB (58.8%)
    fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:6
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 28.9 MiB (11.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 75 GiB size: 75 GiB (100.00%)
    used: 44.14 GiB (58.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:6
  ID-4: /var/log raw-size: 75 GiB size: 75 GiB (100.00%)
    used: 44.14 GiB (58.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:6
  ID-5: /var/tmp raw-size: 75 GiB size: 75 GiB (100.00%)
    used: 44.14 GiB (58.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 2.8 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 389 Uptime: 14h 51m wakeups: 1 Memory: 15.54 GiB
  used: 5.92 GiB (38.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1508 lib: 343 Shell: Zsh v: 5.8
  running-in: alacritty inxi: 3.3.12
Garuda (2.5.3-1):
  System install date:     2022-01-22
  Last full system update: 2022-01-25
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

Here is how gnome-calender looks like here


And it is how it should look like by default, according to gnome. For example, see
https://wiki.gnome.org/Apps/Calendar

I guess, you should ask Gnome devs the reason for this.

Well, as @dalto said, they seem to have a mind of their own... I guess I can't change that.

Well, tbh, I like it this way, because it looks slicker this way.
Just a personnel preference though.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.