Disable asterisk on sudo command

Hello there ...

i dont like when i type sudo command the command showing any pwfeedback ...
can you tell me please how to disable it ?

I am new to garuda and not in linux that's why i dont want any asterisks

Please, follow the template, you can edit your first post.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:


Refusing to post the output of the required "garuda-inxi" on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki's, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum's search engine and on the web. For in depth information on how to search for answers to Linux issues effectively, read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.


Your profile says you joined the forum in October 2020. That makes you probably one of our least new-to-Garuda community members. :face_with_hand_over_mouth:

sudo micro /etc/sudoers.d/pwfeedback

Comment out the one line in the file.

#Defaults pwfeedback

Save and exit, it will take effect immediately.

By the way, here is the reference for this information: Sudo - ArchWiki

Enable password input feedback

By default, there is no visual feedback when you input a password. That is done on purpose for extra security. However, if you wish to have visual input, you can enable it by adding this line:

Defaults pwfeedback

Garuda Linux does not add this option directly into /etc/sudoers as mentioned in the ArchWiki article; instead, a call to the /etc/sudoers.d directory is added and the options are included as drop-in files. You will see the call at the bottom of the sudoers file:

## Read drop-in files from /etc/sudoers.d
@includedir /etc/sudoers.d

Anyway, welcome back @jemadux. Next time you post, please be mindful of the issue template as SGS mentioned.