Diffrent cpu usage readings form System Monitor and htop

Hello !

I have just installed garuda yesterday and today when trying out the widgets I found out that htop and the widget/system monitor weren't reporting the same cpu usage at all. The cpu usage from the system monitor is always way higher than the one from htop. I would more likely believe htop because my cpu usage is always idling at 5% instead of the reported 25% in system monitor.

I tried searching on the forums but I couldn't find anything mentioning that kind of issues (I'm really sorry if I missed it I just registered here).

How could I fix this issue and more importantly who do I should trust ?

Here is the output of the inxi -Faz command (and yes the cpu reported it the correct one):

inxi -Faz output

System: Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=04028740-b627-40a7-9cc2-842b1da79948
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=2209c02d-6d73-4a83-bd7c-2aae32cf692d loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine: Type: Desktop System: Gigabyte product: Z270X-Ultra Gaming v: N/A serial:
Mobo: Gigabyte model: Z270X-Ultra Gaming-CF v: x.x serial: UEFI: American Megatrends
v: F8 date: 10/27/2017
CPU: Info: Quad Core model: Intel Core i5-7600K bits: 64 type: MCP arch: Kaby Lake family: 6
model-id: 9E (158) stepping: 9 microcode: EA cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 30399
Speed: 3906 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 3906 2: 3974 3: 4211 4: 4084
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics: Device-1: Intel HD Graphics 630 vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:5912 class-ID: 0380
Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c03 class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 6400x1440 s-dpi: 93 s-size: 1746x393mm (68.7x15.5") s-diag: 1790mm (70.5")
Monitor-1: HDMI-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")
Monitor-2: DP-0 res: 2560x1440 dpi: 93 size: 697x393mm (27.4x15.5") diag: 800mm (31.5")
Monitor-3: HDMI2 res: 1920x1080 hz: 60 dpi: 163 size: 300x230mm (11.8x9.1") diag: 378mm (14.9")
OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44
direct render: Yes
Audio: Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-3: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK CMI8786 driver: snd_oxygen
v: kernel bus-ID: 0b:04.0 chip-ID: 13f6:8788 class-ID: 0401
Device-4: Focusrite-Novation Scarlett Solo (3rd Gen.) type: USB driver: snd-usb-audio
bus-ID: 1-3:2 chip-ID: 1235:8211 class-ID: 0102 serial:
Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network: Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel port: N/A
bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac:
RAID: Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus-ID: 00:17.0
chip-ID: 8086:2822 rev: class-ID: 0104
Drives: Local Storage: total: 2.95 TiB used: 100.96 GiB (3.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: P2CR033 temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDA240G size: 223.57 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: rev: 30RL scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: HM500JI size: 465.76 GiB block-size:
physical: 512 B logical: 512 B speed: 1.5 Gb/s type: N/A serial: rev: 01U4 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: rev: CC26 scheme: GPT
Partition: ID-1: / raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 100.96 GiB (22.5%) fs: btrfs
dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 580 KiB (0.2%) fs: vfat
dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 100.96 GiB (22.5%) fs: btrfs
dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 100.96 GiB (22.5%) fs: btrfs
dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 448.4 GiB size: 448.4 GiB (100.00%) used: 100.96 GiB (22.5%) fs: btrfs
dev: /dev/sdb2 maj-min: 8:18
Swap: Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.51 GiB used: 2 MiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.06 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3
maj-min: 8:19
Sensors: System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 55 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info: Processes: 250 Uptime: 19m wakeups: 1 Memory: 15.51 GiB used: 6.34 GiB (40.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2079 lib: 576
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Thanks in advance !

1 Like

htop is one thread, system monitor show use of complete CPU.

I do not search about just my thought :smiley:

2 Likes

More strangeness, when I look at the processes tab and sorting by cpu usage, all the processes cpu usage added up are very far away from the reported cpu usage usage (around 5% against almost 40% at idle). It seems very strange for me that my cpu would run at 40% usage at idle even if it's not the fastest of it kind kind but it still manages around 10% usage at idle on windows.

I'm also noticing that the usage reported in the system monitor is bouncing up and down from around 40% to 25% at sometimes it dips to 5% for a fraction of second, I have even seen it going to 90% for absolutely no reason.... The cpu fan on my pc is also not ramping out like it usually does when it's under load.

From all of that I really don't think that the system monitor is correct.

Check conky too :smiley:

2 Likes

Conky reports about 5% of cpu usage at idle

I found the culprit ! I'm sorry for bothering you ! I found out by sorting by ram usage and seeing that the baloo_file_extractor was using 4gb of memory so that ticked me off to do a little more research.
The problem seems to be that the baloo_file_extractor cpu usage is not correctly reported in htop, conky and the processes tab. So as I just installed garuda and I installed some games and software, the indexing is still not finished on my machine and that is causing the high cpu usage.

Nonetheless thanks a lot for your help !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.