Difficulty installing proprietary Nvidia driver

I'm having the same problem with an RTX 4050. Initially with an Asus laptop with AMD CPU + RTX 4050, which I bought and returned, and now with the replacement Dell laptop with Intel CPU + RTX 4050. I have tried installing a LTS kernel and that didn't help. I tried manually installing NVIDIA driver and that also didn't work. After breaking my system a couple times attempting to get it working, I now have a fresh vanilla install, and am asking for community guidance.

Does anyone have suggestions to get this working? Thanks in advance!!

In case it helps:

My dmesg output indicates this in red:
[ 1.375912] nouveau 0000:01:00.0: unknown chipset (197000a1)

and during install Garuda doesn't install the NVIDIA driver. Neofetch output that occurs from opening a terminal correctly reports the GPU:

OS: Garuda Linux x86_64
Host: Dell G15 5530
Kernel: 6.3.4-zen1-1-zen
Uptime: 9 mins
Battery: 100% [Not charging]

Packages: 1174 (pacman)[stable]
Shell: fish 3.6.1
Terminal: konsole 23.4.1

CPU: 13th Gen Intel(R) Core(TM) i7-13650HX (20) @ 4.9 GHz
GPU: Intel Raptor Lake-S UHD Graphics
GPU: NVIDIA GeForce RTX 4050 Max-Q / Mobile
Memory: 3.01 GiB / 15.31 GiB (19%)

You are using zen kernels so did you install 'nvidia-dkms' ??


@Chrisso I have moved your post to a separate topic to give it better visibility. When you have a chance please describe the issue you are experiencing with as much detail as you can, including the troubleshooting efforts you have attempted so far.

Please post the output of garuda-inxi to the thread as text, with three tildes (~) before and after the output to format as a code block.


Thank you both for the quick responses. I installed nvidia-dkms per @RodneyCK 's suggestion and that resolved my issue. In prior generation laptops Garuda automatically installed the Nvidia drivers, so I guess I got used to being spoiled :slight_smile:
Many thanks for the quick resolution, I really appreciate it.

For posterity, here is the garuda-inxi output, from after installing nvidia-dkms:

Kernel: 6.3.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=28ac71eb-5937-4572-a772-61991b310e49 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: Dell G15 5530 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0K793X v: A00 serial: <superuser required> UEFI: Dell
v: 1.3.0 date: 03/15/2023
ID-1: BAT0 charge: 80.3 Wh (95.3%) condition: 84.3/84.3 Wh (100.0%)
volts: 12.3 min: 11.4 model: BYD DELL M59JH31 type: Li-poly serial: <filter>
status: discharging cycles: 1
Info: model: 13th Gen Intel Core i7-13650HX bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
microcode: 0x113
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1893 high: 2800 min/max: 800/4700:4900:3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 1100 2: 1032 3: 1064
4: 2800 5: 996 6: 2800 7: 1079 8: 2150 9: 1098 10: 2800 11: 923 12: 2800
13: 1100 14: 1036 15: 1100 16: 2800 17: 2800 18: 2800 19: 2800 20: 2800
bogomips: 112127
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Raptor Lake-S UHD Graphics vendor: Dell driver: i915
v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+ ports:
active: eDP-1 empty: DP-1 bus-ID: 0000:00:02.0 chip-ID: 8086:a78b
class-ID: 0300
Device-2: NVIDIA AD107M [GeForce RTX 4050 Max-Q / Mobile]
vendor: Dell GN21-X2 driver: nvidia v: 530.41.03
alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022-23+ bus-ID: 0000:01:00.0
chip-ID: 10de:28e1 class-ID: 0300
Device-3: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2
chip-ID: 1bcf:2b9d class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x0a41 built: 2021 res: 1920x1080
hz: 165 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.0 renderer: Mesa Intel Graphics (RPL-S)
direct-render: Yes
Device-1: Intel vendor: Dell driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:7a50 class-ID: 0401
Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1
chip-ID: 10de:22be class-ID: 0403
API: ALSA v: k6.3.4-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 0000:00:14.3
chip-ID: 8086:7a70 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 0000:02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:3 chip-ID: 8087:0026
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Local Storage: total: 476.94 GiB used: 10.94 GiB (2.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: CL4-3D512-Q11 NVMe SSSTC 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 25301111 temp: 64.8 C
scheme: GPT
ID-1: / raw-size: 226.17 GiB size: 226.17 GiB (100.00%)
used: 10.82 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
used: 119.1 MiB (40.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 226.17 GiB size: 226.17 GiB (100.00%)
used: 10.82 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /var/log raw-size: 226.17 GiB size: 226.17 GiB (100.00%)
used: 10.82 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-5: /var/tmp raw-size: 226.17 GiB size: 226.17 GiB (100.00%)
used: 10.82 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.31 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 64.0 C mobo: N/A sodimm: SODIMM C
Fan Speeds (RPM): cpu: 539
Processes: 347 Uptime: 7m wakeups: 8284 Memory: available: 15.31 GiB
used: 2.97 GiB (19.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1180
libs: 329 tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-27
Last full system update: 2023-05-27
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.