Desktop Scrolling Graphical bug

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

System:
Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9aac4a86-99cd-452a-99b6-5f70bfd7565d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: All Series v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: H81-PLUS v: Rev X.0x serial: <superuser required>
BIOS: American Megatrends v: 1001 date: 02/21/2014
CPU:
Info: model: Intel Core i3-4130T bits: 64 type: MT MCP arch: Haswell
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2900 high: 2901 min/max: 800/2900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2900 2: 2900 3: 2901
4: 2901 bogomips: 23199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 4th Generation Core Processor Family Integrated Graphics
vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:041e
class-ID: 0380
Device-2: NVIDIA GK107 [GeForce GTX 650] vendor: ASUSTeK GTX650-DC-1GD5
driver: nvidia v: 470.94 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
chip-ID: 10de:0fc6 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3244x1014 s-dpi: 89 s-size: 925x296mm (36.4x11.7")
s-diag: 971mm (38.2")
Monitor-1: VGA-0 res: 1440x900 dpi: 89 size: 410x260mm (16.1x10.2")
diag: 485mm (19.1")
Monitor-2: HDMI-0 res: 1804x1014 hz: 60 dpi: 286
size: 160x90mm (6.3x3.5") diag: 184mm (7.2")
OpenGL: renderer: NVIDIA GeForce GTX 650/PCIe/SSE2 v: 4.6.0 NVIDIA 470.94
direct render: Yes
Audio:
Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
class-ID: 0403
Device-2: NVIDIA GK107 HDMI Audio vendor: ASUSTeK GTX650-DC-1GD5
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e1b
class-ID: 0403
Device-3: HP OMEN Mindframe Prime type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:2 chip-ID: 03f0:3241
class-ID: 0300
Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK H81M-C driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.2 TiB used: 32.74 GiB (2.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-00BN5A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Samsung model: HM321HX
size: 298.09 GiB block-size: physical: 512 B logical: 512 B type: HDD
rpm: 5400 serial: <filter> scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 442.73 GiB size: 442.73 GiB (100.00%)
used: 32.74 GiB (7.4%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
ID-2: /home raw-size: 442.73 GiB size: 442.73 GiB (100.00%)
used: 32.74 GiB (7.4%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
ID-3: /var/log raw-size: 442.73 GiB size: 442.73 GiB (100.00%)
used: 32.74 GiB (7.4%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
ID-4: /var/tmp raw-size: 442.73 GiB size: 442.73 GiB (100.00%)
used: 32.74 GiB (7.4%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.63 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 35 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 10%
Info:
Processes: 223 Uptime: 15m wakeups: 0 Memory: 7.63 GiB
used: 3.27 GiB (42.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1724 lib: 515 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-02-03
Last full system update: 2022-02-04
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Hello.
I am new to Garuda Linux, i got pretty familiar with it and everything works without any major problem.
Sadly, when i was changing my graphical settings in nvidia-settings (Resolution changes, second screen had overscan) and rebooted, the desktop scrolls?
When i move my mouse to the bottom of the screen, the whole screen scrolls. Never seen anything like this before. I tried capturing it to give you a better idea whta it looks like, but the screen capture doesn't see it. So i had to use my phone to record it.

Reapplying the settings in nvidia-settings fixes it, but its really annoying to reapply it after every boot.

Does anyone have any idea why or how is this caused?

That looks like a panning virtual desktop space rather than a proper graphical bug, as to why it got enabled unexpectedly, sorry no idea.

I remember seeing that feature somewhere but can't remember where.

Potentially useful links:

KDE multi display XRANDR problems. / Applications & Desktop Environments / Arch Linux Forums

https://www.reddit.com/r/linuxquestions/comments/4c2o4p/what_does_panning_and_fb_in_xrandr_stand_for/

Big Screen - KDE Store .

P.S. Welcome.

2 Likes

Ok so, looked at the links and sadly i didnt find anything that worked.
But meanwhile, i found out that the nvidia-settings resolution parameters change whenever going into fullscreen mode on e.c. Minecraft (Firedragon, Discord and Terminal dont cause it to go haywire)
Tried manually removing the panning values, which worked. But as said above it re-enables it after the screen "refresh" and the panning is back.
(Seriously who the hell thought of this feature)

Not really sure as I'm no expert here, but something to look into in no particular order:

driver: nvidia v: 470.94 alternate: nouveau,nvidia_drm bus-ID: 01:00.0

The nvidia driver, it is often reported as causing trouble.
If you can get decent performance and no troubles with nouveau it is probably adviseable.

[...] and Terminal dont cause it to go haywire

Good catch, looks like games cause the trouble but "normal" applications do not.
Games obviously do fancy stuff with the display that other applications don't need to, including changing the resolution. They generally take over the display for performance reasons.

removing the panning values

Better report where exactly you removed them from to avoid misunderstandings.
Also, what is your normal screen resolution, and see if you can determine what resolution the game runs under. Perhaps something goes out of sync on the switch back.

who the hell thought of this feature

LOL... someone with a small display or a high resolution poster-sized image I guess :man_shrugging:

Sadly, I'm no expert and I'm not on KDE nor X11, so I'm afraid my little help ends here.

1 Like

What exactly am i supposed to do with this thingamagig?

From the nvidia-settings GUI (sudo nvidia-settings), X Server Display Configuration, Advanced... , Panning.

HDMI-0 = 1920x1080 (Underscanned to 1808x1017)
VGA-0 = 1440x900 (Native)

Tried fresh install of Garuda Dragonized, didnt mess with anything just the nvidia settings (Set the underscan of the HDMI display) and the panning came back. So i guess its safe to assume the driver is trolling a bit. Tho i dont see the panning values change anymore in the GUi, which i find odd.


No worries, thanks for the help nontheless. If you come up with anything (literally ANYTHING that could potentionally fix this) i'll be glad.

I'd say, leave the thingamagig alone for now and look into the underscanning thing first.

BTW

:slight_smile:

1 Like

So after some painstaking tests and trying out stuff, i gave up and changed to a different display that didnt need the overscan setting. Not the best solution but at least something. :c

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.