Desktop is empty with no dock or hotbar

Yeah okay i am able to access apps using Alt+F2, but I have no dock or hotbar, this most likely happened after I updated my apps and then restarted my computer like I was asked to.


My Desktop


inxi -Fxxxa

System: Host: Hakai Kernel: 5.11.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1c66e6c9-d4c5-4043-a709-e6ee2d6bd028 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine: Type: Laptop System: Sony product: SVF1531GSAB v: C10J5E30 serial: Chassis: type: 10
serial:
Mobo: Sony model: VAIO serial: UEFI-[Legacy]: Insyde v: R1100DB date: 01/26/2016
CPU: Info: Dual Core model: Intel Core i7-4500U bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 45 (69)
stepping: 1 microcode: 26 cache: L2: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19156
Speed: 2336 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 2336 2: 1816 3: 1796 4: 1796
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel Haswell-ULT Integrated Graphics vendor: Sony driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0a16 class-ID: 0300
Device-2: NVIDIA GK208M [GeForce GT 740M] vendor: Sony driver: nouveau v: kernel bus-ID: 04:00.0 chip-ID: 10de:1292
class-ID: 0302
Device-3: Chicony Front Camera type: USB driver: uvcvideo bus-ID: 2-5:3 chip-ID: 04f2:b3aa class-ID: 0e02
serial: 0001
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel,nouveau unloaded: modesetting
alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 21.0.1 compat-v: 3.0 direct render: Yes
Audio: Device-1: Intel Haswell-ULT HD Audio vendor: Sony driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:0a0c class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Sony driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
class-ID: 0403
Sound Server-1: ALSA v: k5.11.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.25 running: no
Network: Device-1: Broadcom BCM43142 802.11b/g/n vendor: Foxconn driver: wl v: kernel port: 5040 bus-ID: 02:00.0
chip-ID: 14e4:4365 class-ID: 0280
IF: wlp2s0 state: up mac: 0c:84:dc:fd:05:e9
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Sony driver: r8169 v: kernel port: 4000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: 78:84:3c:3b:a9:8e
Bluetooth: Device-1: Foxconn / Hon Hai BCM43142A0 type: USB driver: btusb v: 0.8 bus-ID: 2-4:2 chip-ID: 0489:e062
class-ID: fe01 serial: 0C84DCFD05EA
Report: ID: hci0 state: up address: 0C:84:DC:FD:05:EA
Drives: Local Storage: total: 465.76 GiB used: 25.93 GiB (5.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500325ASG size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: 5VEWSP5H rev: APM1 scheme: MBR
Partition: ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 25.93 GiB (5.6%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 25.93 GiB (5.6%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 25.93 GiB (5.6%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 25.93 GiB (5.6%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
Swap: Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 2.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 2.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 2.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 2.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors: System Temperatures: cpu: 46.0 C mobo: N/A gpu: nouveau temp: 42.0 C
Fan Speeds (RPM): N/A
Info: Processes: 213 Uptime: 9m wakeups: 1 Memory: 11.59 GiB used: 2.85 GiB (24.6%) Init: systemd v: 248 tool: systemctl
Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1437 lib: 360 Shell: fish v: 3.2.1 running-in: konsole
inxi: 3.3.03

I can right click on my desktop.

1 Like

Have you tried rolling back the update with a timeshift snapshot?

3 Likes

Yeah but my desktop was the same

1 Like

Have you tried stopping and restarting plasma.

You haven't given us enough information about what you did to cause this. Was it a system update or you're own tinkering.

3 Likes

Try starting latte manually, using Alt + F2

3 Likes

It was a batch update using the Add/Remove software.

And i did do killplasmashell in the command terminal, and restarted it but that didn't do anything

Latte is running, i also reinstalled the app with some of its supporting software

Its latte providing top & dock so either your latte config is completely messed up or latte not running properly :eyes:

2 Likes

I figured, Any idea how do i make sure latte is working properly. ( tho its clear something went wrong, not by my tinkering tho)

1 Like
Latte App

not sure if this image helps but its more info... Oh right i at one point my OpenGl crashed when my dock went missing. I restarted it but then nothing happened

First make sure the config exists by doing cat ~/.config/latte/Dr460nized.layout.latte
If it looks alright, latte-dock --replace and look for eventual errors.

3 Likes
Output of cat ~/.config

File: /home/ridha/.config/latte/Dr460nized.layout.latte
[LayoutSettings]
backgroundStyle=0
color=blue
customBackground=
customTextColor=
icon=
lastUsedActivity=e3caaa1c-c1d3-49ca-850b-388c83cfa2ca
launchers=
preferredForShortcutsTouched=false
version=2

Yup, broken layout. Get the correct one from /etc/skel/.config/latte/Dr460nized.layout.latte (how ever this happened)

4 Likes

I got no clue how that happened, i never tamper with these things. I only update apps when i am asked to.

There is nothing which ever touches this file (or the home directory) so this is quite mysterious :face_with_raised_eyebrow:

3 Likes

I really am sorry for all the trouble I cause, Thanks for helping me.

You guys are awesome :star:

Stay safe and be well,Thank You :smiley:

3 Likes

Just a suggestion, learn to use pacman for system updates.

Glad it's fixed. :+1:

3 Likes

Okay ,Ill check it out :+1:

2 Likes

For your info -

https://wiki.archlinux.org/index.php/Pacman/Rosetta

4 Likes

I have experienced the exact same issue. luckily it was my previous laptop. after an update blank desktop. I have time-shifted working backup and after -Syu and reboot broken desktop again. since then I have formatted the disk.

1 Like