Desktop has changed since a forced shutdown of laptop

Hello.

inxi -Faz
System:    Kernel: 5.14.8-203-tkg-bmq x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=737b71e3-4f9f-406e-b2df-14e416d5ee93 rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=2fb70f7a-7849-408c-9472-b1fbc976ee62 
           loglevel=3 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20UNS02400 v: ThinkPad X1 Nano Gen 1 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20UNS02400 v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N2TET66W (1.44 ) date: 06/24/2021 
Battery:   ID-1: BAT0 charge: 35.3 Wh (71.5%) condition: 49.4/48.3 Wh (102.4%) volts: 12.8 min: 11.6 model: SMP 5B10W13963 
           type: Li-poly serial: <filter> status: Charging cycles: 2 
CPU:       Info: Quad Core model: 11th Gen Intel Core i7-1160G7 bits: 64 type: MT MCP arch: Tiger Lake family: 6 
           model-id: 8C (140) stepping: 1 microcode: 88 cache: L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33826 
           Speed: 3465 MHz min/max: 400/4400 MHz Core speeds (MHz): 1: 3465 2: 2190 3: 3522 4: 3226 5: 623 6: 607 7: 1030 
           8: 979 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a40 class-ID: 0300 
           Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo bus-ID: 3-4:3 chip-ID: 13d3:5411 class-ID: fe01 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 4080x1350 s-dpi: 96 s-size: 1078x357mm (42.4x14.1") s-diag: 1136mm (44.7") 
           Monitor-1: eDP1 res: 2160x1350 hz: 60 dpi: 196 size: 280x170mm (11.0x6.7") diag: 328mm (12.9") 
           Monitor-2: DP2 res: 1920x1080 hz: 60 dpi: 42 size: 1150x650mm (45.3x25.6") diag: 1321mm (52") 
           OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.2 direct render: Yes 
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo driver: sof-audio-pci-intel-tgl 
           alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.8-203-tkg-bmq running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.37 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000 bus-ID: 00:14.3 chip-ID: 8086:a0f0 
           class-ID: 0280 
           IF: wlp0s20f3 state: up mac: <filter> 
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter> 
Drives:    Local Storage: total: 593.47 GiB used: 50.2 GiB (8.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPMPZ-512G-1001 size: 476.94 GiB 
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 21160001 
           temp: 58.9 C scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Ultra size: 116.53 GiB block-size: physical: 512 B 
           logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw-size: 459.74 GiB size: 459.74 GiB (100.00%) used: 50.2 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 459.74 GiB size: 459.74 GiB (100.00%) used: 50.2 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 459.74 GiB size: 459.74 GiB (100.00%) used: 50.2 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-5: /var/tmp raw-size: 459.74 GiB size: 459.74 GiB (100.00%) used: 50.2 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100) 
           ID-1: swap-1 type: partition size: 16.9 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 
           ID-2: swap-2 type: zram size: 15.35 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 5033 fan-1: 
Info:      Processes: 300 Uptime: 13m wakeups: 784 Memory: 15.36 GiB used: 5.81 GiB (37.8%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1982 lib: 569 flatpak: 0 Shell: Zsh v: 5.8 
           running-in: konsole inxi: 3.3.06

I did a force shutdown (using the power button) of my Thinkpad running Garuda due to Slack spawning numerous Firefox tabs and then subsequently Slack instances (looping) when authenticating one of my accounts.

When I logged back in, my desktop is markedly different (fewer icons in he bottom launcher, no top bar any longer, different wallpaper,...essentially like a different account.

I am also getting some KGPG prompts when I log back in as well (asking for Kwallet setup)

Wondering if there is some way to get back the previous setup.

Hello,

I am no expert but I can suggest some things.

You can change the wallpaper easily.

You can get back the top bar easily by going to Latte, removing the present layout, then selecting New > Dr460nized. A new layout will be created, you have to switch to that one.

If you don't need KDE wallet you can disable it in Settings > KDE Wallet.

And you can easily add icons to your bottom launcher.

Thank you @somebody

Manual restoration could be last resort.

I was wondering what might cause the issue in the first place and if there was a way to 'reinitialize' the desktop to what it was previously?

Like, did some config/file get deleted or overwritten?

1 Like

Try

7 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.