Desktop doesn't work properly after updating kernel

@ExistingDude
I tried, but it doesn't improve black-bg problem. I will check ghost-window issue later.

@filo
How can I check it? "Enable compositor" in Display and Monitor settings is already checked.

So it is ok, otherwise there would be an error message.
Maybe you could restore the latest snapshot and update again. Just in case something went wrong...
Or maybe you could try reinstalling your Nvidia drivers.

It sounds pretty stupid to re-install an operating system because of a perceived kernel problem without first trying a few other kernels, right?

5 Likes

@filo
I have updated system again and again. So I guess the wrong setting has already persisted. But I will try, thanks.

@c00ter
Maybe you are right. But I prefer remaining on linux-zen because I had some other serious troubles from changing to other kernels before. The issue of this time looks easier then the previous ones. How interesting and exciting using linux is haha.

Garuda comes with a timeshift rollback feature precisely for these types of issues. Simply roll your system back to your pre-update state.

If that doesn't fix things it's a user configuration setting in your home directory causing your issues.

If the issue is corrected with timeshift, then wait a week before trying another update to see if the problem has been resolved. Reinstalling should always be a last resort.

6 Likes

@ExistingDude
Ghost window problem isn't solved even after changing the setting you mentioned.

@tbg
You are right. This is gonna be a very good lesson for me.

So, was it solved with a timeshift restore? If so, please mark it as such.
If not, in the meanwhile, a somewhat similar KDE issue (only a black background there) could be solved creating a new user (timeshift does not backup/restore home configs).
It would be very quick to test it, if you want...

4 Likes

I don't have the timeshift in which everything works correctly any more. It has gone. I left the problem a bit long. This is my fault.

Creating a new user seems to fix the issue. Sometime, while I repeat rebooting as an experiment and for reset system settings, one display randomly shows the same symptom of black background. That monitor is another one from before. But mostly it works.

I'll see whether the problems will happen again or not for a few days. Thanks!

Oh, the new user doesn't have neofetch. So I installed it but it shows old logo, maybe.

How can I bring the new logo from the old user setting? I prefer this.

You really want to waste the valuable time of Garuda staff, forum staff, and people that have other, real problems? Really? Did you do a forum search?

1 Like

Did you try resetting config in Garuda Assistant

1 Like

@c00ter
Sorry for irritating you. Yes I did search forum and couldn't find the direct answer. I didn't think this was intended phenomenon that a new user doesn't have neofetch. If this is a disturbing minor problem, I didn't know that. Sorry, Just leave it.

@SameExpert
Yes and nothing changed.

OK, this is a good lesson. I'll use timeshift function more often.

The latter picture is the output of paleofetch not neofetch, which I think is the default.
Try editing config.fish as follows (ie substituing neofetch with paleofetch in the line before end)

3 Likes

I have the same problem after a recent kernel update. I dont think its related to any settings or multiple monitors. (I run a single monitor and didnt tinker with any settings before or after the update) . just as the gif shows, the windows cannot be selected or closed but when you click on them the click is parsed to the desktop.

I'm going to try and downgrade the kernel (if possible), if I do so do I need to downgrade the kernel headers as well ?

When you file a help request, the proper method is to tell us what you've researched and found, what you've tried and not tried, what the results were, output, journal files, inxi etc., etc.

You waste the valuable time of every developer, team member, or forum helper that responds when you fail to do so.

Those posters who do not follow some semblance of the above are considered Help Vampires.

3 Likes

Help Vampires :laughing:

3 Likes

Thanks for the link @Rickyboobie. It's also kosher to let'em Google the term. MUAHAHAHA! :wink:
:smiley:

2 Likes

Thank you! Terminal shows the default logo again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.