Default applications for icons gone after power cut

I had a power cut today while my system was on
when i turned on my pc launching an application from my desktop caused the "open with" dialog to pop up
all the icons properties show "File type video/x-sgi-movie"
i tried creating new icons but they have the same issue

Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5853f345-c275-46ac-84e0-5de4868e2b5e rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1 dm: N/A
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME B450M-A II v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2409
date: 12/02/2020
Info: model: AMD Ryzen 5 3500 bits: 64 type: MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
desc: 2x8 MiB
Speed (MHz): avg: 3598 high: 3600 min/max: 2200/4120 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3600 2: 3600
3: 3600 4: 3593 5: 3600 6: 3600 bogomips: 43116
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 09:00.0 chip-ID: 1002:699f
class-ID: 0300 temp: 45.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: LG (GoldStar) FULL HD
serial: <filter> built: 2016 res: 1920x1080 hz: 75 dpi: 102 gamma: 1.2
size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.2 renderer: AMD Radeon RX 550 / 550 Series
(polaris12 LLVM 15.0.7 DRM 3.52 6.3.9-zen1-1-zen) direct-render: Yes
Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 8 bus-ID: 09:00.1 chip-ID: 1002:aae0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-1:2 chip-ID: 0c76:1694 class-ID: 0300
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 08:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Local Storage: total: 465.76 GiB used: 189.1 GiB (40.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 2B4QFXO7 temp: 37.9 C
scheme: GPT
ID-1: / raw-size: 349.78 GiB size: 349.78 GiB (100.00%)
used: 189.07 GiB (54.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25 MiB (26.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /home raw-size: 349.78 GiB size: 349.78 GiB (100.00%)
used: 189.07 GiB (54.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 349.78 GiB size: 349.78 GiB (100.00%)
used: 189.07 GiB (54.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 349.78 GiB size: 349.78 GiB (100.00%)
used: 189.07 GiB (54.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 50.5 C mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1057
Processes: 312 Uptime: 26m wakeups: 0 Memory: available: 15.53 GiB
used: 5.86 GiB (37.8%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 1644 pm: dpkg
pkgs: 0 pm: pacman pkgs: 1633 libs: 418 tools: octopi,paru pm: flatpak
pkgs: 11 Shell: fish v: 3.6.1 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2022-10-31
Last full system update: 2023-06-25
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Power loss can cause corruption in the filesystem. Hopefully the default apps thing is the worst of your issues.

Try restoring a Btrfs snapshot from before the system went down. If that doesn't resolve the issue with the default apps, try deleting or moving mimeapps.list file.

mv ~/.config/mimeapps.list ~/.config/mimeapps.list.bak

Then log out/log back in and test again.


I have already tried restoring to an old snapshot and and deleting mimeapp.list then logging out and in, and restarting didnt work

Too bad. :slightly_frowning_face:

Try creating a new user, then log in as them and try launching one of the problematic shortcuts.


uh oh that does not sound good. Btrfs likes to break beyond repair if it fails to sync some changes from a power cut, hard crash or something like that that… (I recommend always having an actual backup at hand)

Please try sudo btrfs check --force /dev/nvme0n1p5 and post what it returns

Icons work for new user


Opening filesystem to check...
WARNING: filesystem mounted, continuing because of --force
Checking filesystem on /dev/nvme0n1p5
UUID: 5853f345-c275-46ac-84e0-5de4868e2b5e
[1/7] checking root items
[2/7] checking extents
[3/7] checking free space tree
[4/7] checking fs roots
[5/7] checking only csums items (without verifying data)
[6/7] checking root refs
[7/7] checking quota groups skipped (not enabled on this FS)
found 193473171456 bytes used, no error found
total csum bytes: 178380880
total tree bytes: 1500987392
total fs tree bytes: 1163100160
total extent tree bytes: 113065984
btree space waste bytes: 288471720
file data blocks allocated: 309747662848
referenced 248325386240

Btrfs likes to break beyond repair if it fails to sync some changes from a power cut, hard crash

not sure what you mean by this
the backup i used was from 4 days ago

the backup i used was from 4 days ago

snapshots are not backups. Snapshots will corrupt if btrfs has an issue

You are in luck that btrfs is seemingly alright.

all the icons properties show “File type video/x-sgi-movie”

Maybe KDE has a custom filetype configuration tool that ignores mimeapps.list? Check the settings (or the default icon option, located where you can change individual file icons), just in case

1 Like

what should i add here?

konsole open when running a .desktop file and shows this error

This is both good and bad.

Good: this suggests the root filesystem may be fine.

Bad: troubleshooting corrupt user profiles is not easy or fun.

Often user-related issues are tucked away in the ~/ directory somewhere, buried in the dotfiles. A common troubleshooting tactic is the bisection method: rsync half the directories from the home directory of the bad profile to the home directory of the good one and retest. If everything is fine, rsync another half. Once you copy over a chuck that is bad, start bisecting that chunk and try to isolate where the problematic files are.

Another option is to just copy over the files you need to the new user profile, and if they are fine just “start over” with the new user becoming your main user. Optionally, delete the old user, re-create it, and move stuff back if you wish.


I finally managed to narrow the problem down to ~/.local/share/mime/ but i cant figure out which specific file is causing this. Do you any ideas that can make this quicker?

Deleting the ~/.local/share/mime/ was causing weird problems but now it works

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.