Davinici-Resolve makes issues again

Hello Fello Linux users,

I have issue with the davinci resolve package on aur. I tried to manually write the PCKGUILD file so it would download the newer version but that didn’t work (i only changed minor version form 0 to 3 which is not enough i had to learn). I now updated my system but not davinci resolve which has resulted in it completly stooping to work. And the biggest issue is that the maintainer is right no working on the package from what i know

is there a way how i could reinstall the old version of the package with the binarys already existing on my system ?

Welcome :slight_smile:

You use the correct Unsupported Software (AUR & Other) category, but we need always the garuda-inxi, like the template ask for. Please add it.

Maybe it is possible with downgrade

sudo downgrade <app name>

i tried your advice and now i have a new error
error: ‘/var/cache/pacman/pkg/davinci-resolve-18.1.4-1.1-x86_64.pkg.tar.zst’: invalid or corrupted package (PGP signature)

Did you have more than one version to choose from in downgrade?
I don’t use this app so I can’t say much about it.

yeah trhee i tried two both with the same error. Probably something wrong with my keyrings

update remote keyring

sorry for being a bit slow
i did what you recomended and now downgrade is unable to downgrade davinci-resolve

Hi @ANDO , actually i got a solution that is temp for now if you don’t have time to solve the issue , it does work for me when i encounter any brain melting issue with Davinci so far ,
The solution is to remove it completely from your system , yes (and anything related to it) and reinstall it ,

So Install Resolve from AUR:

mkdir ./Davinci_Resolve && cd Davinci_Resolve
wget https://aur.archlinux.org/cgit/aur.git/snapshot/davinci-resolve.tar.gz
tar –xvzf davinci-resolve.tar.gz
cd davinci-resolve

Then After makepkg you will see :


==> Making package: davinci-resolve 17.4.2-1 (Sunday, December 19, 2021 PM05:45:28)
==> Checking runtime dependencies...
==> Missing dependencies:

anything after Missing dependencies like

==> Missing dependencies:
  -> libpng12
  -> lib32-libpng12
  -> ocl-icd
  -> openssl-1.0
  -> opencl-driver
  -> qt5-websockets

install it using :

sudo pacman -S The name of packages 
sudo pacman -S libpng12 lib32-libpng12 ocl-icd openssl-1.0 opencl-driver qt5-websockets

Then makepkg again ,and every thing should be fine .

if any issue appeared please share it and share this command :


more info about DaVinci resolve can be found in Arch DaVinci wiki

1 Like

i would normaly do something similar but curently the davinci package is broken so ther is now way to install davinci via aur. I tried tinkering with the PKGBUILD but to no sucess. THe error exists cause the package is stil for version 18.6.0 but currently 18.6.2 is out

the way to “fix” this is to figure out the referid. which point to the right url on the blackmagic site. But i don’t know how to do that

So i now simply installed it manually via the file from the official site. And probably will do it this way in the future.
Still thanks for the tips :slightly_smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.