Davinci Resolve unable to see menus

Hello, I'm new to Garuda Linux, been loving it. I finally managed to install Davinci Resolve today, but had problems using it.

Btw, turns out on this Thinkpad L13 Lenovo, to make DR (Davinci Resolve) work, you need to get Intel Compute Runtime driver for OpenCL by running pacman -S intel-compute-runtime, just in case someone else experiences the same issue (for intel graphics).

So after installing, and running it, I realized that the options in the menus weren't showing up on Latte dock in the window menu, or global menu. How do I get it to show menu options? I tried looking for a setting in DR, but didn't find any.

Also another problem, is that if i make the window smaller, the window border does not show up, and the DR window doesn't drag, so it's stuck there forever. Is there a way to force the window borders to show?

I guess while I'm here, one final question related to latte dock: is it possible to get the window menus instead of on latte dock on all time, when not maximized, have them appear on the window border instead of staying up on latte dock? I feel it's missed real -state on the window borders (right next to the window buttons), and it's slightly nagging me, although not such a big issue.

garuda-inxi:

System:
Kernel: 5.18.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2886e1d2-1f51-401c-9a54-77b069ecd400 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: LENOVO product: 20R5A000US v: ThinkPad L13 Yoga
serial: <superuser required> Chassis: type: 31 serial: <superuser required>
Mobo: LENOVO model: 20R5A000US v: SDK0J40700 WIN
serial: <superuser required> UEFI: LENOVO v: R15ET47W (1.28 )
date: 01/12/2021
Battery:
ID-1: BAT0 charge: 35.2 Wh (74.6%) condition: 47.2/46.0 Wh (102.7%)
volts: 16.3 min: 15.4 model: SMP 5B10W13933 type: Li-poly serial: <filter>
status: not charging cycles: 57
CPU:
Info: model: Intel Core i5-10210U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
stepping: 0xC (12) microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1623 high: 1700 min/max: 400/4200 scaling:
driver: intel_pstate governor: powersave cores: 1: 1583 2: 1545 3: 1600
4: 1600 5: 1600 6: 1661 7: 1700 8: 1700 bogomips: 33599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 13d3:56a6 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x05ea built: 2018 res: 1920x1080
hz: 60 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5") diag: 337mm (13.3")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.0
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:02c8 class-ID: 0403
Sound Server-1: ALSA v: k5.18.1-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 16.0 running: no
Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d4f class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 238.47 GiB used: 61.7 GiB (25.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB256HBHQ-000L7 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 5M2QEXH7 temp: 43.9 C scheme: GPT
Partition:
ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 61.7 GiB (25.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 61.7 GiB (25.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 61.7 GiB (25.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 61.7 GiB (25.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.35 GiB used: 2.18 GiB (29.6%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 73.0 C pch: 66.0 C mobo: 1.0 C
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
Processes: 319 Uptime: 24m wakeups: 57735 Memory: 7.35 GiB
used: 5.58 GiB (75.9%) Init: systemd v: 251 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 2089 lib: 572 Shell: fish
v: 3.4.1 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
System install date:     2022-05-28
Last full system update: 2022-06-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:      nope
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

Hi there, welcome!
Try opening Latte configuration and unflag "support borderless maximized windows...".
Then right click on the top panel and remove the applet window-appmenu.
Probably a logoff/logon will be necessary.
I don't know about DR, but maybe this will help...

PS:

This means you updated but not yet rebooted.
Please do so before everything.

4 Likes

I tried what you told me, although the menu problem still persists. Also turns out that if I drag off of the window title on latte, it drags the window, so I guess the DR window not dragging isn't an issue.

Try to give a look at this one:
https://wiki.archlinux.org/title/DaVinci_Resolve#Application_window_misses_title_bar

2 Likes

I use those start parameters:

killall latte-dock &&  progl /opt/resolve/bin/resolve %u & sleep 30 && latte-dock --replace &

the progl option is for using AMD pro drivers. If you are using an nvidia gpu you don't need it.
The rest of this code is literally killing latte until DaVinci Resolve has gotten started up and/or 30sec.
Those 30 secs are important b/c just being on the project page doesn't help you with the software. If you need more time on that project site feel free to use a larger interval than 30 Secs :slight_smile:

Have fun

3 Likes

I'm assuming (newbie here) that the start parameters are for editing the com.blackmagicdesign.resolve.desktop file, which I tried, but still no luck with the menus not showing. I then tried quitting latte manually, starting davinci, and then restarting latte, but also no luck. I also tried to see if it would work with a normal dock and the global menu, but also no luck. The menu items still don't show no matter what.

1 Like

Yep, those starting parameters are for the desktop link file for DaVinci Resolve.
It is this file:


Befehl means command btw.

It works out like that:

I'm not sure what's causing your issue, since I don't had that big of a problem with Resolve. :thinking:

Huh, I guess something must be going on weirdly with my install, or could be DR 18. Here's what I see, the top options menus are missing. This was done with also the fix you had of modifying startup commands.

Oh btw the weird window thing going on was because of filo's solution for the drag fix, that's not much of an issue anyway since apparently you can move windows by dragging off the top bar of latte, and doesn't change the menu problem.

1 Like

Both suggestions I gave can be easily rolled back.
E.g. you can add borderless windows and the window-appmenu
Or if you stay as is, you should remove also the window buttons widget. Otherwise there buttons appear twice (on the panel for the widget and on the window because not borderless)

3 Likes

I still have Resolve 17 Studio. It could be that Resolve 18 might make those issues. I can't say for sure but it is in fact a major difference. :thinking:

Hmmm, so I tried installing DR 17, still same problem, menus not showing up. This one is definitely puzzling me. I guess I'll keep looking for a solution, if anyone has any other potential clues or can point me in the right direction that would be great, or else I guess I'm gonna go ask on the Blackmagic forums.

1 Like

Ok, that's strange. :thinking: :thinking: :thinking:

I just tried again, after all the updates for today and it works for me. (on DR17 tho).
Have you tried @filo's suggestion?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.