Davinci Resolve, Is my discrete AMD GPU being used in Linux?

Today I installed davinci-resolve from chaotic-aur.
But it keep on giving me errors:
image

I even tried changing the configuretions:

I even tried changing my AMD driver used to amdgpu by following this: drivers - How to switch radeon to amdgpu - Ask Ubuntu

Is this the correct method?
......................................................................................................................................................................

 ╰─λ inxi -Faz

System:    Kernel: 5.13.11-3-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule root=UUID=e665afea-6249-46e2-a56a-9037924055c3 rw 
           [email protected] cgroup_enable=memory swapaccount=1 quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 radeon.cik_support=0 amdgpu.cik_support=1 
           radeon.si_support=0 amdgpu.si_support=1 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.14.1 date: 05/06/2021 
Battery:   ID-1: BAT0 charge: 14.4 Wh (72.7%) condition: 19.8/41.4 Wh (47.8%) volts: 17.1 min: 14.8 model: SMP DELL VN3N047 
           type: Li-ion serial: <filter> status: Charging 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6 
           model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
           Speed: 2376 MHz min/max: 400/2500 MHz Core speeds (MHz): 1: 2376 2: 2466 3: 2476 4: 2405 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5916 
           class-ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Dell driver: amdgpu 
           v: kernel alternate: radeon bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380 
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:5769 class-ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati,intel unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.11-3-cacule running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: e000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
           bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-8:5 chip-ID: 0cf3:e009 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 113.78 GiB (12.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 3D scheme: GPT 
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 25.22 GiB (25.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 51.9 MiB (5.1%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 8.33 GiB (8.3%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 
           ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 25.22 GiB (25.2%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 25.22 GiB (25.2%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 11.44 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
           ID-2: swap-2 type: partition size: 6 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7 maj-min: 8:7 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 50.0 C 
           Fan Speeds (RPM): cpu: 2572 
Info:      Processes: 275 Uptime: 17m wakeups: 1 Memory: 11.44 GiB used: 2.57 GiB (22.5%) Init: systemd v: 249 tool: systemctl 
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1528 pacman: 1509 lib: 389 flatpak: 9 snap: 10 Shell: fish v: 3.3.1 
           default: Zsh v: 5.8 running-in: konsole inxi: 3.3.06 


I also installed opencl-amd

 ╰─λ glxinfo | grep "OpenGL renderer"
     DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2)
OpenGL renderer string: AMD Radeon (TM) R5 M330 (HAINAN, DRM 3.41.0, 5.13.11-3-cacule, LLVM 12.0.1)

I am a complete noob as to the hardware aspect of linux.
I some might take time to respond, thank you for you patience. :upside_down_face:
Sorry to mention, davinci-resolve worked in Windows :grimacing:

Thank You

\Support Center | Blackmagic Design

But I installed it from chaotic-aur only.
And this is Garuda linux's hardware aspect of issuse, not exactly related to Resolve

So I think it is resonable to ask here.

You could try using optimus manager.
Set it to boot or switch to amdgpu
Then start resolve.
There is cli for this but not sure what it is for amd

Does it work for AMD?

optimus-manager -h
usage: optimus-manager [-h] [-v] [--status] [--print-mode] [--print-next-mode] [--print-startup] [--switch MODE] [--temp-config PATH] [--unset-temp-config]
                       [--no-confirm] [--cleanup]

Client program for optimus-manager. https://github.com/Askannz/optimus-manager

optional arguments:
  -h, --help           show this help message and exit
  -v, --version        Print version and exit.
  --status             Print current status of optimus-manager
  --print-mode         Print the GPU mode that your current desktop session is running on.
  --print-next-mode    Print the GPU mode that will be used the next time you log into your session.
  --print-startup      Print the GPU mode that will be used on startup.
  --switch MODE        Set the GPU mode to MODE. You need to log out then log in to apply the change.Possible modes : integrated, nvidia, hybrid, intel (deprecated,
                       equivalent to integrated)
  --temp-config PATH   Set a path to a temporary configuration file to use for the next reboot ONLY. Useful for testing power switching configurations without ending
                       up with an unbootable setup.
  --unset-temp-config  Undo --temp-config (unset temp config path)
  --no-confirm         Do not ask for confirmation and skip all warnings when switching GPUs.
  --cleanup            Remove auto-generated configuration files left over by the daemon.

Thank you

Good point there is setting for it but that properly is to set from amd igpu to nvidia ?
you could try this

DRI_PRIME=1 /opt/resolve/bin/resolve
1 Like

What about launching with prime-run /opt/resolve/bin/resolve ?

3 Likes

https://wiki.archlinux.org/title/DaVinci_Resolve
See table of supported drivers. (in works with davinci section)
And
https://wiki.archlinux.org/title/AMDGPU_PRO

4 Likes

Tried this but it showed the same error

It means that amdgpu driver is the issue.
Thanks, I will check the others out and report here.

The whole day I tried, but
now matter what I try Davinci resolve won't run,
Any help would be appreciated.
Its seems that opencl-amd is not doing its work.

There is an aspect that is not clear to me, but I'm not expert on these things, so ignore my comment and don't spend time on it if it doesn't make sense :slight_smile:
According to the second table in DaVinci Resolve - ArchWiki, you need opencl-amd for sure, but looking at the first table, don't you need also AMDGPU-PRO instead of AMDGPU, i.e. amdgpu-pro-libgl ?

1 Like

May be I should update my progress.
I have install these packages:

  1. amdgpu-pro-libgl
  2. opencl-amd
  3. vulkan-amdgpu-pro
  4. xf86-video-amdgpu
  5. vulkan-radeon
  6. Davinci Resolve 17.2

and I am now running amdgpu driver

and I creates this file:

/etc/X11/xorg.conf.d/20-amdgpu.conf
Section "Device"
     Identifier "AMD"
     Driver "amdgpu"
EndSection

I took help from :
https://wiki.archlinux.org/title/AMDGPU
https://wiki.archlinux.org/title/DaVinci_Resolve
https://wiki.archlinux.org/title/AMDGPU_PRO

Still not working.

[EDIT:]

I also have the issue that after some time after boot, I get:

 ╰─λ glxinfo | grep "OpenGL renderer"
            DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2)
OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2)

But initially just after boot I get:

╰─λ glxinfo | grep "OpenGL renderer"
     DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2)
OpenGL renderer string: AMD Radeon (TM) R5 M330 (HAINAN, DRM 3.41.0, 5.13.11-3-cacule, LLVM 12.0.1)

This is only the case with amdgpu driver, radeon driver does't behave like that.
After amdgpu goes to sleep, Davinci resolve launches a new project with my integrated intel driver.
Whereas it doesn't happen when amdgpu driver is awake.
And also opencl-amd also doesn't shows up in this list:

image

I also tried uninstalling opencl-mesa.
(The one in the list is opencl-mesa one, which doen't work and gives this error:

Can we conclude anything from here, or is there any scope of running it?
I came across this:

Troubleshooting

Intel + AMD hybrid graphics

Currently (as of version 19.30) there is a problem when using the AMDGPU Pro OpenGL driver alongside with an Intel GPU. It is a common configuration for laptops, but also applies to desktop users in case you set your Intel GPU as primary. When you boot your machine, you will get a black screen, but with your mouse cursor moving normally. If you have a suggestion, please edit this Wiki page. Reverse PRIME could probably be a solution, but PRIME#Reverse PRIME lacks this information.

If you are affected, please upvote this bug report.

I have also posted at Davinci Resolve Reddit: https://www.reddit.com/r/davinciresolve/comments/pbzoyv/does_anyone_know_how_to_install_davinci_resolve/hafe0sx/?context=3

I got this reply:

Even back to DVR 15, integrated graphic was not recommended
https://documents.blackmagicdesign.com/ConfigGuides/DaVinci_Resolve_15_Mac_Configuration_Guide.pdf(page 42)

so you are unlikely to have a good experience if you do get it working.


Also, do be aware of the codec limitations of Resolve in Linux. H.264/265 is only supported in the paid version. AAC audio is not supported at all. So expect to need to transcode anything from a consumer camera with FFmpeg.


The only distro officially supported is Centos 7. So other distros can be a challenge. Though they are plenty of people running it on Ubuntu.


Hopefully, someone running Arch can step in and point to the setup guide they used.
  • I uninstalled Resolve and I am happy with Kdenlive!
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.