Date and time incorrect in waybar

Hi there, I just installed Garuda Hyprland and I am very much enjoying it. However I’ve noticed in the status bar (towards the top right) the time is incorrect. After checking Garuda settings as well as typing “Date” in terminal the correct time in fact does show just not in the status bar. Any help is appreciated thanks!

Is there a reason you asked for help but did not post the required terminal output of garuda-inxi?

5 Likes

Check your waybar configs ~/.config/waybar/config

Goto somewhere around line 55 or 60 ,
see if the clock module is set like this :

    "clock": {
        "tooltip-format": "<big>{:%A, %d.%B %Y }</big>\n<tt><small>{calendar}</small></tt>",
        "format": " {:%a %d %b  %I:%M %p}",	//12 hour format
        //"format": " {:%a %d %b  %H:%M}",	//24 hour format
        "format-alt": " {:%d/%m/%Y  %H:%M:%S}",
        //"max-length": 200
        "interval": 1,
        "on-click": "~/.config/waybar/scripts/OCV",
    },

or not ?
also with garuda-inxi I would like to know the full name of ISO through which you installed it . :slightly_smiling_face:

3 Likes

You’re probably using the Official Webiste ISO like me. This ISO comes with German timezone set in the waybar (top bar) config.

  1. Open Thunar.
  2. Make sure you enable ‘show hidden files’ (ctrl+h).
  3. Go to .config/waybar/config find ‘clock’.
  4. There in ‘timezones’ just remove the one written there (most probably its Europe/Berlin) and put in your timezone.
weather

Do the same steps for weather (last 4-5 lines of config)
Add your city name ahead of wttr.in in the link.

If this helps, don’t forget the garuda-inxi next time :rofl:

Hi there, thanks for the help. I swear I had put the output. I must’ve erased it by mistake when I corrected my typos. I’ll double check next time. Thanks again and sorry for the lack of info!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.