Data recovery and File system corrections

Hello Garuda users,

Recently I can't mount my vfat formatted partition in hard drive.

Currently the issue has been resolved I'm asking this question just to know wheather any bootable os write in the boot sector of hard drive without user permission !

I connected a hard drive from a laptop, and tried to boot the windows 10 and while booting I got text on screen saying checking disks... After that I copied wanted stuffs to desktop hard drive and removed the drive and rebooted.

The dolphin file manager in linux not able to mount desktop hard drive. I tested on KDE partition manager it's showing the space is unallocated without a file system in my desktop hard drive.

I was pissed off at that point. Luckily with testdisk I recovered some important files.

After that I tried to repair file system using

$ sudo fsck -P /dev/sdX

and it showed some prompt to fix the file system and after that continued with Y and then I was able to mount the hard drive.

I want to know whether the windows written some non-sence to my hard drive and made the file system corrupt.

It didn't touched ext4 and btrfs file system on my SSD.

Ask on a Windows forum. This is just one of the dangers associated with dual-booting.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.