Dark Reader extension installed but not working

I have updated to the latest firedragon 101.0.1

Dark Reader plugin is not working properly anymore. When you click on the dark reader icon at the top left. It show as "loading please wait". When I got to any page it is white instead of black. I really miss this.

Garuda-Inxi
System:
  Kernel: 5.18.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=00b33177-335b-466d-8a5b-e5bad5669f19 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
  Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: Micro-Star product: GL65 9SE v: REV:1.0
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Micro-Star model: MS-16U5 v: REV:1.0 serial: <filter>
    UEFI: American Megatrends v: E16U5IMS.102 date: 03/17/2020
Battery:
  ID-1: BAT1 charge: 24.5 Wh (61.6%) condition: 39.8/51.6 Wh (77.2%)
    volts: 11.1 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: N/A
CPU:
  Info: model: Intel Core i7-9750H socket: BGA1440 (U3E1) note: check
    bits: 64 type: MT MCP arch: Coffee Lake gen: core 9 built: 2018
    process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1314 high: 1800 min/max: 800/4500 base/boost: 2475/8300
    scaling: driver: intel_pstate governor: powersave volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 1800 2: 1800 3: 1800 4: 1633 5: 1144 6: 800
    7: 800 8: 800 9: 800 10: 800 11: 1800 12: 1800 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:3e9b
    class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Turing process: TSMC 12nm
    built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: none empty: DP-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1f11 class-ID: 0300
  Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5
    chip-ID: 04f2:b695 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0xd0ed built: 2019 res: 1920x1080
    hz: 120 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.7-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8168 v: 8.050.03-NAPI modules: r8169 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
Drives:
  Local Storage: total: 1.38 TiB lvm-free: 1.51 GiB used: 580.11 GiB (41.2%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN520 SDAPNUW-512G-1032 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
    serial: <filter> rev: 20140000 temp: 44.9 C scheme: GPT
  SMART: yes health: PASSED on: 234d 7h cycles: 3,832
    read-units: 43,801,208 [22.4 TB] written-units: 38,222,495 [19.5 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10JPVX-60JC3T0 family: Blue Mobile size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: HDD
    rpm: 5400 serial: <filter> rev: 1A01 temp: 32 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 1y 344d 4h cycles: 7679
    Old-Age: g-sense error rate: 337 write error rate: 100 threshold: 100
Partition:
  ID-1: / raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
    used: 88.2 GiB (60.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%)
    used: 557 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
    used: 88.2 GiB (60.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
    used: 88.2 GiB (60.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
    used: 88.2 GiB (60.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.47 GiB used: 322.2 MiB (2.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 47.0 C pch: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 364 Uptime: 1d 5h 29m wakeups: 5 Memory: 15.47 GiB
  used: 3.93 GiB (25.4%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1909
  lib: 544 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.19
Garuda (2.6.4-2):
  System install date:     2022-01-25
  Last full system update: 2022-06-29
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            pacman-files.service

When you go into the extension from the Add-ons and Themes menu of FireDragon and you click MANAGE on Dark Reader through the 3-dots menu, do you see this version?

Version 4.9.52
Last Updated June 28, 2022

I got the same on

Version
4.9.48
Last Updated
July 1, 2022

Strange :slight_smile:

My dark reader shows version 4.9.52

Did you try reinstalling the plugin? I can't reproduce this locally :confused:

I uninstalled via
pacman -Rns librewolf-extension-dark-reader

I then tried to install
librewolf-extension-dark-reader and community/firefox-dark-reader

These two after install no longer even show up in the extensions of firedragon even after restarting the browser. I then downloaded the extension file from firefox extensions and installed manually. The extension now shows in the about:addons, however I still have the same results as in the beginning.

I ran a new vm with a fresh install. Firedragon and dark-reader are working wonderfully on there. I have also noticed a few nsfw sites have had audio broken, while chromium is working wonderfully. In the vm all sites are also working. So is there a way to export my stuff in firedragon, and then delete all firedragon related things and reinstall from scratch? Which folders/files should i be looking for?

Are you looking at migrating your Firedragon profile folder (located in your Home folder) from the VM to the physical machine?

If yes I can be of assistance, I've done that for test purposes back in May, quite easy.

What puzzles me in your post is

If you export your profile from the VM to the physical machine and then reinstall from scratch on the physical machine, you could lose your exported profile. Not sure though.

In that case I'd suggest to remove Firedragon, delete your profile (physical machine), reinstall Firedragon AND THEN migrate your VM's profile to your physical machine. Maybe that's what you meant.

That is a better plan! I am very interested.

Ok, bare with me cuz I have to list all the steps, nothing complicated but a bunch of small steps to follow mostly in order.

There are a couple ways to do that, depending if your installation uses symlinks in ~/.firedragon or not. I'll try to keep simple.

Disclaimer: I assume you have a way to copy files from your VM to your physical machine. If not, that's a different step we would need to look into.

  1. On your physical machine, plz take backups of your firedragon folder in ~/.firedragon. If you have symlinks in there (folders), plz backup the content (files) somewhere. May not matter much though since your physical installation is not working well anyway.
  2. garuda-update # This will update your system to make sure you have all latest packages and you can issue without issue the command in 5. below
  3. paru -R firedragon # I don't think it's necessary to remove more than the core package
  4. Delete everything in ~/.firedragon (again I assume you took backups if worth it to you)
  5. Assuming your system is updated, paru -S firedragon
  6. Now things could get a bit trickier due to the symlinks, if your installation has any. At this point I'd ask you to post ls ~/.firedragon from both the VM and physical machine so I can get a better view of what folders and symlinks you got.

Basically the idea is to then delete what you got in the profile folder of your physical machine and copy the files from the VM's profile into it.
You could probably also copy the Profile the folder from VM to physical and launch the profile with firedragon -P in terminal, then choosing MAKE DEFAULT so it remembers it. I can't remember however if firedragon will detect the new profile, but like I said there are other ways to go around this as I've done it twice recently so I'm not that worried about it.

That's the plan but if you have symlinks the files are located elsewhere and we have to take that into account.

1 Like