Custom Cursors don't work under certain conditions

When using the Sweet cursor, which is the default, it works everywhere. I've installed the LyraR cursor, and I noticed that when near a dock (eg. Latte, Conky), on Title Bars and also Java applications (eg. Minecraft) the cursor changes to the Adwaita theme. Any help?

garuda-inxi here:

System:
Kernel: 5.16.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=952017aa-dcff-42ae-8a0e-d05399391137 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME A520M-A v: Rev X.0x
serial: <superuser required> BIOS: American Megatrends v: 1804
date: 02/01/2021
CPU:
Info: model: AMD Ryzen 7 PRO 4750G with Radeon Graphics bits: 64
type: MT MCP arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600106
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 3084 high: 3839 min/max: 1400/4454 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3238 2: 2994
3: 2982 4: 2989 5: 2993 6: 3148 7: 2994 8: 2994 9: 2994 10: 2992 11: 2995
12: 3305 13: 3839 14: 2922 15: 2974 16: 2994 bogomips: 114980
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 07:00.0 chip-ID: 1002:1636
class-ID: 0300
Device-2: Microdia Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-7:3 chip-ID: 0c45:64ab class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 mapped: HDMI-A-1 model: Philips PHL 243V7
serial: <filter> built: 2020 res: 1920x1080 dpi: 93 gamma: 1.2
size: 527x296mm (20.7x11.7") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.13-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK PRIME B450M-A
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.16.13-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-2: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtl88x2bu
bus-ID: 5-1:2 chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
IF: wlp7s0f4u1 state: up mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-3:2 chip-ID: 0a12:0001 class-ID: e001
Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
bt-v: 2.1 lmp-v: 4.0 sub-v: 22bb hci-v: 4.0 rev: 22bb
Info: acl-mtu: 310:10 sco-mtu: 64:8 link-policy: rswitch hold sniff park
link-mode: peripheral accept
service-classes: rendering, capturing, object transfer, audio, telephony
Drives:
Local Storage: total: 1.13 TiB used: 339.31 GiB (29.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Patriot model: Burst size: 223.57 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 61.3 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD110
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A8R0
scheme: MBR
Partition:
ID-1: / raw-size: 214.77 GiB size: 214.77 GiB (100.00%)
used: 56.41 GiB (26.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 214.77 GiB size: 214.77 GiB (100.00%)
used: 56.41 GiB (26.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 214.77 GiB size: 214.77 GiB (100.00%)
used: 56.41 GiB (26.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 214.77 GiB size: 214.77 GiB (100.00%)
used: 56.41 GiB (26.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 20.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 436 Uptime: 38m wakeups: 0 Memory: 15 GiB used: 5.38 GiB (35.9%)
Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
Packages: pacman: 1812 lib: 519 Shell: fish v: 3.3.1 default: Bash
v: 5.1.16 running-in: yakuake inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2022-02-20
Last full system update: 2022-03-12
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Timeshift
Failed units:            shadow.service

Hi there, welcome.
Maybe check if this helps.
I haven't checked in details, but it looked a similar problem at a quick glance.

PS: you can please include your inxi between
~~~
text
~~~

2 Likes

I read that article, but I got confused :sweat_smile: , what do I have to do?
Edit: I synced the SDDM settings with my Plasma Settings, but on the login screen the Adwaita cursor is shown and again it's not fixed on the other condition I mentioned

Can you see that theme in settings / appearence?
Maybe give a look also here.
Sorry, I'm not at home so cannot check or try on the system...

1 Like

The cursor theme yeah, only under the "Cursors" Appearance menu. I also checked Kvantum to see if there was anything there, but no. Also, the cursor is from a different theme pack from my application style etc.

For your user account configuration, check and apply these instructions. You may probably need to log out and in to be sure if the changed settings are applied.

For SDDM go with this.

6 Likes

OMG it worked thank you so much!!!!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.