Cursor: sometimes it's normal and sometimes it's adwaita

Here is my garuda-inxi:

[[email protected] ~]$ garuda-inxi
System:
  Kernel: 5.15.74-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=10eff176-0f05-40d0-8036-ea2504cc29cc rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: SAMSUNG product: QX310/QX410/QX510/SF310/SF410/SF510
    v: 05MX serial: <superuser required> Chassis: type: 9
    serial: <superuser required>
  Mobo: SAMSUNG model: QX310/QX410/QX510/SF310/SF410/SF510 v: 05MX
    serial: <superuser required> BIOS: American Megatrends
    v: 05MX.M008.20110525.SCY date: 05/25/2011
Battery:
  ID-1: BAT1 charge: 33.7 Wh (82.0%) condition: 41.1/61.0 Wh (67.3%)
    volts: 11.5 min: 11.1 model: SAMSUNG Electronics type: Li-ion serial: N/A
    status: discharging
CPU:
  Info: model: Intel Core i5 M 480 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 level: v2 built: 2010-11 process: Intel 32nm family: 6
    model-id: 0x25 (37) stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2103 high: 2373 min/max: 1199/2667 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 1997 2: 2373
    3: 2009 4: 2035 bogomips: 21279
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Core Processor Integrated Graphics vendor: Samsung Co
    driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010
    ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0046 class-ID: 0300
  Device-2: NVIDIA GT218M [GeForce 310M] vendor: Samsung Co driver: nouveau
    v: kernel non-free: series: 340.xx status: legacy (EOL) last:
    release: 340.108 kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm
    built: 2006-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports: active: none
    off: VGA-2 empty: none bus-ID: 01:00.0 chip-ID: 10de:0a70 class-ID: 0302
    temp: 66.0 C
  Device-3: Silicon Motion WebCam SCB-0370N type: USB driver: uvcvideo
    bus-ID: 1-1.4:3 chip-ID: 2232:1001 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting,nouveau alternate: fbdev,intel,nv,vesa
    dri: crocus,nouveau gpu: i915,nouveau display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 pos: primary model: Seiko Epson 0x3355 built: 2010
    res: 1366x768 hz: 60 dpi: 118 gamma: 1.2 size: 293x165mm (11.54x6.5")
    diag: 336mm (13.2") ratio: 16:9 modes: 1366x768
  Monitor-2: VGA-2 mapped: VGA-1-2 note: disabled size-res: N/A modes:
    max: 1024x768 min: 640x480
  OpenGL: renderer: Mesa Intel HD Graphics (ILK) v: 2.1 Mesa 22.2.1
    direct render: Yes
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    vendor: Samsung Co driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:3b56 class-ID: 0403
  Device-2: NVIDIA High Definition Audio vendor: Samsung Co
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0be3 class-ID: 0403
  Sound API: ALSA v: k5.15.74-1-lts running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter vendor: Askey
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 14e4:4727 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Marvell Yukon Optima 88E8059 [PCIe Gigabit Ethernet with AVB]
    vendor: Samsung Co driver: sky2 v: 1.30 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: b000 bus-ID: 03:00.0 chip-ID: 11ab:4381 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
Drives:
  Local Storage: total: 232.89 GiB used: 73.86 GiB (31.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 750 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: MBR
Partition:
  ID-1: / raw-size: 169.41 GiB size: 169.41 GiB (100.00%) used: 73.86 GiB
    (43.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 169.41 GiB size: 169.41 GiB (100.00%) used: 73.86
    GiB (43.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 169.41 GiB size: 169.41 GiB (100.00%) used: 73.86
    GiB (43.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 169.41 GiB size: 169.41 GiB (100.00%) used: 73.86
    GiB (43.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.62 GiB used: 234 MiB (6.3%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 71.0 C mobo: N/A gpu: nouveau temp: 66.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 245 Uptime: 17m wakeups: 1 Memory: 3.63 GiB used: 2.13 GiB
  (58.9%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1378 libs: 357
  tools: pamac,paru,yay Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-10-17
  Last full system update: 2022-10-19 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:       

I have a problem: my mouse cursor (the "hand" one) (chicago95) is "strange" in some apps, and working in some other apps.
In some apps it's the other one, but on other ones it's adwaita...
the apps where it shows adwaita are: spotify, opera, chrome
Video example:

(https://streamable.com/0zv9iu) i did it this way cause I can't embed videos

I don't know if you can understand my english, and that's because I am italian.
But if you have any english-related corrections, tell me.

Hi there, welcome to the forum!
Maybe try to give a look at this article (sections 2.1 and 2.3.3, I think):
https://wiki.archlinux.org/title/Cursor_themes#Configuration

2 Likes

Yes! This worked!
Thank you!
(or maybe I can say you GRAZIE since you're Italian...!)

1 Like

Prego...!!! :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.